6 Replies Latest reply: May 16, 2013 3:06 PM by ravs78
444zim444 Level 1 Level 1 (0 points)

So, I have an app (X-Assist) that I want to have start at startup every time, so I set that in my Login Items. But every time I login I get the message "downloaded from an unidentified developer, something something" as Gatekeeper does.

I cannot get this app to open without that warning. I have tried Control+Open and I have tried setting the security to allow applications from anywhere, yet it will still bring up this warning at startup.

Anyone know how to disable it? I have been using X-Assist for years without issue and don't want to stop.

Thanks in advance.

  • 1. Re: gatekeeper settings
    hpr3 Level 5 Level 5 (5,710 points)

    The only way I know of would be to set GateKeeper to allow applications to download from "anywhere".

  • 2. Re: gatekeeper settings
    thomas_r. Level 7 Level 7 (27,945 points)

    After opening it successfully once, using control-click and choosing Open or some other method, you should never see that message again. The fact that you are means that the quarantine metadata (which is the foundation of Gatekeeper) is not being cleared appropriately. Have you tried opening it once from an admin user account? If not, do that first.

     

    If that has been tried and doesn't work, try repairing permissions, then try again.

     

    If that still doesn't fix it, you can clear that quarantine flag manually by opening the Terminal and entering the following command (but do not press return yet):

     

    xattr -d com.apple.quarantine

     

    Make sure there is a space at the end of that. Next, find the app in the Finder and drag and drop it onto the Terminal window. That will insert the path to the app. Now switch back to the Terminal and press return. When the command prompt reappears, you can repeat for other apps or quit the Terminal, and the warning should not be displayed any further for those apps.

     

    If there is an error saying "permission denied," you don't have permission to change that item, which must be the core of the problem. Try repeating the command with a "sudo" at the beginning (ie, "sudo xattr -d com.apple.quarantine /path/to/app"). When asked for your password, type it and press return, and note that it's normal for nothing to appear on the screen while you type.

  • 3. Re: gatekeeper settings
    444zim444 Level 1 Level 1 (0 points)

    Thank you! Rebuilding permissions worked.

  • 4. Re: gatekeeper settings
    thomas_r. Level 7 Level 7 (27,945 points)

    Glad to hear it!

  • 5. Re: gatekeeper settings
    ravs78 Level 1 Level 1 (0 points)

    Hi!

    How do I repair permissions ?

     

    Cheers,

     

    -- rafael

  • 6. Re: gatekeeper settings
    ravs78 Level 1 Level 1 (0 points)

    I found it already

     

    Sorry for the question. !