Skip navigation

A NEW TRACKPAD DRIVER IS OUT

340026 Views 975 Replies Latest reply: Apr 16, 2014 12:20 PM by V-l-a-d-i-m-i-r RSS
  • nmiceli Calculating status...
    Currently Being Moderated
    Sep 4, 2012 3:12 PM (in response to V-l-a-d-i-m-i-r)

    Thank you so much for this!

  • ajp_anton Calculating status...
    Currently Being Moderated
    Sep 5, 2012 5:25 AM (in response to V-l-a-d-i-m-i-r)

    Does the new version give anything for Win7 users on an old non-pro Macbook?

     

    Another weird behavior: when clicking using 2 fingers for a right-click (sometimes double-finger tapping is hard with slippery fingers when they're dry or cold), it seems to add a left click to the mix. Or something else weird.

     

    Example 1: click on text somewhere on a webpage. Don't move the cursor, wait a few seconds, and double-finger click again in the same spot. It will select the word under the cursor (as if you double-clicked it) and then right-click the selected word.

    Example 2: double-finger click on an URL. You will both right-click and left-click the link. The new page will load, and on top of it you will get the right-click menu.

     

     

    I'll donate as soon as I can afford more than $1. Hoping that my features will be added soon =).

  • timdyang Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 6, 2012 7:09 AM (in response to V-l-a-d-i-m-i-r)

    Does anyone else get an unhandled exception on a standard user account?

     

    I haven't seen this error mentioned, except by thefa last year (https://discussions.apple.com/message/13280437#13280437). I get the same behavior where it seems to work on the admin account, but fails when I use my daily standard account.

     

    I'm using Win7 Pro 64-bit on a MBP Retina. I tried reinstalling the TP++ module, but it still gives the same error.

  • timdyang Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 6, 2012 11:39 AM (in response to V-l-a-d-i-m-i-r)

    Great, thanks for the quick update.

  • seb101 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Sep 6, 2012 3:11 PM (in response to V-l-a-d-i-m-i-r)

    Hey Vladimir,

     

    I'm having real problems with the beta.  I'm running Win 8 64bit Release Preview on the latest MacBook Air - I have no VMs anywhere, just a Mac Partition and a Win Partition, completely seperate.

     

    I have installed the Power Plan Assistant and verified it can turn off the backlight keys.  Then I install the Trackpad 2.3 beta and go through the installation process, when I get to driver installation it gives me the 'Red Banner' warning twice and I tell it to install the driver anyway - it then reboots automatically.

     

    When Windows comes back up, I have no mouse control at all I can use the keyboard to navigate around and on the desktop there is an error saying that the control module cannot communicate with the Trackpad++ driver. The only way to get mouse control back is to use the keyboard to navigate into the Control Panel and delete the Trackpad++ driver.

     

    In the Device Manager there is an error on the Trackpad++ driver, saying that the digital signature cannot be verified. 

     

    I have attempted 3 times now, completely uninstalling Trackpad, Power Plan Assistant and re-installing them, but every time it comes out the same

     

    Any ideas?  Are there some log files I can send you to help you?

  • pratnala Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 7, 2012 12:04 AM (in response to V-l-a-d-i-m-i-r)

    But Vladimir, how to install Windows 8 on a Mac? Do the Windows 7 Bootcamp drivers work?

  • ajp_anton Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 7, 2012 2:57 AM (in response to V-l-a-d-i-m-i-r)

    Well, 3 works for me. I hold two fingers on the pad for a while to make sure it doesn't register as a right-click. Then I press the button while holding these fingers.

    It will register as a right-click immediately as the button is pressed (not released), but the problem is that in certain situations (the ones I mentioned above) it will also register as a left-click at the same time, except it behaves a bit weird (the select-word example).

    However, now I see that this "bug" also exists with the Bootcamp drivers... Maybe if you implement this feature in your drivers, it will overwrite the Bootcamp behavior? =)

  • pratnala Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 7, 2012 7:47 AM (in response to V-l-a-d-i-m-i-r)

    Mine is 4.0.4255. How to upgrade to 4326?

  • Wajubalo Calculating status...
    Currently Being Moderated
    Sep 7, 2012 7:27 PM (in response to V-l-a-d-i-m-i-r)

    Hi man,

     

    Running Windows 8 Pro - RTM. I'm having these problems and can't get TP++ to work: 

     

    Right clicking and running as admin for everything.

     

    1. After installing powerplan the my desktop now has "Test Mode, Windows 8 Pro Build 9200" in the bottom right hand corner of the desktop.

     

    2. After I install powerplan I go ahead and install trackpad++. However after I click "finish" it closes down and says it failed. No auto-restart.

     

    So that's it. Thanks for your efforts, hope you can find away to solve these issues I'm having. Happy to donate.

     

    Cheers

1 ... 20 21 22 23 24 ... 66 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (11)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.