Skip navigation

AirPlay mirroring is broken on 5ghz Wireless band

9476 Views 14 Replies Latest reply: Oct 24, 2013 12:51 PM by muratjr RSS
DanielCeleste Level 1 Level 1 (0 points)
Currently Being Moderated
Jan 2, 2012 6:55 PM

I got a new, simultaneous dual band N router. When the Appe tv (2gen) is on the 2.4ghz band, AirPlay mirroring works fine no matter which band my iPad 2, but when it is on the 5ghz band it is behind by up to 5 minutes. (I enable it, then see a screenshot on my tv literally five minutes after I disable it) It basically doesn't work. My router is a linksys E2500. Thanks!

iPad 2, iOS 5.0.1
  • grinny11 Level 1 Level 1 (0 points)

    I have the exact same problem with the exact same router. It is so weird.

     

    Do you know how to fix it?

  • tjjohnsto Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 19, 2012 10:22 AM (in response to grinny11)

    From what I've seen this is a known issue with most Linksys e series devices. It happens when putting both iPad and AppleTV2 on the 5Ghz band.

     

    From what I've been seeing, there is a fix on the way but nothing as of today 2/19/12

     

    http://homecommunity.cisco.com/t5/Wireless-Routers/E4200-with-Airplay-mirroring- hangs/td-p/456851

     

    Your workaround is going to be put one device on 2.4Ghz and one on 5Ghz or both on 2.4. It will work then but is noticibly laggy especially if you have several G devices on your 2.4.

     

    Let's hope this gets fixed soon.

  • Jon Rossen Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 14, 2012 4:57 PM (in response to tjjohnsto)

    I'm having this same problem with a Cisco E3200 dual band N router.  Airplay mirroring will not work on the 5GHz band.  Luckily it is working with 2.4Ghz, meaning that at least Airplay mirroring isn't completely broken.

     

    Sorry, if I'm overlooking something but I'm not following one of your workarounds, specifically the part about having one device on 2.4GHz and the other on 5GHz.  It is my understanding that the devices have to be on the same wireless network.....or is that incorrect on my part?  My setup is that I have two wireless networks created; one is 2.4GHz, the other 5GHz.  My experience is that when trying to do mirroring with the devices on different networks there is no chance at all at connecting, so in other words you can't even expect to get to the condition where 5GHz will fail.  OR is my understanding of this being clouded by the issue with 5GHz?

     

    I see the link to the Cisco site discussion area has a potential fix with regards to a tweak to the router; I may give that a try later and then try to see if I can get 5Ghz to work.

  • tjjohnsto Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 14, 2012 5:15 PM (in response to Jon Rossen)

    My understanding is that there is an issue in the way Cisco designed WMM and QoS on these routers. Wi-Fi Multimedia (WMM) is a wireless Quality of Service feature that improves quality for audio, video, and voice applications by prioritizing wireless traffic.

     

    If you turn of WMM on these routers the 5GHz band stops working completely. 5GHz needs this to operate correctly. I believe this is where the issue comes into play. Something goes terribly wrong when both the iPad and Apple TV are on the 5GHz band and WMM screws something up with traffic passing between the devices.

     

    So the work around I currently use is:

     

    iPad (ver 1 and 2) on 2.4GHz

    Apple TV on 5GHz

     

    Everything works as expected with this implementation. Also, I have noticed that it is not only Airplay Mirroring that is affected, but everything when you are sending Pandora, Youtube, etc to the apple tv with both devices on 5GHz.

     

    Let me know if that helps, I would also encourage you to read the forum comments as some others have work arounds that may help you as well. I have an E2500 and the same issue exists but the work around others used does not exist for my model. It may on yours.

     

    http://homecommunity.cisco.com/t5/Wireless-Routers/E4200-with-Airplay-mirroring- hangs/td-p/456851

  • Steven Howard1 Level 1 Level 1 (15 points)

    Macbook Air 2011 (4,1), MountainLion,

     

    I have Linksys E2500 dual band and the Apple TV 3rd gen at an apartment and have the same problem; all on 5GHz does not work.   Had Atv on 5GHz and had to put Macbook Air on 2.4 and all is well.   I ended up using a cable since the Apple TV is colocated with the router so no real issue here until it is solved.

     

    Also, before I went with the cable my iPad2 worked fine with mirroring with all devices on 5GHz band. 

     

     

    However, an interesting point, at home I have an Linksys E3000 dual band and the second gen AppleTV and I can mirror just fine with everything on the 5GHz band.

     

    So does this mean it is the Atv gen 3 problem? 

  • SylHan Level 1 Level 1 (0 points)

    I've the same problem with my Macbook (late 2009) and iPad 2 and Apple TV (gen 2), but I fixed this. You should turn off WMM at QoS. When I do this everything works on the 5GHz band ;-)

  • juangui16 Level 1 Level 1 (0 points)

    Same problem here, kind of. I even cahnge the rputher thinking it was broken, they give me a new one and when I intalled it again, the same problem happened, I have a Macbook Pro Retina display and a Apple tv 1080p.

     

    Both of my devices are on the 2.4 Band.

     

    I didnt try last time to connect it by ethernet cable, Ill try that when I get home today.

  • themoreyouknow Level 1 Level 1 (0 points)

    This is not an ATV problem as far as I can tell.  It is, as previously mentioned, a Cisco firmware / QoS configuration problem.  In the link provided above, Cisco released an update for the E4200 (see post by tinkererguy: http://homecommunity.cisco.com/t5/Wireless-Routers/E4200-with-Airplay-mirroring- hangs/td-p/456851/page/9 ) to address this.

     

    I am stuck with an E2500 right now and there's no fix, so I'm waiting to see if someone responds to me in that thread.  Otherwise I'm sending this E2500 straight back whence it was conceived (it's a factory refurb).

  • tjjohnsto Level 1 Level 1 (0 points)

    I doubt they will ever fixed it. I dumped my Linksys and went to Buffalo. I won't but linksys again.

  • themoreyouknow Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 30, 2012 10:50 AM (in response to tjjohnsto)

    Roger that.  I figured since I made a slight fuss in that thread I could give them a day or two to try to respond (if they're even interested).

     

    I know this is an older router (E2500) so I don't expect much. 

  • Gistropod Level 1 Level 1 (0 points)

    I have the exact same issue with my 2012 Mac mini and 2012 time capsule (2012 Apple TV).  I have everything set to 2.4ghz and works perfectly.  Every when I try to use 5ghz I have intermittent issues with AirPlay from Mac mini showing only video but no sound and the only way to fix is to restart Mac mini or router.  No issue with iPhone mirroring on either 2.4ghz or 5ghz.

  • marcmeyer Level 1 Level 1 (0 points)

    I had exactly the same problem.   On the Cisco Linksys site, I found advice to turn of WMM in the QOS settings section of the router, and this fixed the problem!

  • brassknucklenerd Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 31, 2013 7:44 PM (in response to SylHan)

    My problem: Airplay mirroring from MacBook Pro to Apple TV via Linsys (Cisco) E2500 dual band router, got a black screen on the TV.

     

    Disabling WMM on my router solved this for me right away. Thanks so much for the suggestion.

     

    My steps:

     

    - Go to the router's admin UI (192.168.1.1 in a browser by default)

    - Applications & Gaming > QoS

    - set "WMM Support" to "Disabled" (enabled by default)

    - reboot router

     

    Worked like a charm. Mirroring is faster than ever now.

  • muratjr Level 1 Level 1 (10 points)

    Just use different SSID Names for different bands. For example MyWireless for 2.4 ghz and MyWireless-5Ghz for 5 Ghz. And connect your apple tv to the 2.4 ghz. You can connect your mac or your supported idevices to the 5 ghz.

     

    it works flawless.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.