Skip navigation

Why does my iMac boot in linux some of the time instead of Mac OS?

2394 Views 62 Replies Latest reply: Jan 9, 2013 6:24 PM by Kenneth Hayden RSS
  • BDAqua Level 10 Level 10 (114,705 points)

    I agree, a bit too much of a coincidence, but we're running out of ideas!

  • Kenneth Hayden Calculating status...

    I'm not buying the battery either.  Two of us at once after the update?  Don't think so.  Yesterday a new symptom. On power up I got an error message that said an error had ocurred on boot and the system had to reboot.  It did this on it's own and then reported the error had happend (upon reboot) and did I want to generate a report and send it to Apple.  I clicked yes, the message disappeared and I never got the report and I don't it went to Apple either.  That has not recurred but today it's back to the same problem we've been discussing.  I do have a few other minor symptoms just in case they mean anything.  First when I have the mail program open the cursor occaisionally disappears from the screen.  Have to drag away from the program to make it reappear.  When I click send to send a new message it takes a few minutes before it actually gets sent.  During that time the new message is nowhere to be found.  Not in Drafts or Sent folders.  I also seem to be loosing Bluetooth Keyboard connection briefly fairly often. (2 or 3 times a day, batteries are fresh)  The Magic Trackpad doesn't seem to be affected.  Almost wonder if the Bluetooth in Mountain Lion and the keyboard are causing some sort of odd command to occur during boot.  The mystery continues.

  • WZZZ Level 6 Level 6 (11,875 points)

    This one should clear it and restore the boot defaults.  Although a PRAM Reset should have as well.


    sudo nvram -d boot-args


    Hit return and give admin pword when prompted. You won't see it as you type it in, then hit return again.


    Try a PRAM Reset again, but this time let it chime away a good six times.


    If this doesn't help Verify Disk in DU should be your next step. Or boot to Safe Mode. Hold Shift down at startup chime. Give it much longer to boot than normal; it wil be checking and repairing the volume directory, if necessary.

  • Kenneth Hayden Level 1 Level 1 (15 points)

    New observation that probably isn't related but who knows?   I started Pages for the first time and was informed there was an update for it.  I had previously checked for updates (almost everyday) but when the "Checking for new software message" appears it just seemed to keep running in a loop so I would close the page.  Did the same thing when I clicked the update button on the message inside of pages.  Finally just decided to let "Checking for software" run for as long as it took.  Came back to the computer about 15 minutes later and low and behold there were updates for iPhoto, iMovie, iWork, and printer driver updates.  I had previously updated Mountain Lion manually from the support site because I never saw it show up on update.  If I had waited long enough I guess it would have shown up.  Anyway, maybe the updates will cause something a little different during startup?  No occurrences so far but it's way too early to tell.  If it still happens I'm going to connect a hardwire keyboard and mouse to see if the bluetooth might be the culprit.  When it happens it's definitely single user mode.  I went and found a whole bunch of commands to try out.  Don't worry I won't kill it.  I ran fsck -fy and it comes out good.  Ran it from single user mode that was purposely invoked and ran it from when it occurred unexpectedly with the same results.  I'll report back if I find or don't find anything else.

  • Kenneth Hayden Level 1 Level 1 (15 points)

    Software updates had no effect.  Switched to hardwire keyboard and so far it hasn't had a problem.  Decided to try deleting my wireless keyboard and trackpad and then re-installing them.  That didn't work either.  Today I'm back on the hardwire keyboard and mouse.  No trouble so far.  My logic here is that something has to be inoking the single user mode at boot.  I can do it with command s but something is generating that command without being told to.  What can do that?  Flaky wireless keyboard?  Bluetooth driver?  New Bluethooth driver and older wireless keyboard?  The mystery continues.

  • Paul_31 Level 6 Level 6 (12,165 points)

    There's a chance you may be on to something. There have been other threads on here where a few users Macs would randomly boot into 'safe mode' on start-up - not all the time, just occasionally. The 'fix' for that issue is to ensure that all Bluetooth devices are only switched on once the boot-up process has got past the Apple logo - better still once boot-up is complete.

    Possible that BT could be behind your issue as well.

  • WZZZ Level 6 Level 6 (11,875 points)

    All that is related to unintended booting in Safe Boot, not single user, which appears to be what is happening.

  • Paul_31 Level 6 Level 6 (12,165 points)

    True - still think it's worth a try

  • Kenneth Hayden Level 1 Level 1 (15 points)

    Ok, after a few days of normal use on the USB keyboard and mouse I'm becoming convinced there is a bluetooth bug in Mountain Lion.  I'll give it another week before I "carve it in stone".  It may be that it's only affecting the "older" equipment.  I can't believe that Fred and I are the only ones who've seen this.  Fortunately typeing exit or reboot to continue is only mildly annoying but we shouldn't have to do anything and I'm thinking at some point an update will probably cover this.  I'll report back in a week unless it occurrs again with the USB keyboard.

  • WZZZ Level 6 Level 6 (11,875 points)

    When this happens, does it boot in Safe Boot or single user? The OP's issue is single user, not Safe Boot, and it is fairly well known that it will randomly boot in SB if bluetooth devices are on before booting up is finished.


    Can you please clear this up, since it's not obvious from your posts which kind of boot this is.


    (EDIT: But it does sound like single user if you have to type reboot to get out of it. There would be nothing to enter from a Safe Boot.)

  • WZZZ Level 6 Level 6 (11,875 points)

    I am not sure if it is single user mode or safe boot. How do I tell?

    "Safe Boot" will appear in red on the login screen. Other than that, it looks very similar to a normal startup. There is no text, as in single user.



    Here is one example of single user. Note the root# prompt at the conclusion of the text.




    Screen shot 2012-09-09 at 1.44.51 PM.png



    single user accepts Unix commands from root, which means virtually unlimied access to system files and or modifications of system files. Similar to the root user. You need to know what you're doing if you enter any commands. You're completely safe with "reboot."


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.