Skip navigation

Lion kills SoundTrack Pro, DVD Studio Pro and Color

11770 Views 28 Replies Latest reply: Sep 9, 2012 11:05 AM by Russ H RSS
  • eagles051387 Calculating status...

    Here is another interesting issue. I have a mac book pro with SL and logic pro 9 installed and after upgrading to lion sound track pro works like a charm.

     

    What has me really bewildered is if i upgrade first to lion and then install logic pro 9 on as i did on my imac sound track pro instantly crashes.

     

    is there a patch or anythign to fix this as its annoying to be doing music production on my imac and have to pull out my macbook to use soundtrack.

     

    both machines are intel based machines.

  • Studio X Level 7 Level 7 (26,835 points)

    REALLY REALLY bad solution.

     

    OSX 10.6 and 10.7 are very different beasts. If you have issues with a ProApps install, the better way is to use Digital Rebellion's FCP remover to delete the whole FCS package from your hard drive and do a clean installation.

     

    x

  • eagles051387 Level 1 Level 1 (0 points)

    For me though this was a brand spanking new and fresh install of logic pro 9.

     

    The odd thing is the issue is with soundtrack pro only logic pro works like a charm and a very speedy one at that and so do the rest of the apps.

     

    anything else i can try?

  • eagles051387 Level 1 Level 1 (0 points)

    Sadly it seems like im fully up to date. here is a paste of the crash report that pops up

     

    Process:         Soundtrack Pro [48491]

    Path:            /Applications/Soundtrack Pro.app/Contents/MacOS/Soundtrack Pro

    Identifier:      com.apple.soundtrackpro

    Version:         3.0.1 (960)

    Build Info:      SoundtrackProProject-9600000~277

    Code Type:       X86 (Native)

    Parent Process:  launchd [340]

     

     

    Date/Time:       2012-02-06 08:29:52.107 +0100

    OS Version:      Mac OS X 10.7.3 (11D50)

    Report Version:  9

     

     

    Interval Since Last Report:          324248 sec

    Crashes Since Last Report:           2

    Per-App Crashes Since Last Report:   1

    Anonymous UUID:                      224792DE-A070-4479-9AB3-92A04A444BE5

     

     

    Crashed Thread:  0

     

     

    Exception Type:  EXC_BREAKPOINT (SIGTRAP)

    Exception Codes: 0x0000000000000002, 0x0000000000000000

     

     

    Application Specific Information:

    dyld: launch, loading dependent libraries

     

     

    Dyld Error Message:

      Library not loaded: /Library/Application Support/ProApps/*/ProFX.framework/Versions/A/ProFX

      Referenced from: /Applications/Soundtrack Pro.app/Contents/MacOS/Soundtrack Pro

      Reason: image not found

     

     

    Binary Images:

        0x1000 -   0x7f7ff8  com.apple.soundtrackpro (3.0.1 - 960) <77CF322B-8BBE-AAEA-173F-75A237035319> /Applications/Soundtrack Pro.app/Contents/MacOS/Soundtrack Pro

      0x947000 -   0x94bfe6 +STPInterleave (??? - ???) <E87D1F34-6D97-63DB-454C-CF3D1B03F8E5> /Applications/Soundtrack Pro.app/Contents/Frameworks/STPInterleave.framework/Versions/A/STPInterleave

      0x952000 -   0x98ffff  com.apple.vmutils (4.2.1 - 107) <43B3BFA5-8362-3EBD-B44B-32DCE9885082> /System/Library/PrivateFrameworks/vmutils.framework/Versions/A/vmutils

      0x9a9000 -   0x9f5ffb  com.apple.audio.midi.CoreMIDI (1.8 - 42) <CBD34EBC-0FFD-34B4-B55A-BE1F61EF4BD8> /System/Library/Frameworks/CoreMIDI.framework/Versions/A/CoreMIDI

      0xa18000 -   0xc3eff7  com.apple.prokit (7.2.1 - 1710) <3791E1B1-DAB0-3989-BF09-4BE2EFC82B4F> /System/Library/PrivateFrameworks/ProKit.framework/Versions/A/ProKit

      0xd49000 -   0xd49fff  com.apple.iokit.dvcomponentglue (2.0.7 - 2.0.7) <1CFA5944-AB33-3A41-B4D2-4A624A514C0D> /System/Library/Frameworks/DVComponentGlue.framework/Versions/A/DVComponentGlue

      0xd4d000 -   0xd54fff  com.apple.AEProfiling (1.2 - 22) <43A46C32-8E13-82DD-8AF1-2A40690BF810> /Applications/Soundtrack Pro.app/Contents/Frameworks/AEProfiling.framework/Versions/A/AEProfiling

      0xd5e000 -   0xd6dfff  com.apple.AERegistration (1.2 - 77) <5D18C47F-6F9E-0C4C-8875-24A14A97186D> /Applications/Soundtrack Pro.app/Contents/Frameworks/AERegistration.framework/Versions/A/AERegistration

      0xd81000 -   0xd83fff  com.apple.ExceptionHandling (1.5 - 10) <6CA9446C-7EF9-35EE-BDF2-AA8D51E93E9E> /System/Library/Frameworks/ExceptionHandling.framework/Versions/A/ExceptionHand ling

      0xd89000 -   0xe49fff  com.apple.omf_framework (1.1.0 - 1.0) <ED5F21BC-18CD-D7F7-3D2E-F7F856BC0D40> /Applications/Soundtrack Pro.app/Contents/Frameworks/OMF.framework/Versions/A/OMF

    0x11000000 - 0x1102afeb  com.apple.proapps.ControlSurfaceSupport (2.0 - 68) <BD914236-49D8-9C9A-E8D6-CBC1738850B3> /Applications/Soundtrack Pro.app/Contents/Frameworks/ControlSurfaceSupport.framework/Versions/A/ControlS urfaceSupport

    0x8fe65000 - 0x8fe97aa7  dyld (195.6 - ???) <3A866A34-4CDD-35A4-B26E-F145B05F3644> /usr/lib/dyld

    0x9225c000 - 0x92518ff3  com.apple.security (7.0 - 55110) <2F4FCD65-2A30-3330-99DE-91FE1F78B9FB> /System/Library/Frameworks/Security.framework/Versions/A/Security

    0x92560000 - 0x925a8ff7  com.apple.SystemConfiguration (1.11.2 - 1.11) <CA077C0D-8A54-38DB-9690-5D222899B93D> /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfi guration

    0x92649000 - 0x92649fff  com.apple.Cocoa (6.6 - ???) <650273EF-1ABC-334E-B745-B75AF028F9F4> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa

    0x927d5000 - 0x92836ffb  com.apple.audio.CoreAudio (4.0.2 - 4.0.2) <E617857C-D870-3E2D-BA13-3732DD1BC15E> /System/Library/Frameworks/CoreAudio.framework/Versions/A/CoreAudio

    0x93b73000 - 0x93cd4ffb  com.apple.QuartzCore (1.7 - 270.2) <4A6035C8-1237-37E5-9FFF-1EFD735D8B18> /System/Library/Frameworks/QuartzCore.framework/Versions/A/QuartzCore

    0x943ec000 - 0x943ecfff  com.apple.Carbon (153 - 153) <A75A970B-6D82-3451-8D3E-05B1A130ABDE> /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon

    0x94eb9000 - 0x95090fff  com.apple.CoreFoundation (6.7.1 - 635.19) <3A07EDA3-F460-3971-BFCB-AFE9A11F74F1> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation

    0x95f5d000 - 0x95f5dfff  com.apple.vecLib (3.7 - vecLib 3.7) <8CCF99BF-A4B7-3C01-9219-B83D2AE5F82A> /System/Library/Frameworks/vecLib.framework/Versions/A/vecLib

    0x9625d000 - 0x963affff  com.apple.audio.toolbox.AudioToolbox (1.7.2 - 1.7.2) <E369AC9E-F548-3DF6-B320-9D09E486070E> /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox

    0x972b7000 - 0x972c5fff  com.apple.opengl (1.7.6 - 1.7.6) <5EF9685C-F8B2-3B22-B291-8012761E9AC8> /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL

    0x980c4000 - 0x980c4ff2  com.apple.CoreServices (53 - 53) <7CB7AA95-D5A7-366A-BB8A-035AA9E582F8> /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices

    0x9891c000 - 0x9891cfff  com.apple.audio.units.AudioUnit (1.7.2 - 1.7.2) <2E71E880-25D1-3210-8D26-21EC47ED810C> /System/Library/Frameworks/AudioUnit.framework/Versions/A/AudioUnit

    0x999cd000 - 0x99a31fff  com.apple.framework.IOKit (2.0 - ???) <8DAF4991-7359-3D1B-AC69-3CBA797D1E3C> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit

    0x99a7b000 - 0x99d00fe3  com.apple.QuickTime (7.7.1 - 2315) <E6249041-B569-3A96-897F-E84B1C057948> /System/Library/Frameworks/QuickTime.framework/Versions/A/QuickTime

     

     

    Model: iMac12,2, BootROM IM121.0047.B1D, 4 processors, Intel Core i5, 2.7 GHz, 16 GB, SMC 1.72f2

    Graphics: AMD Radeon HD 6770M, AMD Radeon HD 6770M, PCIe, 512 MB

    Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1333 MHz, 0x859B, 0x435435313236344243313333392E4D313646

    Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1333 MHz, 0x859B, 0x435435313236344243313333392E4D313646

    Memory Module: BANK 0/DIMM1, 4 GB, DDR3, 1333 MHz, 0x859B, 0x435435313236344243313333392E4D313646

    Memory Module: BANK 1/DIMM1, 4 GB, DDR3, 1333 MHz, 0x859B, 0x435435313236344243313333392E4D313646

    AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x9A), Atheros 9380: 4.0.61.4-P2P

    Bluetooth: Version 4.0.3f12, 2 service, 18 devices, 1 incoming serial ports

    Network Service: Ethernet, Ethernet, en0

    Serial ATA Device: ST31000528AS, 1 TB

    Serial ATA Device: HL-DT-STDVDRW  GA32N

    USB Device: FaceTime HD Camera (Built-in), apple_vendor_id, 0x850b, 0xfa200000 / 3

    USB Device: hub_device, 0x0424  (SMSC), 0x2514, 0xfa100000 / 2

    USB Device: Optical USB Mouse, 0x046d  (Logitech Inc.), 0xc016, 0xfa130000 / 6

    USB Device: BRCM2046 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0xfa110000 / 4

    USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8215, 0xfa111000 / 8

    USB Device: hub_device, 0x0424  (SMSC), 0x2514, 0xfd100000 / 2

    USB Device: ProKeys Sono 61, 0x0763  (M-Audio), 0x201e, 0xfd140000 / 5

    USB Device: IR Receiver, apple_vendor_id, 0x8242, 0xfd120000 / 4

    USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0xfd110000 / 3

  • jfancherla Calculating status...

    On my iMac Lion system the missing library is in another location. Color seems to launch okay on my system but I haven't tried using it. This would suggest that the path to the missing library, which is the cause of the crash, is not set properly which would be an insrtallation issue. Hope this helps.

  • eagles051387 Level 1 Level 1 (0 points)

    If thats the case wouldnt other apps have the same issue. Do you have a fix for this?

  • Graeme White Calculating status...

    I'll miss Soundtrack Pro - when it worked it was a fast and elegant stereo editor. When...it was also the buggiest piece of schrott that Apple ever released and it only grew worse with age. If I had the time back that I've lost to STP, I'd be a much younger man...

  • Boisv Level 1 Level 1 (0 points)

    Interesting. I have a mid 2009 MacBook Pro that already had the full Final Cut Studio suite installed when I upgraded to Lion. Those programs are still running fine. Today I tried to install DVD Studio Pro on a brand new iMac, also running Lion. The computer refused to run the install, and pointed out that it is a Power PC application.

  • eagles051387 Level 1 Level 1 (0 points)

    Are apple planning on releasing an updated version of this software for lion?

  • Russ H Level 6 Level 6 (12,925 points)

    Very doubtful that there will ever be an update for Lion – or for any other reason.

     

    FCS 3 runs fine on Lion. It's FCS2 that needs the PPC installer  and requires a workaround. Many posts on these boards about the workaround.

     

    Russ

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.