Skip navigation

Ipod stuck in restore mode, Itunes won't install.

8591 Views 15 Replies Latest reply: Nov 25, 2012 7:45 AM by Dimem RSS
1 2 Previous Next
meandree4ever Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 9, 2012 6:22 AM

Okay so first off, my ipod would not connect to my ihome and would say that this accessory is not supported by this device. And I looked online and apple said to restore my ipod. Itunes restored my ipod, but then said unable to restore. So my ipod is stuck in restore mode and itunes would not read it. So I tried uninstalling and reinstalling itunes. After i uninstalled everything when i try and reinstall itunes, midway through it says "service 'apple mobile device' (apple mobile device) failed to start. Verify that you have sufficent privelages to start this service." I really do not know what to do at this point. I need to get my ipod to work. When i go to device management it says apple mobile device(recovery mode). Please help ASAP

iPod touch (4th generation), Windows 7
1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.