Skip navigation

iPhone 4S "no service" problem

739098 Views 723 Replies Latest reply: Apr 5, 2014 4:59 PM by liam1989 RSS Branched to a new discussion.
  • Kamikaze_Dat_Ho Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 2, 2012 8:19 PM (in response to abds2000)

    Everybody i have found a solution that worked for me the first time. All you have to do is go to general settings~ reset~ Erase all content. Be warned that by doing this it will delete all your contacts and everything so back up first. After you do that set your phone back up, redo the network reset and then make sure you are connected to the internet. It will say Iphone is activating, will take a few minutes. And then it will say Iphone has be Activated. From there all you have to do is then add your stuff back on it and you are good to go.

  • Iamdjlex Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 12, 2012 1:05 PM (in response to abds2000)

    I live in Barbados & I experienced this problem. The "no service" & "searching..." issue was mind bogglin and frustrating. I went to my service provider & they looked at it...To sum everything up in a nutshell they gave me a brand new sim-card & voila!!! Back to normal!!!

  • Flicflic Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 13, 2012 8:17 PM (in response to Iamdjlex)

    I live in Barbados and have experienced this only in the last two days. Only problem is I'm on a uk sim and can't get a replacement sent here! So annoying, it was working find for about 10 months and then one night just stops!

  • Ed.......... Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 20, 2012 12:26 PM (in response to Flicflic)

    My iPhone was replaced due to faulty mic a month ago and never got this problem. Now they replaced my iPhone and now whenever i enable 3G signal bar drops but carrier name is still there and 3G works but I am not able to send or recieve txts or calls. and goes to no service and searching at times.. and it ****** me off! when i disable 3G i get signal and normal use. So whats the use of a data plan if I can't use 3G.. what should i do please help me! i restored already new and backed it up resored a few more time still no go and i already did the reset and still no go! what should i do? is it the phone? i already changed sim cards too and still the same inserted sim in and out airplane mode on off sim pin off  still same ****. is it the phone? or an update will fix it please help me thanks guys!

  • Ed.......... Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 20, 2012 1:10 PM (in response to abds2000)

    I'm fed up had this for months! im selling this tomorrow and get an android an S2 or S3! im sick of this! im paying for services i cant even use!

  • gdjgarcia Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 20, 2012 1:27 PM (in response to Ed..........)

    I feel for you! I can tell you that I had 4 phones and 4 sim cards before I decided that the iPhone 4S wasn't for me. I can't tell you how much time I wasted with Apple resetting, restoring, swapping, turn this on, turn that off, etc etc before I got to the same point. Apple blamed the carrier, the carrier blamed Apple, etc etc. I left both of them. I don't know wether it was software or hardware but I now have a phone that works every time I need to use it!

  • hehehey Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 21, 2012 7:24 PM (in response to gdjgarcia)

    I've been experienceing the same issue for over a month. It's ridiculous!!!

    What made it worse is that fact that when I called Apple after waisting my time with At&t, Apple wanted to charge $29.99 for phone support. The guy aknowledged that he'll be using this same useless forum and didn't garantee that the problem is going to be fixed. After owning almost every product that they made over the last years, I'M FED UP WITH APPLE and will defenitly switch to another phone.

     

    note: I'm so upset that I can't spell right

  • Shinn_Freedom Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 27, 2012 12:13 AM (in response to hehehey)

    hi there,

     

    i just fix a Iphone 4G which start all of sudden it ask to activate the phone after restart the phone.

     

    what i did was:

     

    1. was restore the phone to factory default but that is no good at all.

    2. try with jailbreak and i get the phone back again but with no wifi, no bluetooth and no network.

    3. as i surfing net and get some info such as put the phone into the freezer! i was thinking that was nuts! but it do work after 2 hr in the freezer. wifi working and bluetooth as well. but no service appear which is very annoying. a phone which cant use the sim is useless... so i have to do some research and try.

    (put into the freeze to fix the wifi problem 1st before proceed to the following step)

    4. jailbreak the phone with redsnow 14b.2. then follow by restore with iphone factory restore.

    5. after finish those open your itunes and see your iphone you should be able to see the iphone detail then it will ask you to restore from your backup. after finish restore.

    6. it works perfectly!

    7.Basically no wifi, no bluetooth and no network service - IS NOT HARDWARE ISSUE AND IT CAN BE SOLVE IF YOU DO SOME RESEARCH.

     

    ok guys good luck to you all!!!!

    iphone 4/4S

    this is for IOS 5.1.1 version 9B208

    redsnow 14B.2

     

    P/S: i learn alot more bout iphone now. hopefully new problem will come so that i can exprience it more!

  • peterwardgd Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 27, 2012 1:18 AM (in response to abds2000)

    yes its very common. Please contact apple and make a report so tehy take notice. thans

  • syddo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 29, 2012 11:18 PM (in response to Shinn_Freedom)

    are you really sure about this freezer thing? it really sounds absurd to me.

     

    i got the same issue. but i think this is more of a software glitch since I updated to the latest iOS 5.1

    I hope Apple noticed this and fixed it on iOS6 which is gonna be out in the next few days!!! oh cmon.

  • Shinn_Freedom Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 30, 2012 5:45 PM (in response to syddo)

    i have try it with my fren is watching as well. actually that iphone is his. and he is really sad cos it was his 1st iphone. so i decide to see if is work or not.

     

    do wrap it with plastic before you put into the freezer. since you cant use it why not try it? unless your phone is still under warranty. but this is no an new issue, if your search around kinda alot of users already try it and they do say it works!

     

    now he is happy and everything is working. just need to do some reading and patience while doing this. do let me know if you facing the prob. cos i think i know how to do it the right way since i spend whole sunday fixing that problem.

  • Luiggi7 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 10, 2012 1:47 AM (in response to Iamdjlex)

    Hello lamdjlex. I have the same problem (I think barbados is Spain, doesn't it? I'm from Madrid). I am dissapointed so far with Apple and Orange, because non of them give me a solution.

     

    I have a microSIM but I don't know if it is 64bits or 128bits.

     

    Lamdjlex, what do you say I gotta do? Changing my actual SIM to other new (microSIM and 128 or microSIM and 64bits) will solve that horrible issue???

     

    Many thanks.

  • vwagner311 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 15, 2012 9:26 AM (in response to abds2000)

    I have restored my iPhone 4s several times in the past without any problems. But yesterday I restored my phone and all of a sudden I was having the "No Service" issue with the signal dropping.  So I tried restoring again, and I still had the same problem. After three restores, I was still having the same problem. I called tech support and they told me there is nothing they can do that I have to bring the phone in to an Apple Store.

     

    I figured I would try one last restore. I noticed that I had the silent switch on the side of the phone in the vibrate only position. I switched it back to the normal position and tried the restore again and bingo! Problem resolved for me. I would definitely suggest that anyone having this issue try a restore on their phone and make sure the switch on the side of the phone is not set to silent.

     

    Good luck to all of you!

  • Luiggi7 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 20, 2012 6:41 AM (in response to Luiggi7)

    Today has been released iOS 6.0.0

     

    I have updated sinced this morning.

     

    Waiting for results.

  • justchil Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 20, 2012 7:19 AM (in response to Luiggi7)

    Same problem with IOS6.

     

    I've tried everything.  Factory reset,  resetting network settings, updated carrier settings, etc

     

    I even reset my network settings after upgrading to IOS6.  Problem still happens.

     

    I'm going to get another 4s this weekend and see if I still have the problem.  I've read on this post people have had their phone replace multiple times and still have the problem.

     

    I'm guessing it's a flaw with the antenna in the phone.

     

    Just happened again.  I've missed many important phone calls because of this... lock the phone put it in pocket only to realize when you pull it out again that it's been sitting there with "no service".  Toggle airplane mode and wow I have service again.

     

    I guess there are enough sheep out there that issues like this really don't matter in the big scope of things.  So a few hundred people switching to another phone due to an issue like this isn't a big deal lol

1 ... 39 40 41 42 43 ... 49 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (16)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.