Skip navigation

Applescript stopped working after Mountain Lion upgrade

1806 Views 7 Replies Latest reply: Sep 10, 2012 12:44 PM by Jacknumpty RSS
Jacknumpty Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 4, 2012 3:18 PM

Hi after upgrading to Mountain Lion (ML) the applescript that I use to reply to certain emails has stoped working on incoming emails. I have the script in the "new" correct folder. The funny thing is that the script works when you "apply rules" from the messages dropdown menu.

OS X Mountain Lion (10.8)
  • Niko Nyman Level 2 Level 2 (270 points)

    Seems like Applescript rules in Mail 10.8 are not working for messages retrieved from POP accounts.

     

    If a Mail rule fires on a POP account, the rule gets passed a list of messages contained in a special "Incoming POP Messages" mailbox, but when the Applescript tries to access the messages, the Incoming POP Messages mailbox is empty.

  • Tony T1 Level 6 Level 6 (8,115 points)

    I may have a workaround until (if) Apple fixes this bug.

    See: https://discussions.apple.com/message/19514671

     

    You will need to add a line to your code to move the messages out of the inbox after processing.

  • Tony T1 Level 6 Level 6 (8,115 points)

    Flagging the email is a good way to prevent the script to process the email more than once.

    Another test to consider is if the read flag is false:

    if read status of theMessage is false then

        ...

    end if

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.