1 2 Previous Next 16 Replies Latest reply: Jul 9, 2014 7:19 PM by mmmax
chriscrown Level 1 Level 1 (0 points)

Hi community!

 

I share my calendar with my wife and she shares her calendar with me. On my iPhone I get all of her alerts on her events... Is there a way to disable alerts from others calenders?

 

Thanks a lot!

Chris

  • 1. Re: Disable alerts from shared calendars
    alphatommo Level 1 Level 1 (10 points)

    this is a huge issue for me and is the only thing stopping me and my wife from moving across from Google.

    In Google i can disable shared calendar alerts but on MobileMe and iCloud you cant and its to annoying to use.

    If apple come up with a solution we will definately switch to iCloud but until then Google is the way to go.

  • 2. Re: Disable alerts from shared calendars
    angelobanjo Level 1 Level 1 (10 points)

    I find it hard to believe that when designing the sofware they didn't see this as a major fuction that should have been addressed.  Especially when building iCloud.  Feels cobbled together.

  • 3. Re: Disable alerts from shared calendars
    Tomasz Gutowski Level 1 Level 1 (5 points)

    I think there is a way to do it at least on a Mac.  Open iCal then right click on the shared calendar, click Get Info which should bring up a window with a check box 'Ignore Alerts' and click OK.  That should disable the alerts from that calendar.  I have not found the same option on the iPhone so far.

  • 4. Re: Disable alerts from shared calendars
    TeaMan Level 1 Level 1 (125 points)

    I have been having this same issue. My wife is very unhappy about this problem of my calendar events triggering alerts on her iPhone. So I've been trying to figure out what is going on.

    First about my setup:

    * I use Google Calendar as the go between for syncing events between iCal on our Mac computers and in iOS Calendar app on our iOS devices.

    * We both use Mac OS X Lion on our Macs.

    * We each have our own Apple ID accounts.

    * We both have iPhone 4S and iPads (hers is 1, mine is 2) and all are on iOS 5.

    * Using Tomasz G. suggestion above I verified I had done that step.

     

    Regarding Tomasz's post, note that when he says to right-click on the shared calendar, this is after first left-clicking on the Calendars button in the upper left corner of iCal window, which drops down a list of calendars. Right-click on the CalDav shared Google calendar there... so for my iCal, I right-clicked in the drop down, on my wife's CalDav shared calendar. On her Mac in iCal I clicked on my shared calendar in her drop-down Calendar list. As he stated, right-clicking gives a menu which includes Get Info.

     

    While checking calendar settings, you might also right-click on your own Google calendar in that drop down, do Get Info and verify that the checkbox for Ignore All Alerts is NOT checked for your own calendar, so that you do get your own alerts. We just don't want to get each other's alerts. So in my iCal, right-clicking on her shared calendar, I checked the box to Ignore All Alerts and the same for my shared calendar in her iCal.

     

    Here is what I've learned from my testing:

    * Events set up on iOS devices (my iPhone and both our iPads) with an alert time did NOT fire an alert on each other's iOS devices or Macs, just on our own devices and Mac. Perfect!

    * Events set up in iCal on my Mac with an alert time DID result in an alert firing on my Mac and on ALL iOS devices! Wrong behavior!  Apple...Google... this is a BUG! IMHO. Please fix this! My wife works nights and she does NOT appreciate getting my daytime alerts on her phone!!

     

    NOTE: To do this testing I had to make sure the event was first showing up on all calendars... i.e. open and refresh all calendars on all devices and Macs PRIOR to the alert trigger time to make sure each device and Mac is aware of the event.

  • 5. Re: Disable alerts from shared calendars
    Colin Viebrock Level 1 Level 1 (25 points)

    This works fine ... except that the alerts still appear on an iPhone that is viewing the shared calendar.  I can't find a similar setting on the phone to deal with this annoyance.

  • 6. Re: Disable alerts from shared calendars
    caw35slr Level 1 Level 1 (10 points)

    That stops alerts of the "alert me 15 minutes before the event" type. It doesn't stop alerts fopr event create, edit or delete. See https://discussions.apple.com/message/16922004#16922004

  • 7. Re: Disable alerts from shared calendars
    Peter Porker Level 1 Level 1 (0 points)

    This bug has been around for 7 months and they still don't have a fix for it? Not cool.

  • 8. Re: Disable alerts from shared calendars
    alphatommo Level 1 Level 1 (10 points)

    good news, i have tested this and now alerts are no longer activated on a shared calendar.

    if i enable an alert on my event and share that calendar, the other person will not get that alert.

     

    thank you apple. i have now switched over to iCloud

  • 9. Re: Disable alerts from shared calendars
    whistlepigger Level 1 Level 1 (0 points)

    not so good news. sometimes my wife and i want a shared calendar event to send the alert to both of us - and sometimes not.

     

    maybe the most flexible design would be to have a selection at event creation time:

    • send event to all
    • send event to creator only
    • send event to shared member xxx - so you could create an alert for someone else
  • 10. Re: Disable alerts from shared calendars
    Mac Fanatic Level 1 Level 1 (115 points)

    You can create another calendar for shared events.

  • 11. Re: Disable alerts from shared calendars
    kthersh Level 1 Level 1 (0 points)

    What did you do to fix it?

  • 12. Re: Disable alerts from shared calendars
    Friar'sPoint Level 1 Level 1 (0 points)

    Did you ever get an answer???

  • 13. Re: Disable alerts from shared calendars
    Tomasz Gutowski Level 1 Level 1 (5 points)

    In system 7 on the iPhone under Settings go to Mail, Contacts, Calendars and scroll all the way down.  You can turn on or off the shared calendar alerts

  • 14. Re: Disable alerts from shared calendars
    Friar'sPoint Level 1 Level 1 (0 points)

    Yes, I did this, but it doesn't seem to have any effect.

1 2 Previous Next