Skip navigation

iMovie 11 showing incorrect date/time

8066 Views 40 Replies Latest reply: Nov 13, 2013 4:06 AM by John Cogdell RSS
1 2 3 Previous Next
PI777 Level 1 Level 1 (0 points)
Currently Being Moderated
Jul 30, 2012 6:29 AM

Hi Guys,

 

I just recently purchased a MBP Retina and have upgraded to Mountain Lion & iMovie 11. My problem is after importing videos from my Sony HD camera I stamp the footage with the time/date stamp but it is showing incorrectly. The date is correct bnut the time seems to be 12hours off for most of it and only a couple hours off at the end. I have checked the date and time of the clip buy turning on "Playhead Info" from the menu and it shows correct when I hover the mouse over the clips but shows wrong in the canvas??

 

Any ideas.

 

Thanks

 

PI777

MacBook Pro with Retina display, OS X Mountain Lion
  • dennisraustin Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 1, 2012 10:05 AM (in response to PI777)

    I've been using this date/time stamp feature for over a year with no problems. Just recently, I am having an identical issue to what you described. Some other threads about this same issue are pointing to a recent iMovie update that introduced this bug.

     

    It's not ideal, but I have resorted to using the "Adjust Clip Date and Time" from the file menu. The only good thing is that all my clips were off by exactly 3 hours. I was able to select multiple clips and adjust the hours for all of them.

     

    Hopefully the Apple iMovie team will take note and fix this in an update.

  • applefan1979 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 1, 2012 8:46 PM (in response to dennisraustin)

    Hi,

    I am having the same problem.  Just bought new Macbook Pro with Retina Display, Os X Mountain Lion.  I verified that the video dates/times are correct using the Adjust Clip Date and Time in iMovie, however for some reason, iMovie is adding 3 hours to the time when it displays it. 

     

    I also hope that the Apple iMovie team will take note of this glitch and fix this in an update soon!!

  • nor500 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 12, 2012 12:19 AM (in response to applefan1979)

    I am facing exaclty the same problem! What a shame.

    Have you contacted Apple about this problem?

  • OaklandMacFan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 12, 2012 2:31 AM (in response to nor500)

    Same problem here except I am still using Lion (10.7.4). I just imported a ton of recent home/family videos into iPhoto '11 (9.2.3) all of which have accurate date/time info. When I open iMovie '11 (9.0.4) and it generates the thumbnails all of the video clips generated are behind by exactly 7 hours. For example, if the clip in iPhoto is 3:41 AM Sept. 7, 2012 (correct) it displays a created data in iMovie as 8:41 PM Sept. 6, 2012. My Time Zone and date/time settings are correct.

     

    This is inexcusable.

  • OaklandMacFan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 12, 2012 3:54 AM (in response to OaklandMacFan)

    Just updated iPhoto to 9.3.2 and iMovie to 9.0.8, imported a video into iPhoto, launched iMovie, and my iMovie clip is still behind 7 hours vs. the original in iPhoto. Total joke.

  • omracer Level 1 Level 1 (30 points)
    Currently Being Moderated
    Sep 12, 2012 4:11 AM (in response to PI777)

    I've had this problem on videos i've , its been a bug ever since imovie 9.0.6 with the retina update. If you insert the time and date stamp, the time shown is 2 or 3 hours out. i've imported into imovie directly from my ipod touch 4G.

  • nor500 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 13, 2012 11:54 PM (in response to omracer)

    When do you think Apple will correct this date/time title issue? Is someone from Apple is reading this thread?

  • nor500 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 14, 2012 1:51 AM (in response to PI777)

    When do you think we can expect the next update?

  • DanielTong Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 15, 2012 11:22 AM (in response to nor500)

    Don't think they would update for that. Next version iMovie will come out and may be need to pay for it.

  • Malbrouck Level 1 Level 1 (10 points)
    Currently Being Moderated
    Sep 23, 2012 9:05 AM (in response to PI777)

    I have a similar problem: 2 hours offset between the time of the clip (which is right) and the time displayed in the project when using the date/time title.

     

    I'm stuck at iMovie 9.0.4 and I don't upgrade because of this bug.

     

    Do we need to cry to get a bug fix release ?

  • tpmccarthy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 23, 2012 9:10 PM (in response to PI777)

    I have also encountered this bug/glitch. Does anyone have any information as to when it may be fixed?

  • camcam1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 25, 2012 5:22 AM (in response to PI777)

    the video clips show correct date in iPhoto Sep 3, Sep 4 etc. However, after importing them into iMovie '09 (8.0.6) in the event folder, all videos show as Sep 10 12:07 AM, all of them. I notice that when I add the date and time effect over the video clip.

     

    finally my wife convinced me to switch to Mac from PC, because it can apparently handle media related tasks much better. Now am finding there is a bug for video date since over 1 year and still not resolved. Bugs can happen, but something simple like that should be addressed promptly via an update (usisng date stamp of video created vs. date imported), specially if the dates are showing correctly in iphoto.

  • rjolmstead Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 15, 2012 1:09 PM (in response to PI777)

    I just discovered the same problem. Mine is 4 hours off.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.