Skip navigation

Profile Manager Fails To Deploy

9697 Views 17 Replies Latest reply: Jan 10, 2014 4:01 AM by Punkman83 RSS
1 2 Previous Next
ionepoch Level 1 Level 1 (0 points)
Currently Being Moderated
Aug 30, 2012 2:17 PM

We have had a number of problems using Profile Manager to deploy settings.  Wanted to share our workarounds.

 

If a profile fails to deploy... it appears to erase all of the users profile settings... therefore it's important to test your profile settings first prior to deploying.  This appears to be a bug.  Logging in and out may refresh the profile... but you must first remove the bad settings.

 

Be sure to have your firewall ports open for Profile Manager communication:  http://support.apple.com/kb/HT5302

 

 

Profile Manager May Fail Under the following circumstances:

 

 

-- Pushing "Calendar" settings without a user's valid password (even though the field is optional) will cause the profile deployment to fail:

 

0::Aug 29 16:31:11.766 [40281] <10.0.142.201> Status='Error' CommandUUID=0afef3a0-d457-012f-b3e9-406c8fb90eeb

Array

(

    [0] => Array

        (

            [ErrorCode] => -319

            [ErrorDomain] => ConfigProfilePluginDomain

            [LocalizedDescription] => The 'Calendars Account' payload could not be installed. The account credentials were invalid.

        )

)

 

 

 

-- Polymorphic profile settings.  IE it does not appear to support things like "Multiple Group Restrictions" blending together.   In other words... having a user part of a "Base Users" group and a "Sales Group"  that have different "Restrictions" will most likely fail.   The old MCX profiles seemed to support this, but not Profile manager.

 

 

-- Mobility syncing does not appear to work unless "Merge with user's settings" is enabled

 

 

-- Unconfirmed... if you restrict a users access to "System Preferences -> Profile" ... the profile updates may not occur.

OS X Server
  • Mark23 Level 3 Level 3 (975 points)
    Currently Being Moderated
    Sep 5, 2012 5:27 AM (in response to ionepoch)

    Thanks for sharing!

  • Greg Malone Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 13, 2012 5:54 AM (in response to ionepoch)

    What you are describing about failed or partially completed profiles deployment to clients is very similar to my own experience.  I've been trying to use Profile Manager for the last few weeks (during the start of the school year deploying in an active school environment!) and it has been a real pain -- esp. the inconsistency.  I did upgrade all of my systems (server and about 60 clients) to Mountain Lion, hoping for fixes to profile manager, but so far the results are not encouraging.

     

    This weekend I'll probably try going back to Workgroup Manager for policy deployment.  I imagine that's why Apple left WGM alive in 10.8 --- they know PM is problematic.  Which ***** and is a bit despicable if you think about it. 

     

    I've long bemoaned how Apple can be a great hardware maker, but a lousy lousy lousy software developer.  With more money than god, you'd think someone would take Apple (and let's throw Google in there too) and shake them by the shoulders and say "DUDES!  Get your act together on the software!"   But instead they use their customers as never-ending beta (and often alpha) testers, jeopardizing the enterprise and education environments that trust them.  Sheesh.  Needed to vent.

     

    Please post any additional findings you may come across re: profile management.  Have you found useful discussions elsewhere?   Forget about finding anything official from Apple in the way of help.  That's another thing...  oh, well, I'll stop here.

     

     

    Added note:  Before going back to WGM, I'll issue via ARD a Unix command to the clients to delete all profiles.  sudo profiles -D from this thread: https://discussions.apple.com/message/19515980#19515980

  • David Urban Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 4, 2012 6:23 AM (in response to ionepoch)

    ionepoch

     

    Thanks for the workaround.  I was having this same problem but with the user profiles.  My users name was their first and last name and I had applied an alias of just their first name.  it worked fine with Lion but always failed with mountain lion.  As soon as I removed the alias the user profiles started to work.

     

    Thanks for the help

     

    David Urban

  • mille1j Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 15, 2012 9:51 PM (in response to ionepoch)

    For mobility, what does "Merge with user's settings"" do?

  • mille1j Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 16, 2012 12:57 PM (in response to ionepoch)

    Still strugging with deploying settings for messages

     

    Payload for the workgroup set to use the %short name isn't working.  It works for SOME users, but not all.  If a user had anything in their preferences for messages before, could that interfere with the payload?  IE, could deleting the user's messages prefs, or somehow refresh it help? 

     

    Instead of trying to use the payload variable, would it be better to setup a user payload for messages settings?  Will that information load on any computer they log into, regardless of whehter it is set to be their device?  IE, if they login to imac5, which is my device, isntead of imac1 which is their device, will that user payload still show up for them?

  • iToaster Level 3 Level 3 (560 points)
    Currently Being Moderated
    Nov 13, 2012 3:53 PM (in response to ionepoch)

    I've noticed strange behavior with pushed smtp setting as well

    deleting manual or pushed mail settings doesn't seem to remove the smtp settings

    especially if your moving from manually configured mail smtp setting to pushed

    were the setting are unchanged

     

    eg delete manually configured mail - settings, mail contacts delete mail account

    push out same mail account via PM

    check mail settings - old manually configured smtp is still there along with pushed smtp setting

    sometimes the pushed smtp setting is mixed in with the manual smtp settings

    sometimes smtp is disabled yet everything still functions

    sometimes no smtp settings at all yet mail still fuctions

     

    I've tried deleting the smtp setting then deleting the profile and pushing the profile out again

    resulted in no smtp setting at all, mail still functions

     

    same behavior with ios 6.01

  • takh Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 26, 2013 1:51 PM (in response to ionepoch)

    Has anyone tried profile manager again on 10.8.2?

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.