Skip navigation

HT5188: Apple Configurator: Using Volume Purchase Program (VPP) Redemption Codes

Learn about Apple Configurator: Using Volume Purchase Program (VPP) Redemption Codes

HT5188 Configurator - "App Not Authorized"

4770 Views 13 Replies Latest reply: Apr 16, 2013 6:27 PM by BastianG RSS
MTSD-IT Calculating status...
Currently Being Moderated
Jun 1, 2012 11:41 AM

I've read several articles and each time get a little farther, but still haven't been able to resolve this...

 

I am using the latest version of Apple Configurator on a Macbook, also freshly updated to the latest update of Lion.  I have set up the Macbook with the iTunes Account I set up for this cart, we'll call it Cart01@email.com.  I have logged into iTunes with this same account, and authorized it.  I have gone to Preferences in Apple Configurator and set this as the iTunes account there.

 

I used the Volume Purchase Store to obtain some apps through my facilitator account, facilitatorA@email.com.  I sent the codes and the xls files to Cart01@email.com, clicked on the links, and downloaded them via iTunes.  These are Supervised iPads, so I went to the Supervise mode of Configurator, and added in the paid apps, along with some free ones I got along the way.  I clicked next to each paid app and imported the xls files. 

 

Each time I try to Apply the new apps, I get the error "App not authorized."  This is when I went into Configurator's preferences and entered Cart01@email.com into the Preferences.  Then when I hit Apply again, it zapped away the codes (marked them as used) but did NOT put them on the iPad - in the license sheet it just has a checkmark, it doens't list device name/number or anything.  And it still says App Not Authorized.  I even went on to the iPad itself and logged into Store with the same Cart01@email.com account.  Nada.

 

I'm tearing my hair out... any other suggestions??

Apple Configurator, Mac OS X (10.7.4)
  • ThrustinJ Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jun 14, 2012 12:10 PM (in response to MTSD-IT)

    iTunes on the configuration computer must be "authorized". You can do that in iTunes > Store menu > Authorize this Computer.

     

    Very silly that they don't specify that in the error message where you authorize.

  • akalthof Level 1 Level 1 (10 points)
    Currently Being Moderated
    Sep 13, 2012 11:27 AM (in response to MTSD-IT)

    Who did you contact for help? I am having this issue right now.

  • gyrhead Level 3 Level 3 (785 points)
    Currently Being Moderated
    Sep 13, 2012 11:47 AM (in response to akalthof)

    You are not running the latest Configurator (1.1.2) if you have that option( to enter an apple id)  in preferences.  It sounds like you are on 1.01.   You should delete the Vpp spreadsheets you imported, update to 1.1.2, and reimport them. When you reimport the vpp spreadsheets use freshly downloaded ones from the vpp website.  You will be prompted for the itunes account authorized for the mac when you reimport and deploy.   You can also check the usage of the codes in Configurator to see what ones are being assigned to what device, and see if "wierd stuff" is happening. 

  • mtsd-vt-it Calculating status...
    Currently Being Moderated
    Sep 13, 2012 12:55 PM (in response to MTSD-IT)

    We are a K-12 school, so the end result after playing phone/email roulette for two days was to email vpp-edu@apple.com.  There may be a new version now, but at the time we were running the latest version (the Apple tech remoted in and verified it).

  • gyrhead Level 3 Level 3 (785 points)
    Currently Being Moderated
    Sep 13, 2012 3:13 PM (in response to mtsd-vt-it)

    I had similar issues, so I deleted the paid apps, deleted the vpp spreadsheets, added the paid apps, downloaded new VPP spreadsheets for the items in the vpp store, readded the apps, reimported the new spreadsheets, got prompted to enter the itunes account of the computer running configurator, and everything worked like it was supposed to.

  • MESAdmin Calculating status...
    Currently Being Moderated
    Sep 21, 2012 10:01 AM (in response to MTSD-IT)

    In my case I had the error if I did NOT have my configurator install the Profile with the Wi-Fi access payload configured before or during the app install process.  If I load the Profile on the ipads, then internet access happens, then suddenly the error about App Not Authorized goes away. Seems they like to send a Wi-Fi double check from the iPad to ensure you are authorized for the code on install. Worth a shot, especial if like me you are starting off with fresh out of the box, newly prepared iPads.

  • mskiwifruit Calculating status...
    Currently Being Moderated
    Nov 24, 2012 12:49 AM (in response to MTSD-IT)

    This is similar to my issue except when the redemption code import process was all take care of, the paid apps showed in the app dock along with the free apps and also displayed the number of redemption codes remaining. HOWEVER, the two rows for just the two paid apps appeared dim (grayed out) and were inactive. Meaning I was unable to select the checkbox that app to be included in the Preparation of devices.


     

    I also made sure that the Mac Mini used throughout this process was an authorized iTunes Store computer for the initial, non-VPP Apple ID. I did not select the devices to be supervised because after having so much trouble & running short on time, I wanted to be able to install the apps manually as a plan B. (which I wasn’t able to do either….) Note: I am working with Mountain Lion & iPad 6.0 software. We are using an Ergotron cart to sync with Apple Configurator.

  • Tngirl14 Calculating status...
    Currently Being Moderated
    Dec 7, 2012 6:54 AM (in response to mskiwifruit)

    I am having the same issue as mskiwifruit - I have a large number of iPads at a school. I have purchased all my codes legitimately through the VPP program and imported them into Configurator.

    When I want to install Apps on an iPad through Configurator the free apps will allow me to check the box, however the paid apps won't allow me to check the box.

    I can, however, install them my using the App Store on each individual device, but I don't want to do that.

    My system was working perfectly until about 2 weeks ago and then all the sudden stopped working.

    I really need a fix to this!

  • mskiwifruit Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 7, 2012 7:01 AM (in response to Tngirl14)

    My problem was that I didn't have Supervise turned on. In order to use apps purchased through VPP, you must supervice the devices. Hope this helps!

  • alexanderstein Calculating status...
    Currently Being Moderated
    Jan 27, 2013 11:39 PM (in response to mtsd-vt-it)

    Apparently that email address vpp-edu@apple.com no longer exists.  Their email servers give me a 550.

  • BastianG Calculating status...
    Currently Being Moderated
    Apr 16, 2013 6:24 PM (in response to MTSD-IT)

    HI,

    I had the same issue,

    Q1. Does this happen ONLY with one appe device?

     

    I was using apple configurator to configur 59 iPadmini(s),
    (Altogether 3 trollies, divided with 17, 19 and 23 in each)

     

    Things that you should notice:

    1. Make sure that after redeemin the appl VVP cods, go back to the VVP webpage and dowload the new spreadsheet. Direct Link:

    https://volume.itunes.apple.com/WebObjects/MZFinance.woa/wa/accountSummary

    + Since you have already redeemed one app, the old spreadsheet doesnt recognise that you have done so. In the new spreadsheet,

     

    2. tyr to install the free apps first, only for the last ipad/iphone,

     

    3. if you are unable to fix it with anyway, call apple care,
    they are pretty good, they will make sure that you get the X number of apps you need.

    + when you recevie these codes make sure that you ask them to send it via an excel spredd sheet, so you can import them directly to apple configurator.

     

    Hope this helps.

  • BastianG Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 16, 2013 6:27 PM (in response to alexanderstein)

    vpp@apple.com.

     

    Thats the new email address.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.