Skip navigation

No wifi/internet after updating to Mountain Lion - help

11922 Views 18 Replies Latest reply: May 19, 2013 4:02 PM by Haze623 RSS
1 2 Previous Next
Reckimo Calculating status...
Currently Being Moderated
Jul 31, 2012 2:56 AM

Hello,

 

I have a big problem. I looked already several times on different forums,but wiithout a result to fix my problem.

After i updated my macbook pro '15 inch to the new Mountain Lion update, i had from that moment no wifi. On my iPad and iPhone the wifi just works, and on my windows 7 laptop i also have wifi connection and it works perfect.

 

I tried many things to fix the connection with the wifi, but it didnt help. I read on another forum that this would work: turn your macbook off. Start it with holding alt + R (so far i can remember) and then i pressed the option to re-install Mountain Lion. So it went to downloading and installing, and after this i didnt have either internet connection with a cable. So at this moment i dont have connection with a cable and wifi.. When i go to safari and try to surve on the internet, it will load for perhaps 4 centimeter and then it just stop with loading of the adress balk..


I could realy appreciate if someone can help me with this problem, i dotn know what to do now.. (im not the smartest one with apple settings, so if it could, keep it easy )

 

Thanks,

Reckimo

MacBook Pro, OS X Mountain Lion, wifi doenst work after updating
  • halfnhalf03 Calculating status...

    I am also having this same problem on my late 2008 macbook.

  • Simon Powell Calculating status...

    Count me in. Just upgraded from Lion to Mountain Lion on my Mac Pro late 2008 with AirPort Extreme card and now get 'No wifi hardware installed'. Not ideal as I am miles away from Ethernet ......

  • Reese77 Calculating status...

    I have the exact same problem as mentioned above with the exception that my MacBook still connects to the internet when wired.

     

    My original post: https://discussions.apple.com/thread/4166568

  • StaceFaceAK Calculating status...

    I've been having this same issue and have found a temporary fix. Click your airport/wi-fi icon so you get the drop down menu, then click on Open Network Preferences. The menu bar on the left side of this box has your various connections, Ethernet and Wi-Fi, for example. When you try to toggle your wi-fi on/off, nothing happens, so what you have to do is select your Wi-Fi network, then click the ( - ) button on the bottom of that menu bar. This deletes the wi-fi connection (don't worry you can add it back later). Click Apply and restart your computer. Once you restart, go back to your Network Preferences and now click the ( + ) button. Add a new Wi-Fi network and turn it on. This should get you reconnected.

     

    Now, I had to do this once before I updated to Mountain Lion. After I updated, this has been a pretty persistant issue and while removing, restarting, and re-adding the Wi-Fi connection works, it's awfully annoying and inconvenient, so if anyone has a permanent solution it would be much appreciated.

     

    Hope this helps in the mean time!

  • reddevil13 Calculating status...

    Hey guys, i have the same problem on my Macbook Pro, after the update the wi-fi is not working. Wi-fi hardware not installed that's what it says.

  • aaadriannn Calculating status...

    I'm having this same issue since today!! I have restarted it several times, and suddenly it worked. I needed to restart it once again because it was super slow! Rainbow wheel all the time. And this time no wifi again!! I have MB LATE 2008 wh mountain lion; which pretty *****!!

  • aaadriannn Level 1 Level 1 (0 points)

    Ok, just tried staceface advise, and it does work!! Thanks!!

  • aaadriannn Level 1 Level 1 (0 points)

    THNKSSS works well!

  • Jimontour Calculating status...

    I just upgraded and I can get on the internet for any WiFi with the exception of my own Airport Time capsule everyone else in my office is on it the Airport (none of them are upgraded to Mountian) but I can not.

    Any suggestions?

  • aaadriannn Level 1 Level 1 (0 points)

    try staceface advice!

  • pomidorchi Calculating status...

    I have MacBook unibody late 2008 with OS X Mountain Lion on board. Wifi stopped working suddenly and I spent about four terrible hours to solve a problem.

     

     

    Actually, none of mentioned and googled advices helped me out to solve this issue with 'WiFi: No Hardware installed'.

     

     

    Except one thing: using the wifi kext from the Snow Leopard. You may use utility and kext from here: http://rys.sommefeldt.com/2011/09/04/osx-lion-wifi.html

     

     

    I hope, this can help.

  • pomidorchi Level 1 Level 1 (0 points)

    UPDATE:

     

    Few reboot/sleep cycles and wifi gone away again

    Wondering what to do next...

  • mcain1321 Level 1 Level 1 (0 points)

    Im having this same problem. I even just got the computer back from getting a new logic board in, i then wiped the harddrive and reinstalled Mountain lion. but not im getting this whole internet problem. It says there is no airport hardware installed and when i go into network pref. it doesnt even give me an option to (+ ) add a network setting. I know that the airport works though becuase it worked once when i restarted the computer and reset the PRAMUntitled 21 copy.jpgUntitled 2 copy.jpg

  • rvjacobs Calculating status...

    Hello you all,

     

    I also had the problem of a disconnecting wifi while my imac was sleeping. I did not have the reconnecting issue after sleep, but the lost connection issue during sleep which made it impossible to reach my imac for things like homesharing, apple tv or remote desktop. I have a late 2012 iMac with a clean ML 10.8.2 on it and wirelessly connected to an apple time capsule (same as an airport extreme). My partner has a mid 2007 iMac, also with an ML 10.8.2 on it.

     

    I tried every single solution I could find on the internet, such as changing the router's security from wpa2 to wpa, changing the MTU from automatic to manual 1453, router reboots, re-installations, re-configurations, keychain clean-ups, everything.

     

    Eventually I solved my problem with these steps and now it works as a charm. I can still find the iMac with the remote app, even after 12 hours of sleep:

     

    My time capsule router is set on automatic MTU and encrypted with WPA2 and I use  the 5Ghz network!

    1. Cleaned all the wifi passwords in keychain on my iMac

    2. Created a new network location in system preferences

    3. In this location I deleted the bluetooth pan and bluetooth dun connection.

    4. In this location I changed the preferred connection-order to wifi on #1 and ethernet on #2.

    5. Restarted my iMac.

     

    Now I still have a connection when it sleeps and I can wake it to low profile using the remote app (homesharing) and everything works fine.

     

    Hope more people wille be helped by this.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.