3 Replies Latest reply: Sep 17, 2012 1:23 AM by Ian O\'Brien
Ian O\'Brien Level 1 Level 1 (5 points)

Hi, I just bought an old imac DV...got OS9.0.4 up and running no probs...but some weird things are going on:

 

1) the system won't mount .smi or .sea disk image installers (system returns the message "an error of type -39 occured")

 

2) Installer apps (that by the way DO show up as 'classic' installers on my OSX intel mac) will not open - they simply show up on the iMac with a generic 'PC' icon and if you double click the system just tries to find an app to open it (which it can't).....these are supposed to be installers they shouldn't need translation.

 

Anyone got a clue what's happening here?

 

Thanks in advance for any help!


iMac DV (circa 1999), Mac OS 9.0.x
  • 1. Re: Mac oS9 .smi .sea images won't mount error -39
    Don Archibald Level 10 Level 10 (101,155 points)

    Re #1 -

     

    That error is most commonly caused by Stuffit Expander intruding where it should not. The download is in a .smi (self-mounting image) format, a format generated by Apple's Disk Copy. Stuffit Expander has ShrinkWrap technology built-in, which allows it to mount some kinds of disk images - but not .smi ones. Yet ShrinkWrap tries to - hence the error message.

     

    The solution - double-click Stuffit Expander, and open its Preferences (under the File menu). Select "Disk Images" from the list on the left, then turn off (uncheck) "Mount Disk Images". Quit Stuffit Expander.

     

    *****

     

    Re #2 -

     

    If it shows up as an installer app on an Intel machine (which must be running OS X since Intel machines can not run OS 9), then it may be an OS X program even though it is for Classic. This sounds contradictory, but on FW800 G4s and G5s OS 9 could be used only as Classic, not as a bootable OS. Hence, on those machines any installers for Classic had to be OS X programs.

     

    Another possibility - OS X does not use the embedded File Type and Creator codes which are required by OS 9. It is possible that those got stripped off. This often happens when an OS 9 item is downloaded to a PC and decompressed while still on the PC, but has been known to happen on a machine running later versions of OS X. The solution is to not decompress the download until it is on the OS 9 machine's hard drive.

  • 2. Re: Mac oS9 .smi .sea images won't mount error -39
    Gary - former developer Level 1 Level 1 (95 points)

    Another possibility exists as well. If the .smi or .sea file was encased in a ZIP archive, before you tried to use it, THAT would have caused the -39 error. Most (but not all) ZIP tools destroy the internal structure of any Mac format file processed by the tool.

     

    The result is error -39 when an unsuspecting user tries to open the file.

     

     

    Gary

  • 3. Re: Mac oS9 .smi .sea images won't mount error -39
    Ian O\'Brien Level 1 Level 1 (5 points)

    Thank you Gary, and to others who tried to help me.

     

    Actually it wasn't a .zip file but the problem was the same.

     

    I had unwittingly decompressed  a (made for os9) .smi.bin file on an OSX 10.7 Intel Mac.

     

    Result was confusing because a) When transferred, file showed up on OS9 desktop with the correct icon, so it seemed to be in order, and b) resulting decompressed .smi image also showed up correctly on OSX (Lion) and would even mount, although of course the OS9 installers had the 'white line' icon for obvious reasons.

     

    I thought one decompression on either OS was as good as another. Now I know better! Thank you again