Skip navigation

Airport says connection is strong but unable to load pages

12141 Views 18 Replies Latest reply: Jan 8, 2013 12:10 AM by clintonfrombirmingham RSS
1 2 Previous Next
Aarusso Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 16, 2012 2:44 PM

This is a new problem within the last couple of days. My Internet was working totally fine but all of a sudden now it says it is connected but web pages won't load at all with google chrome (up to date) or any other server. I've tried restarting the modem and router, the computer itself many times, resetting the location, resetting the DHCP lease, restarting "PRAM". Ethernet wasn't working either but I'm not sure that that is related. Network diagnostics says the Internet is connected. The wifi on my iPhone is working totally fine. I've tried emptying the cashe and no proxies are checked off. I've tried other wifi networks nearby which also don't work on my MacBook but my roommates aren't having any trouble at all with their pcs. Please help!!

I'm using a MacBook pro 2009 with os x 10.6.8, 2.26 GHz intel core 2 duo.

MacBook Pro, Mac OS X (10.6.8)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.