Skip navigation

USB tethering lost after downloading I-tunes 10.7

11434 Views 36 Replies Latest reply: Oct 16, 2013 8:36 AM by JF Paquette RSS
1 2 3 Previous Next
Judyant Calculating status...
Currently Being Moderated
Sep 18, 2012 11:10 PM

I lost all tethering (USB and Bluetooth) after I downloaded I-Tunes 10.7 on Sunday. I live in the country so personal hotspot is the ONLY way I can access the Internet. Network manager lists iPhone, but says the computer can't connect to the phone by Bluetooth or USB.

 

What I have already tried:

I used Time Capsule to restore to before the download (didn't help). I found a solution on this board for Lion (i have Snow Leopard) but I tried it anyway. I deleted the file AppleUSBEthernetHost.kext, re-installed I-tunes from the installer, restarted but it didn't help. Next i connected both iPhones to a friends mac - personal hotspot worked fine, so I know it is my mac.

 

I have never used " terminal", so if your solution needs it, please write simply because I don't know what I am doing! Lol.

iMac, Mac OS X (10.6.8), I-phone 3 Gs Personal hotspot
  • KC7GNM Level 4 Level 4 (2,720 points)
    Currently Being Moderated
    Sep 18, 2012 11:14 PM (in response to Judyant)

    First was your friend using lion on his mac? Second if so then your problem might be using snow leopard. You may want to upgrade if you are able to. I understand that power pc's can't upgrade to lion but if you are able to upgrade then I suggest going to Mountain Lion as I am not having a problem tethering with my macbook air running ML.

  • andrelukmana Calculating status...
    Currently Being Moderated
    Sep 19, 2012 2:31 AM (in response to Judyant)

    I have same problem after update iTunes 10.7 on snow leopard. my iphone 3gs personal hotspot not running on usb cable, but still run on bluetooth pairing. Please apple, fix itunes 10.7

     

    ---waiting for iOS 6--- tik..tok...tik...tokkk

  • Jclib Calculating status...
    Currently Being Moderated
    Sep 21, 2012 9:36 AM (in response to Judyant)

    Same problem here - I lost iPhone tethering over usb after the iTunes 10.7 upgrade.

     

    I previously had usb tethering fail after upgrading to iTunes 10.6.1 earlier this year. This was the problem of the iTunes upgrade installing a copy of AppleUSBEthernetHost.kext that didn't seem to work properly under 64 bit systems, which seemed to happen when you were also running the iPhone configuration utility -- see https://discussions.apple.com/thread/3787866?start=0&tstart=0. That problem was solved by fixing AppleUSBEthernetHost.kext, then going through some steps to make sure that things have the right permissions.

     

    After upgrading to iTunes 10.7 a few days ago, I lost USB tethering again. However the previous fixes don't seem to work. I've tried several old versions of AppleUSBEthernetHost.kext, and several reinstalls of iTunes.

     

    FYI, I'm using Mac OS X 10.6.8 runing on a MBP (Mar 2011, v 8,2) and I'm using an iPhone 4S. I just upgraded to iOS6 and had the same problem both before and after the iOS upgrade.

     

    Tethering over BlueTooth still works for me, but I'd prefer to get the usb running again.

     

    Not sure if the iTunes 10.6.1 upgrade problem is related to the 10.7 upgrade issue, but this is the second time that an iTunes upgrade has clobbered usb tethering.

  • snatchmo Calculating status...
    Currently Being Moderated
    Sep 22, 2012 6:57 PM (in response to Judyant)

    Hi All,

     

    I had this problem with the last iTunes update as well.  I've done as the rest of you and restored /system/library/extensions/appleusbethernethost.kext from a backup and all is well.  Apple has about cured me of updating iTunes.  The new .kext installed with 'Tunes 10.7 is 119kb and the one prior to 10.6.3 is 189kb. The 189kb one is the one that works for me.  I tried just replacing the .kext in system/library/extensions/appleusbethernerhost.kext/contents/macos and this did not work for me.  Therefore replace the folder in system/library/extensions.

     

    rots o' ruck

  • achtungbaby297 Calculating status...
    Currently Being Moderated
    Sep 23, 2012 7:01 PM (in response to snatchmo)

    Thanks for the help...and instructions.

     

    Solved my problems here.

  • Paperinik77 Calculating status...
    Currently Being Moderated
    Sep 24, 2012 2:54 AM (in response to Judyant)

    Good morning! I have a problem with tethering to my iMac (operating system 10.6.8, iTunes 10.7) - never worked (I tried first time yesterday)...while with the same iPhone (3G, software 4.2.1) I can use tethering with my MacBookPro (operating system 10.5.8, iTunes 10.3.1). In my iMac I cannot see anything in Preferences/Network while in MacBookPro there is the connection which I named iPhone USB. It seems my iMac can't see the function Tethering fron iPhone...can anybody help me? I tried to replace the file AppleUSBEthernetHost.kext (the file from MacBookPro (may 2009) instead of the one of iMac (March 2010) but it doesn't work...and I'm afraid to make the same with the whole directory...HELP, ME PLEASE!

  • vtsir Calculating status...

    Thank you! I copied the entier packate (AppleUSBEthernetHost.kext) from an old backup, rebooted and the problem was solved

  • Paperinik77 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 25, 2012 8:19 AM (in response to vtsir)

    And that's what I did but it doesn't work! I'm almost desperate...can anybody help me?

  • AngeloWish Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 26, 2012 1:34 PM (in response to Judyant)

    What if I have TimeMachine disabled? No way to obtaining a working KEXT file?

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.