Skip navigation

wifi keeps disconnecting

91966 Views 53 Replies Latest reply: Dec 26, 2013 4:23 PM by Nuvin RSS
  • ian5251 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 19, 2012 4:49 PM (in response to TWIZTD__)

    I had the same problem on my 4S after updating to iOS6.  Without WiFi, I decided I would be better off restoring my phone back to 5.1.1.  Using iTunes to restore the phone, I found that the only backup available to restore from was a very recent backup that was made after the upgrade to iOS 6, which wasn't what I wanted, but turns out that it was what I needed.

     

    After restoring the iOS6 backup, my WiFi is now working.  Why?  Don't know and to be honest I don't care - I'm just glad to have my WiFi working!!!

     

    YMMV

     

    Ian

  • MyermanCMYK Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 19, 2012 4:51 PM (in response to TWIZTD__)

    Ok. Thanks to a recent post I tried one suggestion and it worked for me. In the wi-if settings click on the blue arrow by your network, then set HTTP proxy to Auto. Then back out to the network selection screen.

     

    As soon as I did that, then went back in and selected the proxy to be off, I'm able to connect again.

     

    Yea!!

  • ebeast23 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 19, 2012 4:51 PM (in response to TWIZTD__)

    Ok guys, just figured out how to fix it. I spent the last hour trying all sorts of things so take that in mind.

    I have an iphone 4s and just upgraded to ios6.

     

    Steps i went through:

    1. Reset safari. (although i use google chrome)
    2. Restarted the iphone. (i did this a lot)
    3. Turned off my wifi
    4. Turned off iphone (I let it sit for about 10-15 secs)
    5. Restarted iphone
    6. Turned back on wifi...prayed...and it worked

     

    Im still having issues with "Top 25" and "Categories" in the app store....Any ideas?

  • BlakeMAC027 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 19, 2012 4:57 PM (in response to TWIZTD__)

    @BlakeMAC27 The problem was with a page hosted on Apple's web site that every iOS device checks when you sign on to wi-fi. They fixed it.

  • Livverrs Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 19, 2012 4:58 PM (in response to TWIZTD__)

    Had the same exact problem. On a whim I tried turning off Bluetooth and the Wifi connected with no problem. Not sure what I'll do if I want to use both before the problem gets fixed. At least the problem is fixed for now though.

  • danliebke Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 19, 2012 5:01 PM (in response to wmeyer51)

    @wmeyer51

     

    Bizarrely, that worked for me too. It doesn't make much sense and it may be a coincidence, but my wi-fi is now working.

  • etjzu2012 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 19, 2012 5:09 PM (in response to TWIZTD__)

    Hi there, I just have the same problem, It shows the same message. What I found was that this new IOS check if everything is okey about your account information. I already check my iCloud account and I notice that this new version see that I don't have my security number for my credit card. After I wrote the number, everything start working Okay. I have back my wi-fi conection back.

     

    Thanks

  • tarorleans Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 19, 2012 5:13 PM (in response to TWIZTD__)

    Mine started working again. I didn't do any of the Proxy stuff. Not sure what I did.

  • prashanth reddy yanala Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 19, 2012 5:14 PM (in response to ian5251)

    hi

    do this it will work fine

    go to settings>privacy>switch off location services. it will definetly work

  • CO83 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 19, 2012 6:03 PM (in response to ebeast23)

    I think I did what ebeast recommended and I have a solid connection now. I not only turned off my wifi on the phone and the phone itsself, but I also uplugged and reset my router.  Plugged everything back, turned everything back to ON, and it's good! (Or maybe Apple website fixed it.)

  • Doug.G Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 25, 2012 2:22 AM (in response to TWIZTD__)

    Hit the blue arrow next to your network name and change the Proxy to AUTO at the bottom of the screen.

  • Videogreg Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 2, 2012 12:40 PM (in response to shmorgan)

    I run a number of wifi hotspots, all of which use a captive portal "Splash Page" that is branded per location.

     

    Since the iOS6 update I have been swamped with guests and customers complaining about this www.apple.com "success" page popping up instead of the intended customers login and terms acceptance page. When cancelling it drops the wifi router connection and there is no way to connect to the intended free wifi hotspot.

     

    The problem is in Apple's update, there currently is no way to disable this unwanted feature.

     

    The solution is to go to your Settings>General>Cellular>Cellular Data and turn it OFF when you are at the hotspot location.

     

    Now when you choose the hotspot's SSID and join it......you will get the sign in page from the captive portal and not the "success" page.

     

    Be sure and turn the Cellular Data back on.....when you leave the hotspot.

     

    Apple needs to fix this WISPr function, I am only a small provider and I am sure that worldwide there are going to be hundreds of thousands of iphone, ipad and laptop users who will no longer be able to sign on at wifi hotspots, work, universities, hospitals and hotels.

     

    As a side note: I have an older 4S phone with iOS6 and I cannot join.....my wife has a newer 4S phone with iOS6 installed and even though both our phones are set exactly the same......she can connect without turning off her cellular data and I cannot.   Curious?

  • wondersuzy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 15, 2012 9:09 AM (in response to MyermanCMYK)

    Thanks, I tried a lot of other ways, this worked

     

    thank you!

  • wondersuzy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 15, 2012 9:10 AM (in response to wondersuzy)

    ah when it goes back to sleep it disconnects again

  • Mistrblank Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 16, 2012 6:09 AM (in response to BlakeMAC027)

    How exactly did apple fix the fact that my device still wants to access a site that my corporate Intranet can't access (and is flagged as a Websense block)?

     

    The fix would be to remove this requirement.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.