Skip navigation

Aperture 3.4 will not open after 10.8.2 installed

13469 Views 78 Replies Latest reply: Nov 28, 2012 4:09 PM by FarNorth_1 RSS
1 2 3 ... 6 Previous Next
psychotic1 Level 1 Level 1 (10 points)
Currently Being Moderated
Sep 19, 2012 11:44 PM

I updated Aperture to 3.4. I opened the Application.  It said it needed to upgrade my libarry, then immediately quit and returned an "Aperture quit unexpectedly" error.  I reopened Aperture. It said "finding Aperture Library" then immediately quit, returning another "Aperture quit unexpectedly" error.  I get the same result over and over, even with the "shift" key held down when attempting to open the application. 

 

I also get the same result when holding the "option" key down (it does show me a list of available libraries and lets me select one, but then returns the error). The first time I tried this, I selected the most recent library dated prior to the upgrade.  When I got no joy, I tried again and that library now no longer appears in the list. And I cannot open any of the libraries that do.

 

If I can't even launch the application, I can't rebuild the library. I've searched the discussions and googled this problem to no avail.  Any ideas, anyone?

  • Clem Level 3 Level 3 (550 points)
    Currently Being Moderated
    Sep 20, 2012 12:36 AM (in response to psychotic1)

    Do the comments in the other current threads help you with what you are seeing? Is it the same? Can you post the first 50 or so lines of your crash log?

  • obo23 Calculating status...
    Currently Being Moderated
    Sep 20, 2012 12:46 AM (in response to psychotic1)

    U are not alone…Have the same problem:

     

    Process:         Aperture [455]

    Path:            /Applications/Aperture.app/Contents/MacOS/Aperture

    Identifier:      com.apple.Aperture

    Version:         3.4 (3.4)

    Build Info:      Aperture-301036000000000~1

    Code Type:       X86-64 (Native)

    Parent Process:  launchd [193]

    User ID:         502

     

     

    Date/Time:       2012-09-20 09:28:30.771 +0200

    OS Version:      Mac OS X 10.8.2 (12C54)

    Report Version:  10

     

     

    Interval Since Last Report:          2686 sec

    Crashes Since Last Report:           20

    Per-App Interval Since Last Report:  1515 sec

    Per-App Crashes Since Last Report:   18

    Anonymous UUID:                      91BC3EE9-0E92-E36D-7A22-1E49A6156929

     

     

    Crashed Thread:  13  Dispatch queue: com.apple.root.default-priority

     

     

    Exception Type:  EXC_CRASH (SIGABRT)

    Exception Codes: 0x0000000000000000, 0x0000000000000000

     

     

    Application Specific Information:

    *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '*** -[NSURL initWithScheme:host:path:]: path 1275945029 is not absolute.'

    terminate called throwing an exception

    abort() called

     

     

    Application Specific Backtrace 1:

    0   CoreFoundation                      0x000000010ba880a6 __exceptionPreprocess + 198

    1   libobjc.A.dylib                     0x000000010df793f0 objc_exception_throw + 43

    2   CoreFoundation                      0x000000010ba87e7c +[NSException raise:format:] + 204

    3   Foundation                          0x000000010da22de8 -[NSURL(NSURL) initWithScheme:host:path:] + 112

    4   PrintServices                       0x000000010d29ac6d +[NSURL(ISNSURLExtensions) URLWithScheme:host:path:] + 61

    5   PrintServices                       0x000000010d29abef -[NSURL(ISNSURLExtensions) URLByAppendingPathComponent:] + 127

    6   FacebookPublisher                   0x0000000127b767f2 -[ILFacebookAPIRequest graphURLRequest] + 215

    7   FacebookPublisher                   0x0000000127b76fb5 -[ILFacebookAPIRequest send] + 33

    8   FacebookPublisher                   0x0000000127b684da -[IPHFacebookPlugin displayNameForUsername:] + 88

    9   AccountConfigurationPlugin          0x000000010ae00fa5 -[AccountConfigurationProfileInformationDownloadOperation main] + 174

    10  Foundation                          0x000000010da79986 -[__NSOperationInternal start] + 684

    11  Foundation                          0x000000010da811a1 __block_global_6 + 129

    12  libdispatch.dylib                   0x0000000110d82f01 _dispatch_call_block_and_release + 15

    13  libdispatch.dylib                   0x0000000110d7f0b6 _dispatch_client_callout + 8

    14  libdispatch.dylib                   0x0000000110d801fa _dispatch_worker_thread2 + 304

    15  libsystem_c.dylib                   0x0000000110e1bcab _pthread_wqthread + 404

    16  libsystem_c.dylib                   0x0000000110e06171 start_wqthread + 13

     

     

    Thread 0:: Dispatch queue: com.apple.main-thread

    0   libsystem_kernel.dylib                  0x0000000110f8d30e __rmdir + 10

    1   libsystem_kernel.dylib                  0x0000000110f8c2c9 rmdir + 11

    2   com.apple.Foundation                    0x000000010dab588d _NSCleanupTemporaryDirectory + 39

    3   com.apple.Foundation                    0x000000010da8e200 _NSWriteBytesToFileWithExtendedAttributes + 1401

    4   com.apple.Foundation                    0x000000010dab5209 _NSWriteBytesToFile + 26

    5   com.apple.Foundation                    0x000000010dab51e3 -[NSData(NSData) writeToFile:atomically:] + 90

    6   com.apple.Foundation                    0x000000010da0ddec -[NSDictionary(NSDictionary) writeToFile:atomically:] + 239

    7   com.apple.RedRock                       0x000000010a25daf3 -[RKDatabase writeDataModelVersionWithVersionCount:] + 1509

    8   com.apple.Aperture                      0x0000000109d1e6d7 0x1097e3000 + 5486295

    9   com.apple.Aperture                      0x0000000109d1e8ba 0x1097e3000 + 5486778

    10  com.apple.Aperture                      0x0000000109d185f9 0x1097e3000 + 5461497

    11  com.apple.Aperture                      0x0000000109d170cc 0x1097e3000 + 5456076

    12  com.apple.Aperture                      0x0000000109d16d98 0x1097e3000 + 5455256

  • Pachacor92 Calculating status...
    Currently Being Moderated
    Sep 20, 2012 12:49 AM (in response to psychotic1)

    I have the same problem

  • obo23 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 20, 2012 12:54 AM (in response to psychotic1)

    Same here

     

    user/library/Preferences

    delete "com.apple.Aperture.plist"

     

    thanks!

  • mstisen Calculating status...
    Currently Being Moderated
    Sep 20, 2012 1:23 AM (in response to obo23)

    Hmm i can't fint the "com.apple.Aperture.plist" file in my libary? any other suggestions?

  • Palindrom Calculating status...
    Currently Being Moderated
    Sep 20, 2012 1:27 AM (in response to mstisen)

    Same here! No "com.apple.Aperture.plist"-file (OSX 10.7.5)

  • léonie Level 8 Level 8 (46,460 points)
    Currently Being Moderated
    Sep 20, 2012 1:32 AM (in response to mstisen)

    Hmm i can't fint the "com.apple.Aperture.plist" file in my libary? any other suggestions?

    In the recent MacOS versions LIon/Mt. Lion the user Library is hidden.

    You can reveal it from the Finder's "Go" menu in the main menu bar:

     

    Finder > Go

     

    Then hold down to options-key ⌥, until Library appears in the drop-down menu. Select it and open the Library.

    In the window that opens select the "Preferences" folder - you will find the Aperture.plist there. Move it to the Desktop, then try again to launch Aperture.

     

    Removing the preference file will result in reverting all preferences you set using the "Preference" panel to default, also the layout of the GUI and the "recent" file list, but all your "Presets" will not be changed.

     

    Regards

    Léonie

  • David Gordon Calculating status...
    Currently Being Moderated
    Sep 20, 2012 1:32 AM (in response to mstisen)

    Are you looking in the correct Library? Its in your 'user' Library. That's hidden by default. Find it in Finder by holding the 'alt' key and looking in the 'Go' menu. 'Alt' will show/hide the Library.

  • nolti Calculating status...
    Currently Being Moderated
    Sep 20, 2012 2:10 AM (in response to léonie)

    Danke für die gute Beschreibung. Läuft alles wieder

  • Palindrom Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 20, 2012 2:16 AM (in response to nolti)

    THX psychotic1 for your precise instructions. Helped me to fix it!

    Danke für die Beschreibung! Läuft wieder!

  • léonie Level 8 Level 8 (46,460 points)
    Currently Being Moderated
    Sep 20, 2012 2:17 AM (in response to nolti)

    Prima!

1 2 3 ... 6 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.