1 2 3 4 Previous Next 47 Replies Latest reply: Oct 5, 2012 2:56 PM by Aye Es Oh
JamesRHarker Level 1 Level 1 (0 points)

I (like others in this forum) are finding Aperture 3.4 crashing. The advice on other threads is to delete Aperture's plist.  It is not in my Libary/Preferences folder (I assume because it was reinstalling).  My crash report appears to be a bit different than others.


Process:         Aperture [1089]

Path:            /Applications/Aperture.app/Contents/MacOS/Aperture

Identifier:      com.apple.Aperture

Version:         3.4 (3.4)

Build Info:      Aperture-301036000000000~2

App Item ID:     408981426

App External ID: 10581304

Code Type:       X86-64 (Native)

Parent Process:  launchd [350]



Date/Time:       2012-09-19 20:54:51.791 -0700

OS Version:      Mac OS X 10.7.5 (11G56)

Report Version:  9



Interval Since Last Report:          9217 sec

Crashes Since Last Report:           3

Per-App Crashes Since Last Report:   1

Anonymous UUID:                      8FFD9E86-9991-47EF-9752-086B981753CA



Crashed Thread:  0




Exception Codes: 0x0000000000000002, 0x0000000000000000



Application Specific Information:

dyld: launch, loading dependent libraries



Dyld Error Message:

  Library not loaded: @executable_path/../Frameworks/PrintServices.framework/Versions/A/PrintServices

  Referenced from: /Applications/Aperture.app/Contents/MacOS/Aperture

  Reason: image not found



Binary Images:

       0x101ff6000 -        0x102747fff  com.apple.Aperture (3.4 - 3.4) <F66E6C13-82C8-3C10-91D2-6A749047429F> /Applications/Aperture.app/Contents/MacOS/Aperture

       0x102968000 -        0x102970ff7  com.apple.PhotoFoundation (1.0 - 1.14) <A1F27E41-CD9E-31F0-8F21-887555E1D576> /Applications/Aperture.app/Contents/Frameworks/PhotoFoundation.framework/Versio ns/A/PhotoFoundation

       0x1029e8000 -        0x102f04fff  com.apple.RedRock (1.9.4 - 301.35) <6425F20F-6955-3997-9AEC-4E7198FC6111> /Applications/Aperture.app/Contents/Frameworks/RedRock.framework/Versions/A/Red Rock

       0x10320d000 -        0x10328ffff  com.apple.iLifePageLayoutCore (1.0 - 176.10) <654893D7-EFC0-3E3F-A766-8C64227FF301> /Applications/Aperture.app/Contents/Frameworks/iLifePageLayoutCore.framework/Ve rsions/A/iLifePageLayoutCore

       0x1032f2000 -        0x1032f7fff  com.apple.iLifePhotoStreamConfiguration (3.4 - 2.5) <906317D7-09FF-3B77-8F35-01BB74C0109C> /Applications/Aperture.app/Contents/Frameworks/iLifePhotoStreamConfiguration.fr amework/Versions/A/iLifePhotoStreamConfiguration

       0x103305000 -        0x103334ff7  com.apple.iLifeAssetManagement (2.7 - 31.34) <C39032ED-C0EA-3204-A272-C0C5318AC8C2> /Applications/Aperture.app/Contents/Frameworks/iLifeAssetManagement.framework/V ersions/A/iLifeAssetManagement

       0x103366000 -        0x103373ff7  com.apple.iphoto.AccountConfigurationPlugin (1.2 - 1.2) <DB1DA508-491A-3B79-B3EC-CFE31C9C9497> /Applications/Aperture.app/Contents/Frameworks/AccountConfigurationPlugin.frame work/Versions/A/AccountConfigurationPlugin

       0x103389000 -        0x10342cff7  com.apple.MobileMe (13 - 1.0.4) <9A7FCC99-67CE-3F5E-98BB-9079B305087F> /Applications/Aperture.app/Contents/Frameworks/MobileMe.framework/Versions/A/Mo bileMe

       0x1034a8000 -        0x1034b6fff  com.apple.PluginManager (1.7.6 - 55) <ABA41202-6D4F-368A-BE19-BD1729AF074A> /Library/Frameworks/PluginManager.framework/Versions/B/PluginManager

       0x1034c6000 -        0x1034d7fff  com.apple.AERegistration (1.2 - 401) <16C4537B-4989-3DF7-8263-588F5C882063> /Applications/Aperture.app/Contents/Frameworks/AERegistration.framework/Version s/A/AERegistration

       0x1034f2000 -        0x10376dff7  com.apple.prokit (7.2.3 - 1823) <0D6BA804-8262-3942-B84D-B4886082242F> /System/Library/PrivateFrameworks/ProKit.framework/Versions/A/ProKit

       0x1038f7000 -        0x103c9bfff  com.apple.iLifeSlideshow (3.1 - 1151.4) <61A831CA-B996-3762-B3DD-85A3CB46F28D> /Applications/Aperture.app/Contents/Frameworks/iLifeSlideshow.framework/Version s/A/iLifeSlideshow

       0x103e1d000 -        0x103e34ff7  com.apple.iLifeFaceRecognition (1.0 - 30.11) <46E3C666-EE15-324E-85D0-E56ECA0A342D> /Applications/Aperture.app/Contents/Frameworks/iLifeFaceRecognition.framework/V ersions/A/iLifeFaceRecognition

    0x7fff61bf6000 -     0x7fff61c2abaf  dyld (195.6 - ???) <0CD1B35B-A28F-32DA-B72E-452EAD609613> /usr/lib/dyld

    0x7fff834ea000 -     0x7fff8380fff7  com.apple.AddressBook.framework (6.1.3 - 1091) <5A8BEED1-229C-3A9C-8281-581127A1B9B5> /System/Library/Frameworks/AddressBook.framework/Versions/A/AddressBook

    0x7fff83d78000 -     0x7fff83dc4ff7  com.apple.SystemConfiguration (1.11.3 - 1.11) <0A7F1982-B4EA-3424-A0C7-FE46C6224F03> /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfi guration

    0x7fff83e6f000 -     0x7fff8400fff7  com.apple.QuartzCore (1.7 - 270.5) <19E5E0AB-DAA9-3F97-988C-D9A46AFB9C04> /System/Library/Frameworks/QuartzCore.framework/Versions/A/QuartzCore

    0x7fff86268000 -     0x7fff862d3ff7  com.apple.framework.IOKit (2.0 - ???) <FE838BB6-D42E-3291-A1A0-6F53FC970261> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit

    0x7fff86e55000 -     0x7fff86fdfff7  com.apple.WebKit (7534.57 - 7534.57.7) <15AA1A2E-DCAC-35CE-89DF-0FF7149198CD> /System/Library/Frameworks/WebKit.framework/Versions/A/WebKit

    0x7fff8714d000 -     0x7fff8714dfff  com.apple.audio.units.AudioUnit (1.7.3 - 1.7.3) <04C10813-CCE5-3333-8C72-E8E35E417B3B> /System/Library/Frameworks/AudioUnit.framework/Versions/A/AudioUnit

    0x7fff87198000 -     0x7fff872f5fff  com.apple.audio.toolbox.AudioToolbox (1.7.3 - 1.7.3) <5F1E4695-BC74-3ADD-8345-627BCD68201A> /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox

    0x7fff8836f000 -     0x7fff8836ffff  com.apple.ApplicationServices (41 - 41) <03F3FA8F-8D2A-3AB6-A8E3-40B001116339> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Application Services

    0x7fff893e2000 -     0x7fff89475fff  com.apple.PDFKit (2.6.4 - 2.6.4) <4C58283C-3F45-31C6-9896-5EFFFF82D840> /System/Library/Frameworks/Quartz.framework/Versions/A/Frameworks/PDFKit.framew ork/Versions/A/PDFKit

    0x7fff896c2000 -     0x7fff8972aff7  com.apple.audio.CoreAudio (4.0.3 - 4.0.3) <9987DC46-2A96-3BA0-B88B-04E573C0AD9B> /System/Library/Frameworks/CoreAudio.framework/Versions/A/CoreAudio

    0x7fff89bb9000 -     0x7fff89bbffff  com.apple.DiskArbitration (2.4.1 - 2.4.1) <CEA34337-63DE-302E-81AA-10D717E1F699> /System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration

    0x7fff89bcc000 -     0x7fff89bccfff  com.apple.Carbon (153 - 153) <895C2BF2-1666-3A59-A669-311B1F4F368B> /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon

    0x7fff8a250000 -     0x7fff8a3dbff7  com.apple.QTKit (7.7.1 - 2339) <2BC2CF44-CEAF-3D3B-A250-CA59D6AFB0B0> /System/Library/Frameworks/QTKit.framework/Versions/A/QTKit

    0x7fff8a51a000 -     0x7fff8a786ff7  com.apple.AOSKit (1.021 - 94) <530546F3-F01C-3A89-8477-C800EFE59593> /System/Library/PrivateFrameworks/AOSKit.framework/Versions/A/AOSKit

    0x7fff8b21a000 -     0x7fff8b50fff7  com.apple.security (7.0 - 55148.6) <4535E500-973A-3BA7-AF65-DF5CF0658F02> /System/Library/Frameworks/Security.framework/Versions/A/Security

    0x7fff8b5d2000 -     0x7fff8b5d2fff  com.apple.CoreServices (53 - 53) <043C8026-8EDD-3241-B090-F589E24062EF> /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices

    0x7fff8c563000 -     0x7fff8c563fff  com.apple.Cocoa (6.6 - ???) <021D4214-9C23-3CD8-AFB2-F331697A4508> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa

    0x7fff8c624000 -     0x7fff8c624fff  com.apple.quartzframework (1.5 - 1.5) <21FCC91F-C7B9-304F-8C9C-04F3924F4AE3> /System/Library/Frameworks/Quartz.framework/Versions/A/Quartz

    0x7fff8d7c0000 -     0x7fff8d7cffff  com.apple.opengl (1.8.1 - 1.8.1) <51B34133-CEE3-3FC6-82AC-ADF567AE673C> /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL

    0x7fff8dd11000 -     0x7fff8dd11fff  com.apple.Accelerate (1.7 - Accelerate 1.7) <82DDF6F5-FBC3-323D-B71D-CF7ABC5CF568> /System/Library/Frameworks/Accelerate.framework/Versions/A/Accelerate

    0x7fff8e0f1000 -     0x7fff8e17ffff  com.apple.iLifeMediaBrowser (2.6.4 - 502.4.5) <A19798B7-E1A6-3117-8094-8D3A2CAB417F> /System/Library/PrivateFrameworks/iLifeMediaBrowser.framework/Versions/A/iLifeM ediaBrowser

    0x7fff8e1e9000 -     0x7fff8e3bdff7  com.apple.CoreFoundation (6.7.2 - 635.21) <62A3402E-A4E7-391F-AD20-1EF20236CE1B> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation



Model: MacBookPro6,2, BootROM MBP61.0057.B0F, 2 processors, Intel Core i5, 2.53 GHz, 8 GB, SMC 1.58f16

Graphics: NVIDIA GeForce GT 330M, NVIDIA GeForce GT 330M, PCIe, 256 MB

Graphics: Intel HD Graphics, Intel HD Graphics, Built-In, 288 MB

Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1067 MHz, 0x0198, 0x393930353432382D3030352E4130324C4620

Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1067 MHz, 0x0198, 0x393930353432382D3030352E4130324C4620

AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x93), Broadcom BCM43xx 1.0 (

Bluetooth: Version 4.0.8f17, 2 service, 18 devices, 1 incoming serial ports

Network Service: Wi-Fi, AirPort, en1

Serial ATA Device: TOSHIBA MK5061GSY, 500.11 GB

Serial ATA Device: MATSHITADVD-R   UJ-898, 3.33 GB

USB Device: hub_device, 0x0424  (SMSC), 0x2514, 0xfa100000 / 2

USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0xfa130000 / 5

USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0236, 0xfa120000 / 4

USB Device: BRCM2070 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0xfa110000 / 3

USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8218, 0xfa113000 / 6

USB Device: hub_device, 0x0424  (SMSC), 0x2514, 0xfd100000 / 2

USB Device: IR Receiver, apple_vendor_id, 0x8242, 0xfd120000 / 4

USB Device: Built-in iSight, apple_vendor_id, 0x8507, 0xfd110000 / 3

Aperture 3, Mac OS X (10.7.5)
  • 1. Re: aperture 3.4 crashing
    Clem Level 3 Level 3 (550 points)

    Looks like its a bad install, there is a missing required framework, PrintServices....guessing you did an upgrade as part of the install from a previous version of Aperture.  Delete the app you have, and empty trash. Go back to the App Store and just reinstall the app, but this time it will be from scratch.  Try this and report back if you have success.

  • 2. Re: aperture 3.4 crashing
    Chris Connors Level 1 Level 1 (120 points)

    Good suggestion, unless you bought Aperture on physical media, which I did.

  • 3. Re: aperture 3.4 crashing
    Clem Level 3 Level 3 (550 points)

    Hi Chris, if you are having this problem, ie, you have the wrong or missing framework, the answer is presuambly the same (ultimately), ie, install from DVD (version 3.0 or 3.1, whichever you have) and go straight to 3.4 with the update in sw update.  What are you seeing problem-wise and what have you tried to fix it? That will shed light on if it's the same issue or no...

  • 4. Re: aperture 3.4 crashing
    Kamdaswani Level 1 Level 1 (0 points)

    yes, have the dvd as well and can't even get it to load after the update .. it just says repairing library and the the crash report pops up

  • 5. Re: aperture 3.4 crashing
    William Lloyd Level 6 Level 6 (19,350 points)

    Did you install from the DVD and then update to Aperture 3.4 _before_ trying to open Aperture?


    If you completely deleted Aperture, installed from DVD, and then updated to Aperture 3.4, and it's still crashing, then launch it with command and option held down.  When you get the popup, try repair library, and if that crashes try it again and select rebuild library.

  • 6. Re: aperture 3.4 crashing
    kaz78 Level 1 Level 1 (0 points)

    I had the same problems and tried repairing the library etc. which all ended up crashing. So, I went to my user/library/Preferences and moved the file "com.apple.Aperture.plist" to the desktop and restarted Aperture and it worked. Hope this helps.

  • 7. Re: aperture 3.4 crashing
    Robert Follis Level 1 Level 1 (5 points)

    Deleting prefs as per kaz78 sorted my problem,. Aperture then recided to repair my library and took ages to open. Still some odd behaviour though

  • 8. Re: aperture 3.4 crashing
    JohnTheAppleFan Level 3 Level 3 (690 points)

    After removing com.apple.Aperture.plist, I opened Aperture by double-clicking on the Aperture library instead of on the Aperture icon.  It worked fine and didn't try and re-repair it.

  • 9. Re: aperture 3.4 crashing
    Chris Connors Level 1 Level 1 (120 points)

    My crash is related to opening libraries that have Facebook accounts associated with them. If I create a new library, it launches fine; as soon as I associate a Facebook signin with that library it crashes.

  • 10. Re: aperture 3.4 crashing
    Clem Level 3 Level 3 (550 points)

    Chris, yes you have the same problem. Just delete the old app, and reinstall, then update. You can leave your prefs.

  • 11. Re: aperture 3.4 crashing
    Clem Level 3 Level 3 (550 points)


    Your library is probably fine, as are your prefs. Its an install problem.  Deleting prefs are a temp solution only.


    Just delete the app and reinstall form your source media (dvd) and update directly to 3.4 (or Redownload from app store); that fixes the problem, ie, a missing or incorrect version of the PrintServices framework in the application.  

    You can leave your old prefs, the key is deleting your old app copy on your system and starting from an earlier version.


    Make sense?  Try that and report back what you find.

  • 12. Re: aperture 3.4 crashing
    Robert Follis Level 1 Level 1 (5 points)

    Facebook destroys Aperture. Fine without. As soon as you add FB, app locks-up totally


    Any ideas on FB problem?


    Cheers Robert

  • 13. Re: aperture 3.4 crashing
    Robert Hurt1 Level 1 Level 1 (95 points)

    Yeah, same issue here. Just trashing the prefs (and not reinstalling the app) was all I needed to get it to run, but as soon as I tried to add a FB account in preferences... crash.


    Clearly Aperture hasn't been fully updated to handle the account-wide facebook login... I hope they fix the crash before that happens or we are screwed!

  • 14. Re: aperture 3.4 crashing
    Adam Burnett Level 1 Level 1 (0 points)

    Am having the same problem as above but am worried about deleting the app and then reinstalling (I have a physical disk, not from app store). 


    My main concern is that I will be deleting the 20,000 plus pics that I already have in my library.  Am I correct in assuming that the program itself and all the files related to photos are totally seperate? 


    Many thanks!

1 2 3 4 Previous Next