Skip navigation

Spotlight not working correctly

57368 Views 148 Replies Latest reply: Feb 21, 2014 10:18 AM by Todd Jacobs RSS
1 2 3 ... 10 Previous Next
Jean-Luc Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 20, 2012 10:55 PM

Since I made ​​the  Lion update  10.7.5,my  Externals HDD LaCie FW800 (4 X  2 To ) since  yesterday  after a reboot the index can not be done.

 

 

He told me about 2 days time remaining

 

 

There should see a bug?

 

My Mac :

Mac 27" Intel Core i7 2,8 GHz 8GB Ram HD 2TB ATI Radeon HD 4850  10.7.5

iMac, Mac OS X (10.7.5)
  • Leslie Burnett Calculating status...
    Currently Being Moderated
    Sep 21, 2012 3:32 AM (in response to Jean-Luc)

    I have a very similar problem. Since upgrading Lion to 10.7.5, Spotlight is unable to index the *main* OS X drive. It reports 3-4 days on one system (with a SSD drive), and 7 weeks! on another system (with a standard HDD). Before the upgrade, indexing the drive usually only took 2-3 hours.

     

    I have tried resetting Spotlight (via System Preferences/Spotlight/Privacy/Stop indexing by adding HDD to the Privacy list, then restart indexing by removing HDD from the Privacy list. This did not fix the problem. I also tried Titanium Onyx, but again didn't fix the problem.

     

    So I agree. The upgrade to 10.7.5 seems to have slowed Spotlight indexing to be almost unusable. I hope Apple has this listed as a bug.

  • OlivierDo Calculating status...
    Currently Being Moderated
    Sep 21, 2012 2:02 PM (in response to Leslie Burnett)

    I can confirm this behaviour here to. Mac OS Lion Server 10.7.5.

  • Larry Nolan Level 2 Level 2 (165 points)
    Currently Being Moderated
    Sep 21, 2012 5:33 PM (in response to OlivierDo)

    Seeing 26 hours remaining on Spotlight reindexing my internal HD on iMac since 10.7.5.  Sigh.

  • OlivierDo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 22, 2012 3:16 PM (in response to OlivierDo)

    some logfiles

     

    23.09.12 00:05:02,779 mdworker: (Error) Import: sniffer paths array empty

    23.09.12 00:05:03,481 mdworker: Unable to talk to lsboxd

    23.09.12 00:08:03,556 mds: (Error) ImportServer: <MDSImporterWrangler: 0x7fba704b84d0> still waiting for plug-in info from mdworker

  • HerrDrKarl Level 1 Level 1 (15 points)
    Currently Being Moderated
    Sep 22, 2012 6:30 PM (in response to Jean-Luc)

    Same problem since 10.7.5 update... 8 days remaining now (for 300 GB of data)!!

     

    Have tried all kinds of stuff - restarting in Safe mode, clearing caches, clearing Spotlight and restarting.  Never took more than a few hours.  Cannot run a Time Machine backup until this finishes.  Before I cleared the spotlight index - because Time Machine in 10.7.5 became outrageously slow - it was taking Time Machine 30 minutes to back up 30 MB - something that until 10.7.5 only took 2 seconds.

     

    Apple, please do something! Where were the beta testers?!

     

     

    8 days remaining.jpg

  • Doug Lockett Calculating status...
    Currently Being Moderated
    Sep 22, 2012 8:17 PM (in response to HerrDrKarl)

    There is clearly an issue with Spotlight in 10.7.5.

     

    The slow TIme Machine issue is related to Spotlight. If you want to back up with Time Machine, there is a current workaround where you can suspend Spotlight first. I used a sharware utility called Spotless to accomplish this (available here: http://www.fixamacsoftware.com/software/spot4/index.php)

     

    Others have pointed out that you can enable/disable spotlight with some terminal commands. You can find them here: http://osxdaily.com/2011/12/10/disable-or-enable-spotlight-in-mac-os-x-lion/

     

    This doesn't work around the underlying issue with Spotlight, but it does allow you to use Time Machine to perform a backup in a reasonable amount of time (I backed up my 250GB in about 3 hours).

  • HenryAZ Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 23, 2012 6:10 AM (in response to Doug Lockett)

    I am noticing the same issue, immediately following the upgrade to 10.7.5 (combo download).  I see the same behavior on two entirely different pieces of Apple hardware, a 5+ year old MacBook Pro, and a mid-2011 MacMini.

     

    On both, I disabled Spotlight prior to the upgrade, to provide the easiest path to getting the system running on the new release.  Prior to 10.7.5, Spotlight, running from building a new index, has never taken longer than 30 minutes on either machine (I have <20GB data on boot drives).

     

    When I re-enable Spotlight on the upgraded machines, it takes as long as 30 minutes just to get an "estimate" of indexing time.  The estimate varies during the indexing period, from days to hours.  On the Mini, it has been running now for 24 hours and the blue progress bar is almost done.  It has been estimating 5 or fewer hours left for the past 12 hours.

     

    One thing I have noticed via Activity monitor, if you sort the display on "%CPU", so the most active process comes to the top of the list.  Prior to 10.7.5, you could see mdworker processes right up at the top during the 30 minutes it took to index.  This always made sense, because they were churning out an index, and it got done rather quickly.

     

    Since 10.7.5, except for very brief spurts of activity, the mdworker processes are using almost zero CPU.  This would jive with the resulting slow indexing.  If mdworker is not working, then it is not producing results

  • Peter Bannon Level 6 Level 6 (10,080 points)
    Currently Being Moderated
    Sep 23, 2012 7:18 AM (in response to HenryAZ)

    HenryAZ wrote:

    Since 10.7.5, except for very brief spurts of activity, the mdworker processes are using almost zero CPU.  This would jive with the resulting slow indexing.  If mdworker is not working, then it is not producing results

     

    Good observation. saw the same thing in Activity Monitor after wondering why Spotlight was taking forever to even estimate the time required to complete indexing. For some reason when I started up this morning Spotlight is finished or inactive, after days of "estimating".

     

    Have not found any explanation for why Spotlight is broken in OS X10.7.5.

  • razmarin Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2012 10:22 AM (in response to Jean-Luc)

    Had the same issue with spotlight even after clean re-install... fixed it with this

    http://blog.chron.com/techblog/2011/09/want-to-really-repair-permissions-on-your -mac-try-this/

    im on 2011mba11"i7 if it matters

  • HerrDrKarl Level 1 Level 1 (15 points)
    Currently Being Moderated
    Sep 23, 2012 1:52 PM (in response to Peter Bannon)

    Yes, had been noticing the same thing about mdworker ... and everything else for that matter... using almost no resources, barely registering CPU usage ... and disk activity showing pretty much no activity.

     

    Combined with the crashes in the Aperture update, unfixed bugs in Final Cut Pro and more... Apple is feeling more like Microsoft than Apple lately. :-(

     

    @rasmarin - thanks for the link, but resseting home permissions had no effect for me.

     

    Misery loves company.  While glad its not just me, still hoping for a quick fix from Apple.  I'll send it in on the bug report system, but my reports there are always ignored, so I'm not sure what the point is...

     

    Karl

     

    PS  The screenshot above with the 8 day spotlight estimate (which went to 9 days...then 10...) was a mid 2009 MacBook Pro.  My early 2008 Mac Pro completed the spotlight indexing fine... spotlight NOT running... but still cannot back up with Time Machine ... has 50.9 MB to back up to my firewire drive right now and is stuck at 1.3 MB.  Normally done in 2 seconds.  Don't want to change the subject of this thread off of Spotlight - there are several other threads with similar TM problems since the 10.7.5 update.  But, due to the inability of TM to progress for me, with Spotlight not indexing, I'm not sure that Doug's suggestion above to disable spotlight in order to get a TM backup would be viable.  Yup, still stuck at 1.3 MB backed up... :-(

  • HerrDrKarl Level 1 Level 1 (15 points)
    Currently Being Moderated
    Sep 23, 2012 2:19 PM (in response to HerrDrKarl)

    OT for those experiencing TM issues as well as Spotlight ones.  In the "TM slow in 10.7.5" thread here:

    https://discussions.apple.com/message/19717783#19717783

    ppithermo says something similar to Doug Lockett (above) - that disabling Spotlight allowed TM to proceed.

     

    He also found that deleting all Spotlight index files while it was deactivated and then reactivating allowed it to complete.  I'm not sure why that differs from dragging the HD into the privacy of Spotlight and then removing it, but there must be more going on under the surface.

1 2 3 ... 10 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (12)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.