6 Replies Latest reply: Sep 21, 2012 3:58 PM by Scott B_1
hborowski Level 1 Level 1 (0 points)

After a message appars saying that the my Aperture Library would be moved and that the new Library would not be able to be opened by older versions of Aperture, I could not open this software. From the Problem Report window ("Aperture quit unexpectedly") and from the Launchpad, I tried to re-open it several times without success. I downloaded and installed again but also I hadd not success.


Color, OS X Mountain Lion (10.8.2), iMac 3.4GHz i7, 16 GB RAM
  • 1. Re: After updating to Aperture 3.4, I couldn't re-open it again. HELP!
    léonie Level 9 Level 9 (51,725 points)

    How did you reinstall? Remove the Aperture version from the Applications folder to the Trash and reinstall?

    If this did not help, post the first 60 lines of the crash log.

  • 2. Re: After updating to Aperture 3.4, I couldn't re-open it again. HELP!
    hborowski Level 1 Level 1 (0 points)

    I tried to reinstall the way you mentioned, but the following message appeared:

    "Alert. Aperture 3.0 or later is require to install this update"

    So I moved again from the Trash folder to the Applications folder (I have 57 GB of photos in my Library and I don't want to lose them).

    Each time I re-opened, the following message appeared:

    "Aperture has detected inconsistencies in your library. Please click Repair to avoid any potencial problems"

    And after click on the Repair button, the following Crash Log:

     

    Process:         Aperture [1627]

    Path:            /Applications/Aperture.app/Contents/MacOS/Aperture

    Identifier:      com.apple.Aperture

    Version:         3.4 (3.4)

    Build Info:      Aperture-301036000000000~1

    Code Type:       X86-64 (Native)

    Parent Process:  launchd [135]

    User ID:         501

    Date/Time:       2012-09-21 17:07:51.819 +0200

    OS Version:      Mac OS X 10.8.2 (12C54)

    Report Version:  10

    Interval Since Last Report:          19745 sec

    Crashes Since Last Report:           15

    Per-App Interval Since Last Report:  353 sec

    Per-App Crashes Since Last Report:   15

    Anonymous UUID:                      ACA768C5-4950-CA97-356D-3EF75D2F5A3A

    Crashed Thread:  2  Dispatch queue: com.apple.root.default-priority

    Exception Type:  EXC_CRASH (SIGABRT)

    Exception Codes: 0x0000000000000000, 0x0000000000000000

    Application Specific Information:

    *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '*** -[NSURL initWithScheme:host:path:]: path 100002409136236 is not absolute.'

    terminate called throwing an exception

    abort() called

    Application Specific Backtrace 1:

    0   CoreFoundation                      0x00007fff85a930a6 __exceptionPreprocess + 198

    1   libobjc.A.dylib                     0x00007fff886213f0 objc_exception_throw + 43

    2   CoreFoundation                      0x00007fff85a92e7c +[NSException raise:format:] + 204

    3   Foundation                          0x00007fff8cb36de8 -[NSURL(NSURL) initWithScheme:host:path:] + 112

    4   PrintServices                       0x00000001021cbc6d +[NSURL(ISNSURLExtensions) URLWithScheme:host:path:] + 61

    5   PrintServices                       0x00000001021cbbef -[NSURL(ISNSURLExtensions) URLByAppendingPathComponent:] + 127

    6   FacebookPublisher                   0x000000010fac37f2 -[ILFacebookAPIRequest graphURLRequest] + 215

    7   FacebookPublisher                   0x000000010fac3fb5 -[ILFacebookAPIRequest send] + 33

    8   FacebookPublisher                   0x000000010fab54da -[IPHFacebookPlugin displayNameForUsername:] + 88

    9   AccountConfigurationPlugin          0x00000001016cbfa5 -[AccountConfigurationProfileInformationDownloadOperation main] + 174

    10  Foundation                          0x00007fff8cb8d986 -[__NSOperationInternal start] + 684

    11  Foundation                          0x00007fff8cb951a1 __block_global_6 + 129

    12  libdispatch.dylib                   0x00007fff86d0cf01 _dispatch_call_block_and_release + 15

    13  libdispatch.dylib                   0x00007fff86d090b6 _dispatch_client_callout + 8

    14  libdispatch.dylib                   0x00007fff86d0a1fa _dispatch_worker_thread2 + 304

    15  libsystem_c.dylib                   0x00007fff8c9afcab _pthread_wqthread + 404

    16  libsystem_c.dylib                   0x00007fff8c99a171 start_wqthread + 13

    Thread 0:: Dispatch queue: com.apple.main-thread

    0   libsystem_kernel.dylib                  0x00007fff8e25a6da semaphore_timedwait_trap + 10

    1   libdispatch.dylib                       0x00007fff86d0c426 _dispatch_semaphore_wait_slow + 145

    2   com.apple.iLifeAssetManagement          0x00000001016658ae -[AssetManagementClient objectResultForRemoteCall:] + 214

    3   com.apple.iLifeAssetManagement          0x000000010166786b -[AssetManagementClient streamLibraryId] + 112

    4   com.apple.iLifeAssetManagement          0x0000000101667289 -[AssetManagementClient libraryMatch] + 30

    5   com.apple.Aperture                      0x00000001008a1dba 0x100367000 + 5483962

    6   com.apple.Aperture                      0x00000001008a1cad 0x100367000 + 5483693

    7   com.apple.Aperture                      0x000000010089ae77 0x100367000 + 5455479

    8   com.apple.Aperture                      0x000000010089adab 0x100367000 + 5455275

    9   com.apple.Aperture                      0x00000001003c2d65 0x100367000 + 376165

    10  com.apple.CoreFoundation                0x00007fff85a4547a _CFXNotificationPost + 2554

    11  com.apple.Foundation                    0x00007fff8cb47846 -[NSNotificationCenter postNotificationName:object:userInfo:] + 64

    12  com.apple.AppKit                        0x00007fff8472a60d -[NSApplication _postDidFinishNotification] + 292

    13  com.apple.AppKit                        0x00007fff8472a346 -[NSApplication _sendFinishLaunchingNotification] + 216

    14  com.apple.AppKit                        0x00007fff84727532 -[NSApplication(NSAppleEventHandling) _handleAEOpenEvent:] + 566

    15  com.apple.AppKit                        0x00007fff8472712c -[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:] + 351

    16  com.apple.Foundation                    0x00007fff8cb6112b -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:] + 308

    17  com.apple.Foundation                    0x00007fff8cb60f8d _NSAppleEventManagerGenericHandler + 106

    18  com.apple.AE                            0x00007fff83045b48 aeDispatchAppleEvent(AEDesc const*, AEDesc*, unsigned int, unsigned char*) + 307

    19  com.apple.AE                            0x00007fff830459a9 dispatchEventAndSendReply(AEDesc const*, AEDesc*) + 37

    20  com.apple.AE                            0x00007fff83045869 aeProcessAppleEvent + 318

    21  com.apple.HIToolbox                     0x00007fff8a7248e9 AEProcessAppleEvent + 100

    22  com.apple.AppKit                        0x00007fff84723916 _DPSNextEvent + 1456

    23  com.apple.AppKit                        0x00007fff84722ed2 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128

    24  com.apple.Aperture                      0x00000001007db00d 0x100367000 + 4669453

    25  com.apple.AppKit                        0x00007fff8471a283 -[NSApplication run] + 517

    26  com.apple.prokit                        0x0000000101874324 NSProApplicationMain + 378

    27  com.apple.Aperture                      0x00000001003769c2 0x100367000 + 63938

    28  com.apple.Aperture                      0x0000000100376314 0x100367000 + 62228

  • 3. Re: After updating to Aperture 3.4, I couldn't re-open it again. HELP!
    léonie Level 9 Level 9 (51,725 points)

    There is a problem with the Aperture installer. In some cases the installation is not complete, if you update on top of a recent version.

     

    For most posters here (there must be 20 and more discussions by now) it helped to reinstall Aperture after removing the Application from the Applications Folder and the reinstalling again. The error message you get "Aperture 3.0" required, suggests that you did not not buy your  Aperture version from the AppStore. How did you buy it?

     

    • If you installed Apperture initially from the boxed retail version, reinstall from the CD/DVD.
    • If you installed from the AppStore, download again from the AppStore.
    • If you unlocked the Trial or bought online previous to the AppStore, use the saved installer or download the Trial again.

    http://appldnld.apple.com.edgesuite.net/content.info.apple.com/Aperture/061-8328 .20101020.AprE3/ApertureTrial3.1.dmg

     

    Upgrade immediately after installing the previous version; you cannot open your current library with the previous version.

     

    Regards

    Léonie

     

     

    Added: your crashlog shows that you have exactly the problem most posters here have - a wrongly installed framework that is needed, when aperture tries to setup the Facebook account: You really need to reinstall  to fix this

    FacebookPublisher                   0x000000010fab54da -[IPHFacebookPlugin displayNameForUsername:] + 88

    9   AccountConfigurationPlugin          0x00000001016cbfa5 -[AccountConfigurationProfileInformationDownloadOperation main] + 174

  • 4. Re: After updating to Aperture 3.4, I couldn't re-open it again. HELP!
    Aye Es Oh Level 2 Level 2 (330 points)

    It's definitely the same crash that most people are seeing around here. Were you trying to install a version of Aperture that's earlier than 3.0? You'll need to track down the installer for some version of Aperture 3, and reinstall. There's no good way to "fix" this issue right now without reinstalling.

     

    Edit: Oop. Leonie beat me to the punch.

  • 5. Re: After updating to Aperture 3.4, I couldn't re-open it again. HELP!
    phillco Level 1 Level 1 (0 points)

    After three attempts at downloading Aperture 3.4 seems to be working with one exception ... When I import pictures from my Nikon D7000 the thumbnails download as 'empty frames' with no picture showing (just an empty space surrounded by dotted frame.   When I confirm he download the pictures actually load.   This is a problem because I now cannot see what is going to download.   I've never had a problem using this camera and Aperture 3.3.2 in the past.   I've also tried importing to another Mac which uses 3.3.2 and no problems.   Any ideas?

  • 6. Re: After updating to Aperture 3.4, I couldn't re-open it again. HELP!
    Scott B_1 Level 1 Level 1 (40 points)

    fixed it!! thank you!!