Skip navigation

TS2518: Aperture 3.5: Release notes

Learn about Aperture 3.5: Release notes

TS2518 After updating to Aperture 3.4, I couldn't re-open it again. HELP!

758 Views 6 Replies Latest reply: Sep 21, 2012 3:58 PM by Scott B_1 RSS
hborowski Calculating status...
Currently Being Moderated
Sep 20, 2012 11:55 PM

After a message appars saying that the my Aperture Library would be moved and that the new Library would not be able to be opened by older versions of Aperture, I could not open this software. From the Problem Report window ("Aperture quit unexpectedly") and from the Launchpad, I tried to re-open it several times without success. I downloaded and installed again but also I hadd not success.

Color, OS X Mountain Lion (10.8.2), iMac 3.4GHz i7, 16 GB RAM
  • léonie Level 8 Level 8 (46,375 points)

    How did you reinstall? Remove the Aperture version from the Applications folder to the Trash and reinstall?

    If this did not help, post the first 60 lines of the crash log.

  • léonie Level 8 Level 8 (46,375 points)

    There is a problem with the Aperture installer. In some cases the installation is not complete, if you update on top of a recent version.

     

    For most posters here (there must be 20 and more discussions by now) it helped to reinstall Aperture after removing the Application from the Applications Folder and the reinstalling again. The error message you get "Aperture 3.0" required, suggests that you did not not buy your  Aperture version from the AppStore. How did you buy it?

     

    • If you installed Apperture initially from the boxed retail version, reinstall from the CD/DVD.
    • If you installed from the AppStore, download again from the AppStore.
    • If you unlocked the Trial or bought online previous to the AppStore, use the saved installer or download the Trial again.

    http://appldnld.apple.com.edgesuite.net/content.info.apple.com/Aperture/061-8328 .20101020.AprE3/ApertureTrial3.1.dmg

     

    Upgrade immediately after installing the previous version; you cannot open your current library with the previous version.

     

    Regards

    Léonie

     

     

    Added: your crashlog shows that you have exactly the problem most posters here have - a wrongly installed framework that is needed, when aperture tries to setup the Facebook account: You really need to reinstall  to fix this

    FacebookPublisher                   0x000000010fab54da -[IPHFacebookPlugin displayNameForUsername:] + 88

    9   AccountConfigurationPlugin          0x00000001016cbfa5 -[AccountConfigurationProfileInformationDownloadOperation main] + 174

  • Aye Es Oh Level 2 Level 2 (330 points)

    It's definitely the same crash that most people are seeing around here. Were you trying to install a version of Aperture that's earlier than 3.0? You'll need to track down the installer for some version of Aperture 3, and reinstall. There's no good way to "fix" this issue right now without reinstalling.

     

    Edit: Oop. Leonie beat me to the punch.

  • phillco Calculating status...

    After three attempts at downloading Aperture 3.4 seems to be working with one exception ... When I import pictures from my Nikon D7000 the thumbnails download as 'empty frames' with no picture showing (just an empty space surrounded by dotted frame.   When I confirm he download the pictures actually load.   This is a problem because I now cannot see what is going to download.   I've never had a problem using this camera and Aperture 3.3.2 in the past.   I've also tried importing to another Mac which uses 3.3.2 and no problems.   Any ideas?

  • Scott B_1 Calculating status...

    fixed it!! thank you!!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.