Skip navigation

After Fixing Update Images lost to unsupported format

738 Views 14 Replies Latest reply: Oct 25, 2012 1:08 PM by Richard Cassidy RSS
pockl Calculating status...
Currently Being Moderated
Sep 20, 2012 8:17 PM

Like everyone, I had Aperture go buggard after update.  Don't even get me started on that mishap.  Several library fixes later to no avail, deleted Aperture and downloaded from App Store.  One more library fix and Apeture opens once again.  However, I now have a listing of recovered projects that report that the photo is an "unsupported image format".  Little over 200 photos effected.  I tried to reprocess but no help.  I downloaded backup from offsite but still shows same message.  I moved backup to lightroom which opens files and displays image but cannot edit.  I cannot think of a bigger screw up since I started using Apple.  I have a call in to Apple scheduled for Sat, but was hoping to get some useful information before that in an attempt t save my photos.

Macpro, Mac OS X (10.4.8)
  • Richard Cassidy Calculating status...
    Currently Being Moderated
    Sep 21, 2012 1:54 PM (in response to pockl)

    I have the same problem as you and looks like we have tried the same trouble shooting steps but now have gone one further and have an odd result. I removed Aperture and all related preferences from my computer then reinstalled from the app store and created a new library to do some testing. I took some test shots with my camera, a sony nex-f3, and downloaded them to Aperture well the raw files downloaded then when right to unsuported format. It's almost acting like the camera isn't  supported and it worked for months under 3.32. To make it even stranger the same files (raw from the same camera) is a shared iphoto and Apertrue library work in iphoto. If i may ask what kind of camera are you using?

  • léonie Level 8 Level 8 (46,405 points)

    Sony nex-F3 is not on the list of supported cameras http://www.apple.com/aperture/specs/raw.html

     

    Maybe you have been lucky previously.

  • léonie Level 8 Level 8 (46,405 points)
    Currently Being Moderated
    Sep 22, 2012 12:13 AM (in response to pockl)

    Are all your Sony 850 and a nex 5n  images unsupported, or only the 200 "lost & found images" and other sony raw files are ok? Are you able to open Sony images at all?

     

    Can you tell by the filenames, if the unsupported images are duplicates of images that are o.k.?

     

    After a rebuild Aperture shows all stray images, that are not connected to current versions in a kind of Lost&Found folder - usually these are redundant images that you can delete and forget (after making a backup of them just in case). Look at the dates and filenames and check, if you have good versions of them.

  • léonie Level 8 Level 8 (46,405 points)
    Currently Being Moderated
    Sep 22, 2012 9:13 AM (in response to pockl)

    What I meant with my question - are the images that are o.k. also Sony 850 and nex 5n  images, or are those in  a different format? I am just trying to figure out, if Aperture cannot decode your raw format any longer or if their is some corruption with your raw files.

  • léonie Level 8 Level 8 (46,405 points)
    Currently Being Moderated
    Sep 22, 2012 9:35 AM (in response to pockl)

    Have you tried the other Library First Aid options - "Repair Permissions" and "Rebuild Database"?

     

    Also open the "unsupported" image files in another image editor - Preview, Photoshop, Adobe DNG Converter, to see if they are really corrupted.

     

    If they are referenced, you can access them outside the Aperture library package; if they are managed crl-click the aperture Library to reveal the Masters folder and look for the images by import date.

  • léonie Level 8 Level 8 (46,405 points)
    Currently Being Moderated
    Sep 22, 2012 11:42 AM (in response to pockl)

    The update really does not touch and change the image files itself - maybe something else is wrong. First thing to do would be to check these particular images in your backup - in your Time Machine backup you can go back in time and find out exactly, at which time the images got corrupted. And if you discover, that the corruption occured earlier, I'd make a hardware check.

     

    Your signature says  "MacPro, Mac OS X (10.4.8)"; I think the MAcPro came with a Hardware Check CD. I'd run a disk check on the volume, where your image files are stored, and also check the RAM.

     

    Regards

    Léonie

  • RichiePoo Calculating status...

    The Sony NEX-3 is on the list.  The F3 and C3 are both in the same family, and should be supported.  The F and C are just the physical form factor of the device.

  • Richard Cassidy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 25, 2012 1:08 PM (in response to pockl)

    The latest raw photo update cured my problems the nex-F3 was incluced in the list. RichiePoo I wold have thought you were right but their is obviously somthing else going on.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.