Skip navigation

Images deleted after export (Aperture 3.4)

470 Views 8 Replies Latest reply: May 24, 2013 12:53 AM by to cheuk yin RSS
draellme Calculating status...
Currently Being Moderated
Sep 23, 2012 12:03 AM

Exported my newly imported images using the Export Originals function in Aperture. After that, all exported images were gone from the file system (previews still showing in Aperture but the refernced files are gone, also not in the Trash, but "fully gone").

Aperture 3, OS X Mountain Lion
  • léonie Level 8 Level 8 (46,350 points)
    Currently Being Moderated
    Sep 23, 2012 12:37 AM (in response to draellme)

    After that, all exported images were gone from the file system

    I am not sure which files are gone now, please clarify:

    • The files that you created on export
    • The original masters in Aperture
    • Both the exported files and the original masters in Aperture?


    If you still have the exported copies rename them exactly as they were named in Aperture and use the "locate referenced files" command to reconnect them.


    I am very puzzled by what happened. I see only three ways to reconstruct what happened to images:

    • If you imported from your card and selected to import referenced with the option "Store files in there current location" then the files will vanish, as soon as you eject the card.
    • If you managed to overwrite the referenced original files when exporting
    • If your referenced files are on a problematic external volume or network volume tht went offline or is wrongly formatted or the location of your master files is enclosed in a file vault. You cannot use Aperture together with file vault - it can store te images there originally, but not access them again.




  • léonie Level 8 Level 8 (46,350 points)
    Currently Being Moderated
    Sep 23, 2012 1:12 AM (in response to draellme)

    One more question - I forgot: What is your current Aperture version? Have you upgraded to Aperture 3.4? Then you may need to reinstall Aperture - see this support article:

    Aperture 3.4: May quit unexpectedly on launch after updating


    Not to mention that Aperture crashed in the meantime, then claimed the library is locked, I had to reboot and then to wait 30 mins for the library to be fixed as it was corrupted...

    After a crash Aperture will repair the library, but it may be necessary to rebuild it is well, see: Aperture 3 User Manual: Repairing and Rebuilding Your Aperture Library


    Looked for the images with Spotlight

    Did you search the entire mac from the Finder?


    In the Finder, choose File > Find or press Command (⌘)-F.


  • léonie Level 8 Level 8 (46,350 points)
    Currently Being Moderated
    Sep 23, 2012 1:30 AM (in response to draellme)

    I am on version 3.4 (see haedline).

    I did not yet have my morning coffee ....

  • léonie Level 8 Level 8 (46,350 points)
    Currently Being Moderated
    Sep 23, 2012 2:01 AM (in response to draellme)



    Spotlight will not show you the private system folders, unless you navigate there.

    Use the Finder''s "Go" menu to open the temporary directory, by selecting "go to folder" and entering "/tmp" into the search field.

    Then search this directory for your raw files (kind "images")


    Aperture sometimes writes files there, if it has a problem to write files.


    If your images are really missing, don't do anything that might write to your disk and use disk recovery software to restore image files, for example "Disk Drill" is free:






  • to cheuk yin Level 1 Level 1 (5 points)
    Currently Being Moderated
    May 24, 2013 12:53 AM (in response to draellme)

    I am experiencing the same problem. This is ridiculous! I have spent weeks working on a Photoshop-intensive project and after applying the final finishing touches, all that was left to do was export the TIFFs for the client. After clicking "Export Originals", an error appears saying that no files have been exported. Now, when I go back into my library, all the files I had attempted to export are now corrupted and missing.


    All the files I worked on for hours on end are gone; complete and utterly gone! They are not in the trash, nor anywhere on my hard drives. I am currently rebuilding my Aperture library as I type, as well as running Disk Drill to see if the files can be found. I am praying they will turn something up, but judging from the other responses in this thread I am not hopeful.


    I just cannot believe such a game-ending bug can exist in Aperture 3. If Aperture 3 was a new product I could understand, but over 3 years into release is outrageous. Has anyone had any luck in recovering their deleted originals? Has anyone heard anything back from Apple?


    Seems like I won't be sleeping tonight.


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.