Skip navigation

iBook G4 charging problems

3292 Views 23 Replies Latest reply: Sep 24, 2012 2:55 AM by bigvoice RSS
  • Knucklesmac Calculating status...
    Currently Being Moderated
    Sep 23, 2012 7:40 AM (in response to bigvoice)

    Try putting your palm firmly onto the left side of the tracker pad while the computer boots. Make sure you do so with the iBook on a flat surface, like a table. Apply pressure to your palm.

    Let us know if anything appears on your display.

  • bigvoice Calculating status...
    Currently Being Moderated
    Sep 23, 2012 11:37 AM (in response to Knucklesmac)

    I haven't heard of that black magic before , but unfortunatly, no joy. While pressing firmly on the left side of the track pad and pressing the power key, I still hear a faint click and a very brief flash on the screen (more like the back light trying to flash, not the screen itself. I get the same thing with battery in or out which is a change. Are you thinking I've got a bad connection somewhere on the mother board?

  • Knucklesmac Level 4 Level 4 (2,225 points)
    Currently Being Moderated
    Sep 23, 2012 11:58 AM (in response to bigvoice)

    Ah, Then it's not what I was thinking.

     

    The reason for me asking you to perform that little exersise was based on my past experience with iBook's which have a graphics processor problem. This is were the graphics chip pins becomes detached from the logic board due to constant heat and cooling over the years.(Common problem) With this problem you tend to get a flicker of the screen, and the sound of the machine, and nothing else. By pressing firmly down the tracker pad, applies pressure to the graphics chip and makes the connection.

     

     

    It could be a power adapter issue. I've known power adapter which have become faulty and simply can't power on a Mac. I have an old faulty power adapter here for my PowerBook, which shows the green or orange light, but it wont power on the PowerBook. When trying another power adapter, the PowerBook works fine.

  • bigvoice Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2012 1:23 PM (in response to Knucklesmac)

    I agree, it's not likely the graphics issue. I also know I have a good power supply as it will power up and charge an old G4 PowerBook. Since I've changed the DC board and it won't start with the battery removed, I wonder if I have different mother board issue?

     

    I'm also thinking that if the disk drive was dead, it would at least start up to a flashing question mark looking for a good boot drive.

     

    Thanks again to all for the ideas and suggestions!

  • Knucklesmac Level 4 Level 4 (2,225 points)
    Currently Being Moderated
    Sep 23, 2012 1:31 PM (in response to bigvoice)

    Which version of the iBook have you got?

     

    I've had this issue before with the iBook 12" model. When the battery was not in the iBook it worked fine.

    When it had the battery in the iBook it wouldn't boot. It turned out to be the ribbon cable from the DC inboard wasn't attached properly to the logic board. It's easily done when you remove the base and shielding. They attached the ribbon cable to the shielding which means that it comes unclipped when the shielding is removed.

    This tends to only happen with the 12" iBook. If you have removed the DC inboard, it easy not to have attached the ribbon cable at the logic board end. Those clips on the logic board are very fiddly and often don't sit right when you put the ribbon cable back in.

     

    Sorry I didn't realize you had a working iBook without the battery, other wise I wouldn't have made the other suggestions

  • bigvoice Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2012 2:50 PM (in response to Knucklesmac)

    I have a 14 inch iBook G4 (A1055, I think). This was a 'book that I gave to a family member that lives out of town. They have been using it for a while and said it just stopped working. After some research I decided it was probabbly the DC in board. So I changed that but it did not help. The charger lights up and changes from amber to green. It will not start with the battery in or removed (sorry if that was not clear). Because of the faint click and slight flash when I press the power button, I'm thinking something else on the mother board is bad.

     

    Thanks again for the suggestions and all of the time trying to help!

  • Ronda Wilson Level 8 Level 8 (40,560 points)
    Currently Being Moderated
    Sep 24, 2012 2:36 AM (in response to bigvoice)

    Have you tried resetting the PMU?

     

    http://support.apple.com/kb/HT1431

     

    Resetting the PMU has a slight potential of curing such an issue.

  • bigvoice Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 24, 2012 2:55 AM (in response to Jagoche)

    I have. It did not seem to help.

     

    Thanks!

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.