Skip navigation

Ios6 ipad3 rotation problems

15744 Views 28 Replies Latest reply: Jul 9, 2013 2:00 PM by Aphoid RSS
1 2 Previous Next
ste_global Calculating status...
Currently Being Moderated
Sep 19, 2012 11:40 PM

I upgraded my hours old ipad 3 to ios6 and now the screen will not auto rotate between portrait and landscape.


Anyone else experiencing this ?

iPad, iOS 6
  • King_Penguin Level 10 Level 10 (92,440 points)
    Currently Being Moderated
    Sep 19, 2012 11:47 PM (in response to ste_global)

    Is there a lock symbol at the top of the screen next to the battery indicator ? If there is, then depending on what you've got Settings > General > Use Side Switch To set to (rotation lock or mute notifications), then you can lock/unlock the rotation by the switch on the right hand side of the iPad above the volume switch, or via the taskbar : double-click the home button; slide from the left; and it's the icon far left; press home again to exit the taskbar. The function that isn't on the side switch is set via the taskbar instead :


    If there isn't a lock symbol then try a reset : press and hold both the sleep and home buttons for about 10 to 15 seconds (ignore the red slider), after which the Apple logo should appear - you won't lose any content, it's the iPad equivalent of a reboot.

  • Diavonex Level 9 Level 9 (58,565 points)
    Currently Being Moderated
    Sep 19, 2012 11:48 PM (in response to ste_global)




    1. Make sure the Side Switch is set to Lock Rotation: Settings>General>Use side switch to





    2. Now check the Side Switch to make sure it's in the unlock position



  • King_Penguin Level 10 Level 10 (92,440 points)
    Currently Being Moderated
    Sep 20, 2012 12:36 AM (in response to ste_global)

    Have you tried a soft-reset as I described in the second paragraph ?

  • sujal Calculating status...
    Currently Being Moderated
    Sep 20, 2012 7:55 AM (in response to ste_global)

    Is this the home screen that's not rotating? Or a particular app?

  • akulow Calculating status...
    Currently Being Moderated
    Sep 21, 2012 3:30 PM (in response to sujal)

    I have the same issue. Home screen is not rotating. And all the apps also. Only after off-rotate-on procedure.

  • Philip-III Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 22, 2012 4:01 AM (in response to ste_global)

    Same issue since upgrade yesterday. Reboot worked once or twice, but now after three reboots even that doesn't help. Sleep-rotate-wake seems to be the only way to get rotation. Apps with fixed rotation also work, but after exiting the app the the screen is back to the state it was stuck at. It is possible that this is an app related issue, as after the first two reboots it worked for a while before getting stuck again. As I understand it some rotation related APIs have changed and apps that have not been updated and are utilizing deprecated APIs may cause this problem. However, it should under no circumstances cause an issue this severe and there should be an easier and obvious way to alleviate this, limiting the issue to the affected apps only and not degrading the experience on the whole device in such a dramatic manner.


    I have not been able to identify potentially offending apps to this point as I am currently in "stuck mode", but I do have some suspicions. Costing all the apps and doing a reset lead to nothing.


    This issue should be addressed urgently on Apple's side, as even if it is an app related issue, it should at most be limited to the affected app and not render the whole device useless.

  • Philip-III Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 22, 2012 8:20 AM (in response to Philip-III)

    Alas, I've tried to isolate this to perhaps a single app or maybe a few, but even after force-closing all apps in the background and doing a reset this issue keeps recurring after I leave the iPad to sleep for a few minutes. A reboot helps temporarily, only as I figured you would have to start turning it around as soon as it boots. Once you leave it to sleep for a bit it usually means its done. It is a sad state of affairs and I am flummoxed by the number of reports related to this issue, but even more so by the common responses - (1) check the switch, or (2) reboot - does it seem like overnight everyone just hit the rotation lock switch by accident? And it just so happened that they did so after upgrading...


    Better get that sorted out as soon as possible...

  • Philip-III Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2012 6:27 AM (in response to Philip-III)

    OK, so it seems in my case it was indeed an app issue, albeit a very weird one as described above. I finally deleted an app I installed just right after the upgrade, and besides other minor bugs in the app itself, it seems it also messed up the autorotation on the whole device (the problems are reported to the developers). After almost a full day of shooting troubles and a signifficant nuissance in the process, this seems to be resoved for me at least. My advice to anyone else experiencing similar issues - check rogue apps hijacking the rotation lock, even if they are not running (my guess as to exactly how this happens is as good as anyone's). I am kinda worried a bit at the possibility of other apps or updates causing similar trouble in the future, but hopefully this gets resoved at the OS level at some point.

  • Philip-III Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 24, 2012 12:16 AM (in response to Philip-III)

    Too quick to celebrate. Back to being stuck again after 36 hours... Seems like the problem lies elsewhere...

  • Bootkie Calculating status...
    Currently Being Moderated
    Sep 25, 2012 5:23 AM (in response to ste_global)

    Is this related to power management baked into iOs6? My ipad2 seems to lock its self when the power is low.....but then works fine once charged back to 100%.

  • Philip-III Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 25, 2012 9:18 AM (in response to Bootkie)

    Definitely not in my case, it occurred during charging (near full anyway) and also anywhere between 100% and 70% so far.

1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (4)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.