5 Replies Latest reply: Sep 24, 2012 5:31 PM by Nitruc
Nitruc Level 1 Level 1 (0 points)

We've had Xserve setup for a while now and all the sudden it stopped working on our Windows 7 PCs and now on the Macs. The strange thing is that we can still see the Xserve folder under Shared, it just says "Connection Failed" and when I try to conenct to "afp://Xserve._afpovertcp._tcp.local" which previously worked, it gives the error 'There was a problem connecting to the server "Xserve". Check the server name or IP address, and then try again.' But when I go to the Xserve it shows that File Sharing is turned On, all the folders are listed under Shared Folders and all Users are still there. It says other users can access shared folders at afp://internal.xxx.com/ or "Xserve", but neither of those work either when trying to connect on another machine. What's going on here?


Xserve, Mac OS X (10.7.4)
  • 1. Re: Xserve shows under Shared, but cannot be accessed.
    Antonio Rocco Level 6 Level 6 (10,180 points)

    Hi

     

    The XServe is not OS X Server itself. It's simply hardware built by Apple to be perform a dedicated server role. You can install the client OS if you want to and use it as a workstation if you wish.

     

    From what you're describing it does not sound like you've OS X Server installed? Firstly File Sharing is not "turned on" in the Sharing Preferences Pane and Shared Folders do not appear under the Shared Folders Section. These settings are available in the Client OS and not the Server OS.

     

    Depending which version of the Server you have File Sharing is configured using Server Admin (10.6 and older) or the Server App (10.7 and newer).

     

    It would be helpful if you posted what OS is actually installed. Click on the Apple Icon in the top left hand corner and select About this Mac. It will either report Mac OS X (with a version number) or Mac OS X Server (with a version number).

     

    Finally have you tried simply rebooting it?

     

    HTH?

     

    Tony

  • 2. Re: Xserve shows under Shared, but cannot be accessed.
    Nitruc Level 1 Level 1 (0 points)

    Hey Tony,

     

    We have Mac OS X 10.7.5 with no new software to update. I'm just opening up the Server app and seeing File Sharing turned on with all our folders. Then under Hardware > Network it says:

     

    Computer Name: Xserve

    Host Name: internal.companyname.com

    Ethernet 1: 10.10.10.77

    Ethernet 2: 10.10.10.50

    LOM Port 1: 10.10.10.90

    LOM Port 2: 10.10.10.91

  • 3. Re: Xserve shows under Shared, but cannot be accessed.
    Nitruc Level 1 Level 1 (0 points)

    Also forgot to mention, that I'm able to get all of this information by using the "Share Screen..." option on my own computer and access the Xserve.

  • 4. Re: Xserve shows under Shared, but cannot be accessed.
    Antonio Rocco Level 6 Level 6 (10,180 points)

    Hi

     

    Based on the information you've provided it appears you've a misconfigured server on your hands.

     

    The computer name does not match the first part of the its hostname. You've configured both NICs (why?) and the LOM Ports are using the same address range and subnets as the main NICs.

     

    Unless there's other information forthcoming it's not surprising things have stopped working suddenty.

     

    How are you trying to connect to the Server?

     

    HTH?

     

    Tony

  • 5. Re: Xserve shows under Shared, but cannot be accessed.
    Nitruc Level 1 Level 1 (0 points)

    I was able to get it back working after seeing somebody with a similar problem say just to turn off and turn back on the File Sharing option. I did that, and it fixed it. But I'm still interesting and trying to understand what you mean by having it misconfigured. Can you go into more details as to how everythign should be? I didn't set this up and only took over for the person who set it up, so I'm not familar with Xserve settings. How should I be connecting the the server to get it under the Shared area on the finder?