2 Replies Latest reply: Sep 24, 2012 3:27 PM by mtb_monster
David Fell Level 1 Level 1 (10 points)

Apple says Aperture 3.4 is not compatible with some third-party plug ins. Does anyone know if this affects the Nik plugins?


Mac Pro, Mac OS X (10.5), MacPro, iPhone4, iPad, AppleTV