Skip navigation

Adding Names (for Faces) in photos keep disappearing.

561 Views 10 Replies Latest reply: Nov 10, 2012 7:18 AM by psimeon RSS
Steve Wolfe Level 2 Level 2 (190 points)
Currently Being Moderated
Sep 22, 2012 9:34 AM

When adding names to faces in photos, part of them keep disappearing.  The first two remain, an additional two vanish (after repeated attempts).  What's up?

MacBook Pro, Mac OS X (10.6.8), various external HDs, Macs since the Mac 512 "FatMac"
  • Kirby Krieger Level 6 Level 6 (11,555 points)

    Steve -- I can't tell what you are seeing.  What part keeps disappearing?  What do you mean by " The first two remain, an additional two vanish".  What container is selected, and how are you entering a mode that lets you add names to Faces?

  • Aye Es Oh Level 2 Level 2 (330 points)

    Steve, is this a new issue under Aperture 3.4, or have you been having the issue for a while? Also, are you using any special characters like accent marks or umlauts in the names that you're entering?

  • psimeon Level 1 Level 1 (5 points)

    I have the same problem. To me it usually happens when I have an original picture and an edited one (edited with Gimp) stacked together. For stacked photos I would like to delete the name tags on the original picture and only have the tags in the edited one, because otherwise the tags show up twice in the faces view.

     

    Sometime when I do the above procedure, the newly created tags vanish again. I tried both in the original and the edited picture. Both vanish again. Once this happens it's not possible to tag that photo again. I just happened again yesterday. Very annoying.

     

    This problem was already present in Aperture 3.3.2, maybe even earlier, though I can't remember exactly when it started. I guess it's is a bug, Apple, please fix this.

     

    Peter

  • psimeon Level 1 Level 1 (5 points)

    I just figured out a way to work around this problem: You can duplicate the picture in question and then Aperture creates new tags, which you can edit and also add new ones. Finally these tags stay on the duplicate picture. After you are finished with the tags, you can delete the previous picture, from which you made the duplicate.

     

    Peter

  • Aye Es Oh Level 2 Level 2 (330 points)

    There was a Faces fix in 3.4.2. Perhaps the new update fixes the issue?

  • psimeon Level 1 Level 1 (5 points)

    I'll try it on my Mac Book air when I have time. I use Aperture mostly on the Mac Pro. The 3.4.2 requires OS X 10.8.2, which unfortunately didn't run smothly on my Mac Pro. I had to downgrade to 10.8.1. to make it usable again. Currently I'm waiting for 10.8.3 before I try another upgrade.

     

    Peter

  • Aye Es Oh Level 2 Level 2 (330 points)

    Fair enough, let us know how it goes.

  • psimeon Level 1 Level 1 (5 points)

    I have checked this on Aperture 3.4.2. and I looks like it was finally fixed. I have a project where in a photo I had one tag and I could not add another one. I then exported this project as a library, upgraded and opened it with Aperture 3.4.2. and finally could add a second tag. If I do the same on Aperture 3.3.2. it does not work. I didn't work long enough on the new version to check whether it creates new situations where tags get refused, but I'm hopeful that this will not happen again.

     

    Peter

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.