Skip navigation

ical "authentication failed. your username and password were rejected by the server"

1248 Views 4 Replies Latest reply: Sep 24, 2012 6:16 PM by Cowan Pettigrew RSS
flowirin Level 1 Level 1 (10 points)
Currently Being Moderated
Apr 26, 2012 5:56 PM

i've a pretty busy server, fully configured with correct DNS.

 

running 10.6.8, uptodate. i've stopped the ical service, and removed it from the server settings.

then i created a folder on my RAID /volumes/raid/ical, set its ownership to _calendar:_calendar (uid 93), rwx,rx,-

then added the iCal service back, and set the data store to this new folder.

authentication is set to digest (to reduce potential kerberos errors), with SSL on.

i then started the service

 

an existing user CANNOT connect to the caldav server. i get the error: ical "authentication failed. your username and password were rejected by the server".

 

if i create a NEW user, that user can correctly connect to the Caldav server. On first joining, an entry is created in the __uids__ folder and the calender works.

 

SO. WHAT IS GOING ON?

 

this is 10.6, so i do not have an option in WGM to 'enable calendering'. i've used the inspector to check for differences, but i can't see any.

 

help. please. and no comments about DNS. the fact i can get  a new user to function means that is excluded. no comments about SSL. ditto. no comments about kerberos, its turned off. thanks.

2x xserve, 30x MacBook, 3x MacBook Pro, 10x iMac, 20x eMac, 30x PC, Mac OS X (10.6.6), mix intel/PPC
  • gracoat Level 3 Level 3 (645 points)

    I often think of things in terms of time it takes to figure out the solution to the problem vs time it takes to nuke and pave.

    Dare I ask...  How many users would you have to remake? 

     

    150 users would probably take 2 hours to recreate?

     

    ...Have you spent 2 hours on this problem yet?  How about 4 or 6?

    Perhaps you could have typed up 450 remade users so far!

     

    I have a great idea as to how to change ownership of home folders to users after they're created.

     

     

    Thoughts on the problem... (but don't spend too much time on it!)

    What about crypt vs open directory password?

    In WGM, select the user, click the advanced tab, and ensure that your users have OD based passwords? 

    ...sometimes that pull-down menu displays OD, but it's not really.  Try selecting OD, retype the password there, and save.

    See if it works.

     

    What about in server admin....  Select the server in question, click the access button at the top.

    Ensure that your services are allowed for all users to use the iCal service.

     

    In the iCal service in Server Admin...

    Host name setting?  It's a stretch as new users seem to work.  Ensure it's correct?

     

    For the sake of argument...  Change authentication type to Any Method...  If you're running OD on the server, Kerberos is running.  I know that certain services require it even though you have the option.  Perhaps iCal is being finiky without it?

     

    I apologize if you've tried all these, but as a user forum, you'll typically get users that don't believe that you've tried the basics.  It's honestly the best place to start.  Seeing as we don't know what you've done, it's the best advice you'll get.

    HTH

    -Graham

  • Cowan Pettigrew Calculating status...

    Hi guys,

     

    Did you find the answer to this? I've got just about the exact same setup except this problem is occuring with mail not ical.

     

    Cheers

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.