1 2 3 4 Previous Next 57 Replies Latest reply: Jun 15, 2013 12:16 PM by Dndkpj
 bluestaff Level 1 Level 1 (0 points)

is any one else having a problem with do not disturb ?


iPhone 4S, iOS 6
  • 1. Re: do not disturb not working
    Poodlezoe Level 1 Level 1 (0 points)

    My do not disturb is not working also

  • 2. Re: do not disturb not working
    The Figurehead Level 1 Level 1 (0 points)

    In order for this to work your phone must be locked (black screen). If the screen is on it understands that someone is using it so he may very well take a call!

     

    Cheers!

  • 3. Re: do not disturb not working
    Arnold53 Level 1 Level 1 (0 points)

    I 've locked the phone and even then "do not disturb " does not work

    I use the Iphone 4S

  • 4. Re: do not disturb not working
     bluestaff Level 1 Level 1 (0 points)

    this is the same problem im having screen locked either blocks all calls or none cannot set individual contacts

  • 5. Re: do not disturb not working
    NatePer Level 1 Level 1 (0 points)

    Do Not Disturb seems to work when it wants to on my 4S. One night it seemed to work as intended. An email came through with no alert. The following night an email came through with the audible alert. My screen was not locked on either night as I run the iHome app while I sleep.

  • 6. Re: do not disturb not working
    mancmanusa Level 1 Level 1 (0 points)

    My do not disturb works only on the first day I switch it on. Then it turns itself off and doesn't switch back on again the next night so have to do it manually each day.

  • 7. Re: do not disturb not working
    KennethOfDenmark Level 1 Level 1 (0 points)

    I am also having problems with this "Do not disturb" feature ... My problem is that I don't hear when favorites sends me iMessages og text messages ... Thats a problem ... Same happens with e-mails, I don't hear any sound when I get any of those ... Haven't experienced any problems with incoming calls but still this feature is so unstable that I can't risk using it ...

     

    Fix it!

  • 8. Re: do not disturb not working
    FelipeV Level 5 Level 5 (4,490 points)

    All:

     

    If you have the "Starting XXX hour Ending XXX hour" enabled this will automatically overide the on/off switch in DND. In otherwords: DND will activate/deactivate depending on the preset time. Should you wish to set it manually you must deactivate this function. And the phone must be in/slee/standby/locked mode for DND to work.

     

    Hope this helps

  • 9. Re: do not disturb not working
    Arnold53 Level 1 Level 1 (0 points)

    If "planned" DND is switched off and I do not allow calls from anybody (same menu)

    and the DND in the settings menu is enabled

    and the Iphone 4S is locked

    then all calls are withheld and people end up in the voicmail box

     

    It also works in the planned mode

    Have not checked other apps such as whatsapp and messages

    It is a bit confusing:

    - I would assume that DNS overrides the planned DNS

    - I thought that the function "allow calls from .. " was connected with the "planned" menu

     

    Bonjour a tous

  • 10. Re: do not disturb not working
    EarlyAdopter Level 1 Level 1 (0 points)

    I understand how DND is supposed to work.  And it isn't working for me. 

     

    Settings --> DND --> ON

    Settings --> Notifications --> DND --> Scheduled --> ON (From 11pm To 8AM)

    Allow Calls From (Address Book Group, called "Do Not Disturb")

     

    At times other than between 11pm and 8AM, with the screen locked, texts and phone calls are silenced, whether they are from the designated Address Book Group or not.  (The physical silence switch on the side of the phone is set to allow sounds.)

  • 11. Re: do not disturb not working
    Blue Planet Man Level 1 Level 1 (10 points)

    Bluestaff: Yep. Do Not Disturb doesn't work. Apple couldn't be bothered as most profitable company in the world to actually ensure that all features of their expensive product worked.

  • 12. Re: do not disturb not working
    Andrea Cerrito Level 1 Level 1 (0 points)

    I can confirm the Do Not Disturb doesn't work as expected: "it just works" when it wants.

  • 13. Re: do not disturb not working
    EarlyAdopter Level 1 Level 1 (0 points)

    I said earlier I uderstood how DND is supposed to work.  I didn't.

     

    The trick is to set it as follows

     

    Settings --> DND --> OFF

    Settings --> Notifications --> DND --> Scheduled --> ON (From X to Y)

    Allow calls from (whatever you set you specify)

     

    The trick is to have DND off and Scheduled on.

  • 14. Re: do not disturb not working
    Arnold53 Level 1 Level 1 (0 points)

    Warning: In my case (4S) the alarmclock does not ring when planned DND is on

    Alarm was set to 06:00 and planned DND was set from 22:00 - 07:00

1 2 3 4 Previous Next