Skip navigation

webdav broken - file copy

1330 Views 7 Replies Latest reply: Feb 26, 2013 4:07 PM by K I M B A K A T RSS
agiolax Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 21, 2012 4:08 AM

Hi all,

 

It looks, that the webdav support in Mountain Lion is broken.

 

I connect to several webdav shares via: Finder - Connect to Server - https://......

 

Since I installed Mountain Lion (10.8, 10.8.1, 10.8.2) I can no longer properly copy files from the webdave shares.

 

Either Mountain Lion reports an a unspecified error: 8388608 and the file is the displayed a 0 bytes large after.

Or it actually starts copying the file but e.g. the first 8MB of the file are ok, but the next 8MB are garbage. The file has the same size but is corrupt.

 

Comparing e.g. the md5 chksum on the webdav share original file and the copied file locally gives diffrent cksums.

 

This is really annoying, as my Lion installed Mac still works without any errors, while the Mountain Lion Mac just fails.

 

The webdav servers are all apache based.

 

The difference I can see in the logs between Lion and Mountain Lion is, that Lion actaullay pulls the file with one HTTP GET command,

while Mountain Lion uses multiple HTTP GET with Range headers in 8MB packets.

 

Anyone having the same issue?

MacBook Pro, OS X Mountain Lion (10.8.2)
  • Mike in CT Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 21, 2012 5:38 AM (in response to agiolax)

         I can no longer connect to my OSX 10.6.8 Web server with webdav either. Wiki authentication to same server works fine... The os x server based website "realms" don't allow permission based access.

     

          It all started with the new security update...   monitoring thread for more clues.  Thanks for posting!

  • Mike in CT Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 21, 2012 6:57 AM (in response to Mike in CT)

    Update:   I've changed the authentication mechanism (for realms) to digest and I can now connect to my realms and use the go->connect with http again.   I think "plain" may have been dropped as an option for good reason

  • nvrmore100 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 26, 2012 10:38 AM (in response to agiolax)

    Just wanted to state I'm having the same issues.  Prior to 10.8.2 I could not even connect to any of my webdav shares, and with the update I can connect, but now am seeing the corruption sisues.  Files I open directly from Finder on the webdav share will often tell me the file is damaged and needs repair.  If I try to copy to the share via finder, I get errors saying the file is in use (results in 0 byte file) or that it cannot write to the folder.

     

    Worked like a charm in Lion...

  • amalhotr Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 19, 2012 3:48 AM (in response to nvrmore100)

    I m having somewhat related issue with native webdav client in 10.8.2. I can successfully connect to a webdav share(using finder, connect to server), but when I copy a file to webdav share, soon after the copy completes, the client sends delete requests to the server when no such gesture(delete) is done.

     

    I see explicit delete requests from client being logged in server logs. Seems like a bug to me, any solutions/pointers to the problems would be appreciated.

  • patH72 Level 1 Level 1 (30 points)
    Currently Being Moderated
    Dec 31, 2012 8:25 PM (in response to agiolax)

    I have had a similar problem in that uploading a file to a webdev share results in a 0 byte file. Further attempts to upload that file will not work. The only solution is to connect via FTP, delete the file, and upload it again.

     

    Connecting to webdev shares didn't work at all in a previous version of Mountain Lion. Now I can connect, but file transfer behavior is inconsistent.

  • K I M B A K A T Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 26, 2013 4:07 PM (in response to patH72)

    The Finder can’t complete the operation because some data in “MYFILE” can’t be read or written.

    (Error code -36)

     

    Plus when I send my Pictures folder up to a webdav (Cubby) via the finder...I get an error code -50.

     

    Tried using Transmit AND Cyberduck! Same files are not copying.

     

    Did not work under Lion or Mountain Lion. Currently updated as of today!

     

    Also did the dot_clean to my entire User folder. Rebooted....Did not work.

     

    HOWEVER, Dropbox sync DOES accept the file. WHAT IS THE DIFFERENCE?

     

    I'm moving from Dropbox to Cubby...so this HAS to work.

    Cubby has a better plan and will do backup in one direction (up) is what I require. Syncing just blows as it is NOT a backup.

     

    Apple please fix.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.