4 Replies Latest reply: Sep 25, 2012 12:10 PM by léonie
CalChloe Level 1 Level 1 (25 points)

I upgraded to Aperture 3.4 a couple of weeks ago.  It updated my library with no issues at that time.

 

Two days ago I upgraded from Lion to Mountain Lion 10.8.2.  I know I have used Aperture since the OS upgrade without problem; however, this morning when in Aperture it gave me a "there is an inconsistency in your database" error and immediately started updating my library.  It got to 72% and stalled.  It's been there well over an hour.

 

I can't quit Aperture normally (greyed out) and I am hesitant to force quit.

 

Any suggestions?

 

Many thanks for any help.

  • 1. Re: Updating library stuck at 72%
    léonie Level 9 Level 9 (51,740 points)

    To avoid force-quitting, try my user tip here; sometimes it helps to quit from the Terminal:

    If Aperture is unresponsive, how to avoid force quitting?

     

    If you can get Aperture to quit, try "Repairing" and Repairing permissions next:

    Aperture 3 User Manual: Repairing and Rebuilding Your Aperture Library

     

    When that succeeds, try to launch Aperture again, with the shift key hold down, to prevent the generation of previews. See, if you can get access to the menu bar this way agai.

     

    Did you import new images or videos recently? Maybe you have a corrupted image or video in your library and need to track it down and remove it.

     

    Post back, if you can get access to your Library again.

     

    Regards

    Léonie

     

    9800

  • 2. Re: Updating library stuck at 72%
    Aye Es Oh Level 2 Level 2 (330 points)

    Depending on how large your library is, Aperture could stall for quite a while during a repair or upgrade attempt. If it's large (~300GB or more), I'd leave it running overnight if at all possible.

  • 3. Re: Updating library stuck at 72%
    CalChloe Level 1 Level 1 (25 points)

    I used the killall Aperture and it worked.

     

    When I started it back up it had to rebuild the library database, but now it seems to be fine.  Thank you so much for this tip!  I will try and remember it if I ever have another issue like this.

     

    My library is only 107.7 GB.  I'm wondering, tho, if it might be advisable to try and break it up into smaller libraries?  I like not having to open and close separate libraries, but maybe it might be a safer option.

  • 4. Re: Updating library stuck at 72%
    léonie Level 9 Level 9 (51,740 points)

    You are welcome. I am glad this worked for you.

    I like not having to open and close separate libraries, but maybe it might be a safer option.

    That is still a moderate size for an Aperture library. It is really not necessary to break it up int several libraries. You will loose a lot of Aperture's powers doing this. It will be impossible to do smart searches involving all your images at once, if the images are distributed over several libraries. Do you have sets of images, that have no connection at all - for example business pictures and private pictures, that will never be used together in a slideshow or an album? Then you can split the library, but otherwise I would not do it.

     

    When your librarie grows, and you are running out of disk space, you might consider to relocate the original images for some of your projects that do no longer need editing to an external drive instead.

     

     

    Regards

    Léonie