3 Replies Latest reply: Sep 25, 2012 4:31 PM by John Galt
mrkeeney Level 1 Level 1 (0 points)

Can't find the appropriate OS.

 

Running an iBook G4... ca


iBook, iOS 4.3.3