Skip navigation

160GB iPod Classic Technical Difficulties (Please Help)

1176 Views 4 Replies Latest reply: Oct 3, 2012 1:41 AM by Bilbo_cheshire RSS
aaaaaahdgfh Calculating status...
Currently Being Moderated
Sep 20, 2012 7:44 AM

Hello all. One week ago I purchased a used - but in great exterior condition - 6th Gen 160GB iPod classic. Since then I've noticed that when I am navigating through the iPod menu, I will occasionally hear a loud cranking, computer noise coming from inside it. Not all song's lyrics will show up. Some songs that play fine in iTunes and on my iPod Touch will not play on the Classic - they will just instantly skip a few songs on the album I'm listening to and play a different song. Most songs play properly, though. Also, most times I plug my iPod into my computer, the iPod will freeze so I'll have to reset it. In an attempt to fix the skipping songs, I scanned/repaired them with mp3val and still they will not play properly. Really disappointed. I'd appreciate any help.

Thanks,

Cam

iPod classic

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.