Skip navigation

TS1449: Portables and Magic Trackpad: Jumpy or erratic trackpad operation

Learn about Portables and Magic Trackpad: Jumpy or erratic trackpad operation

TS1449 Macbook pro trackpad not responsive, opening apps on it's own, moving screens on its own, help!

123370 Views 102 Replies Latest reply: Mar 31, 2014 11:19 AM by amphead RSS
  • MikePolinske Calculating status...

    I just had this issue today with my new Retina MacBook Pro running OS X 10.8.1.

     

    I tried using a wireless Logitech USB mouse and it still happened.  I tried resetting the PRAM and SMC but still no joy. 

     

    It didn't move on the disk selection screen, but it did happen on the login screen.  I disabled Logmein, but it still didn't help.  I also tried wiping it with some glass cleaner on a paper towel, still no luck.

     

    I finally pressed the whole trackpad down with three fingers on each side and that seems to have fixed it.

     

    Very frustrating, but hopefully now it won't happen again!

  • happyatheist Calculating status...

    I dragged my fingernail around the trackpad edges, and lo and behold, totally fine now. Phew!

  • jrnda Calculating status...

    Using MBP 13" i5 Late 2011, I've tried...

    booting to Windows, still occuring,

    resetting SMC, works for about less than 20 minutes,

    applying even pressure, works for a few minutes,

    cleaning the surface of the trackpad, doesn't seems to work,

    cleaning the trackpad edges, not working either,

     

    Are there any other suggestions to try before going to Apple?

  • Osso_Buco Calculating status...

    I'm running Retina MBP Lion .....none of the solutions work on this thread.

     

    Why is Apple not providing a solution? I've had more problems with Mac OS in one month than I have using Windows for 15 years.

     

     

    Maybe this is Apple's strategy to get people to buy Mountain Lion?

  • kevinfarner Calculating status...

    MacBook Air from July 2011

    Mountain Lion 10.8.1

    Using a magic trackpad, I began having issues the day I installed 10.8.1, did not have before that. Having the same issues as you all. It's as though an invisible finger is clicking and holding down my magic trackpad, dragging apps, clicking and unclicking areas, when I'm on a web page I can scroll because it is clicking and selecting text, etc.

     

    I have tried the magic mouse, a non-apple bluetooth mouse and the trackpad on the laptop itself. To no avail. Some work better than others, but after a period of usage, less than an hour, the same issues appear regardless. I have not tried a usb-tethered mouse because I no longer own one.

     

    I have tried all the solutions I've read, resetting the PRAM, the SMC, testing the magsafe and plugging in to another outlet, rebooting, turning off bluetooth (obviously I use the laptop's trackpad then but it still acts up) all to no avail. Usually things like resetting the PRAM help briefly, but less than 30 minutes and it's back to how it was.

     

    I have a Genius Bar appointment tomorrow morning and will write back if I learn more. 

  • bbrowett Calculating status...

    An update to my previous post of 30 August.  Again, thanks to all the folks who are posting.   This is a perplexing problem.   Nonetheless, there seem to be themes:

    • using Lion or Mountain Lion
    • attempts to clean the Trackpad occassionally help
    • resetting the SMC seems to help
    • there may be a connection to Bluetooth signal leakage.

     

    By trying to keep the Trackpad, and especially the areas around and under the edges of the Trackpad clean, I have experienced fewer and less severe attacks of the "cursor with a mind of its own".  ... Resetting the SMC, accorrding the the instructions provided in this tread, also seems to help.  

     

    I wonder if in one of the recent updates to the Mac OS X ... either Lion or Mountain Lion, ... someone changed the sensitivity or tolerances of the Trackpad to touch?   Since the problem seems to occur with both new and old hardware, I am less inclined to think that "aging" is a direct issue, although extent of use of the Trackpad, maybe a contributor to the problem.  

  • Ann G Level 2 Level 2 (300 points)

    To everyone

     

    If you have been experiencing strange or weird responses from your trackpad you may consider taking your unit in to the Apple Store for a look see under the hood. I had similar issues, tried all the resetting processess even went as far as installing Mountain Lion thinking it would correct whatever was going on, which nothing worked.

     

    I took my MBP to the Apple store and found out that the battery was swelling. In fact quite a few customers were there with various battery issues. That moment a customer tagged the store Apple Hospital. LOL - we both laughed it out. You have to have a dry sense of humour.

     

    I got the battery replaced and the trackpad is as it was when I first purchased it.

    Anyways that's my 2cents -- hope this is helpful.

  • JarenSand Calculating status...

    I was having this problem, and I just unplugged my power plug. Fixed everything like a charm!

     

    http://support.apple.com/kb/TS1449

  • myamazon Calculating status...

    Was having the same erratic trackpad behavior for a few days and I chanced upon this forum discussion and did the following:

     

    1. Verified and repaired all permissions through Disk utility.

    2. Rest the PRAM and rebooted twice.

    3. Applied even pressure on entire trackpad for 20 seconds (twice)

    4. Cleaned the trackpad with slightly moist paper towel and rewiped it with dry cloth.

     

    And so far something I did (or all of it) has solved the problem. Trackpad is behaving well (for now).

     

    I'm on ML 10.8.2 on a Mid-2010 MBP 15" 2.4 GHz i5 with 8 GB RAM.

  • AaronStetson Level 1 Level 1 (0 points)

    MIne is doing the same Thing: 15" MacBook Pro.  OS X 10.7.5 took it to the Genius Bar they couldn't replicate the problem.  Reset, nothing, pushed on the trackpad as suggested, nothing, cleaned the trackpad as suggested, nothing.  Last night reset the SMC worked fine for 24 hours.  Started going crazy tonight, tried all of the above again nothing!

     

    Please help!!

  • helpMeinNS Calculating status...

    Please please please help!! Apple - address this issue fast! I am a photographer and I NEED my laptop to work!! 

     

    My issue is with a:

     

    MacBook Pro

    13 inch, Early 2011

    OS X 10.7.5 - Lion

    2.7 GHz INtel Core i7

    4 GB 1333 MHz DDR3

     

    I was mid use - stood up to get a glass of water, came back to continue working and the trackpad wouldn't 'click' to select. 

     

    I tried using a USB mouse and wireless mouse - no use...

     

    Went and bought a wireless trackpad - again - didn't work

     

    Tried the Shift-L Control Option thing and that allowed the new wireless trackpad to work (for a short period of time) however - AS SOON AS I TOUCH THE TRACKPAD on the MacBook Pro - I have to restart - this includes the faintest touch.

     

    I've tried cleaning, I've tried pressure, I've tried a gentle TAP TAP... nothing...

     

    please help - there are no Apple stores within a 6 hour drive and no service within 4... I'M SCREWED!!

     

    help .. help.. help... help!!

     

    I can't get ANY work done and I'm honestly in tears with frustration!!!

  • Mr.Needing.Help Calculating status...

    I am in the same position. I have to think that its a virus or software glitch due to the various models of macs this has been happening to. Please Please if someone has a new solution let me know.

     

    I purchased my MBP Retina in the USA but live in Thailand, The say I need to send it back to them. With import/export costs plus shipping I am looking at over $1,000.

     

    Please Help!

  • anon1010 Calculating status...

    I've tried many of the suggestions and apparently one has worked--unfortunately I have no idea which--the pressure method is the one I tried repeatedly.

     

    Would humidity cause the battery to swell? The problem was the most prevalent during a period of high humdity at the end of summer.

  • helpMeinNS Level 1 Level 1 (0 points)

    Can you describe exactly how you did the pressure method?  I tried by placing three finger on the left side of the pad and three on the right (in a vertical row) and pressing down fairly firmly for 20 seconds each time... to no avail...

     

    I live in a particularly humid area of Canada - so perhaps it did have something to do with it...

     

    Looking for advice on the 'pressure method' that might have worked for you guys.

     

    Cheers-

     

    Getting desperate..

  • anon1010 Level 1 Level 1 (0 points)

    I tried the 3 finger swipe, but that lasted only for a few minutes. I made a fist and ran my fist across the trackpad, applying more pressure than I did with the three-finger swipe. I have no idea if this is what fixed the trackpad or if it was pure coincidence.

     

    Good luck.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (7)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.