1 2 3 4 5 Previous Next 70 Replies Latest reply: Oct 10, 2012 1:21 PM by movery Go to original post
  • 45. Re: Aperture 3.3.2 hangs on launch (library issue)
    Pim Versteeg Level 1 Level 1 (15 points)

    Nope, I have 3.4, same issues

  • 46. Re: Aperture 3.3.2 hangs on launch (library issue)
    Phillip Breske Level 1 Level 1 (60 points)

    Pim Versteeg, do you have "Keep Projects & Albums Arranged by" set to Name or Date?

     

    In previous posts it was mentioned that people with certain legacy iPhoto albums were not able to arrange their library by Date and those same people had the issue with Aperture hanging on launch. Perhaps your problem has something to do with the Arrange setting in the menu at the top of the Library pane.

     

    My Library is set to arrange by Name and, to be frank, I'm not willing to experiment with that setting as long as my application is still launching normally.

  • 47. Re: Aperture 3.3.2 hangs on launch (library issue)
    léonie Level 9 Level 9 (51,720 points)

    Philipp,

    you are referring to Alex Brown's post, right?

    Aperture 3.3.2 unresponsive if library contains old iPhoto albums - solution

    That might indeed be the problem here.

  • 48. Re: Aperture 3.3.2 hangs on launch (library issue)
    Phillip Breske Level 1 Level 1 (60 points)

    Yeah, that's what I was thinking, too. But my hang-at-launch issue went away with version 3.4, so I can't say what problems may still exist for anyone else.

  • 49. Re: Aperture 3.3.2 hangs on launch (library issue)
    Aye Es Oh Level 2 Level 2 (330 points)

    Pim, I saw in another thread that you ran into the PrintServices/Facebook crash on startup, and "fixed" that by removing the preferences.

     

    Did you start crashing again? If you did, that means that you need to delete the Aperture program from the Applications folder and reinstall, as directed in http://support.apple.com/kb/TS4412

  • 50. Re: Aperture 3.3.2 hangs on launch (library issue)
    Pim Versteeg Level 1 Level 1 (15 points)

    no, these were 2 different machines,

     

    the first was on a MBP where a recommended well-placed command in terminal removed the facebook preferences and everything worked from there,

     

    the 2nd time was on my iMac where the above, nor the "first open in iPhoto" gave no joy whatsoever, but the removal of the com.apple.aperture.plist did,

     

    In short; Aplle really screwed up with the recent updates on Aperture, reason for me to re-visit the Adobe products. I can not be dependent on a product like this

  • 51. Re: Aperture 3.3.2 hangs on launch (library issue)
    Aye Es Oh Level 2 Level 2 (330 points)

    Hm... I'd still try deleting and reinstalling Aperture on both machines, if only to eliminate that variable.

  • 52. Re: Aperture 3.3.2 hangs on launch (library issue)
    John Bones Level 1 Level 1 (0 points)

    Philip

     

    Installed Aperture 3.4

     

    Aperture now refuses to open up my Library AND my backup library.

     

    This is very frustrating.  I cannot access my photos.

     

    I purchased my iMac under the assumption that the software would be

    stable and efficient. 

     

    Boy, was I wrong. 

  • 53. Re: Aperture 3.3.2 hangs on launch (library issue)
    Glenn Cogar Level 1 Level 1 (45 points)

    Hi John, and others still having an issue

     

    I was able to resolve the Aperture issues I had by logging out of MobileMe in the Systems Preferences pane.  See https://discussions.apple.com/thread/4147538

     

    Just in case the ongoing issues you are having are to do with that?  The symptoms sound very similar

     

    Good luck and I hope your issues are resolved soon

  • 54. Re: Aperture 3.3.2 hangs on launch (library issue)
    John Bones Level 1 Level 1 (0 points)

    Glenn

    I appreciate your reply... but I am not logged into MobileMe, so that did not resolve the problem. 

     

    I still cannot access 360 GIG worth of photos... the last six years of my family's life,

    birth of a grandchild, graduation, vacations, landscapes, you name it.

     

    I tried the work around by opening a "dummy" Aperture file,

    but Aperture still refuses to open my real files. 

     

    I wish I had never "upgraded" to Aperture 4.... more like a downgrade.    

     

    What is even more frustrating is that Photoshop cannot open these files. 

    APPLE has locked them up with their proprietary software.... thanks for nothing.  

     

    At least with Windows, any number of photo programs can access your photos. 

  • 55. Re: Aperture 3.3.2 hangs on launch (library issue)
    Phillip Breske Level 1 Level 1 (60 points)

    John Bones,

     

    You should still be able to access the photo files with another piece of software. Obviously, if you kept the files out of the Aperture library and only "referenced" the originals to the software, the originals will still be somewhere on the hard drive, able to be used by any other software.

     

    If they were stored in the Aperture library, you can from a Finder window control-click on the Aperture Library file and select Show Package Contents. From there you can click on Masters and your original photo files can be found in whatever filing system you selected when using Aperture. In my case, there is a folder for each year, with subfolders for each month and day.

     

    Be advised that changing the contents of the Aperture package from the Finder may have undesireable results, but if you are truly stuck and need to get to and/or edit these files, you can still access them.

  • 56. Re: Aperture 3.3.2 hangs on launch (library issue)
    léonie Level 9 Level 9 (51,720 points)

    John,

    have you upgraded from Aperture 3.4 to Aperture 3.4.1 by now? That release contains some important bug fixes.

     

    And after upgrading to 3.4.1, have you run the Aperture Library First Aid tools?

    see:  Aperture 3 User Manual: Repairing and Rebuilding Your Aperture Library

    From your post is not clear, which of the Trouble shooting measures you already have tried.

     

    Regards

    Léonie

  • 57. Re: Aperture 3.3.2 hangs on launch (library issue)
    John Bones Level 1 Level 1 (0 points)

    Philip 

     

    Indeed, Masters can be accessed, but all labels, organization are lost. 

    It would take several days to identify, label and file nearly 400 Gig of photos. 

     

    I have attempted to go  through the Repair process.

    All I get is the Aperture opened in (null) message again and again. 

    Nothing works.  

     

    So....

    I go to the App Store, pay $80 for the latest version of Aperture.

     

    Guess what?

     

    We still have failure to launch the programme. 

    Photos are virtually inaccessible.

     

    Apple has my money.

    I have no photos.

    Nice.  

  • 58. Re: Aperture 3.3.2 hangs on launch (library issue)
    CorkyO2 Level 4 Level 4 (1,290 points)

    John,

     

    If you originally purchased AP 3.x via retail full or upgrade version and have the serial number(s) and also have a backup of the Aperture library pre-3.4 upgrade, you might want to try using the link below to access the AP 3.1 trial and update to whatever version your backup library was made with / for. This may allow you to launch the backup and access the images intact with added metadata.

     

    http://support.apple.com/kb/TS4412

     

    Note - I would suggest removing any 'Aperture' files from the following locations if you go this route before installing:

     

    /Library/Application Support

    ~/Library/Application Support

    ~/Caches

    ~/Preferences

     

    Note - you could also use the 'Go menu > Go to Folder...' command and type: /var/db/receipts and then press Enter/Return. Delete any 'Aperture' named files in this folder as well. This is simply a clean up step that would remove any record of Aperture being installed, but is generally not necessary unless you really want to do a clean install of Aperture.

     

    If you have a backup of the library, then simply double-click that library while pressing the 'Option + Command' key and just run the 'Repair Database' option for completeness. Hopefully that will load for you after the Welcome screen process.

  • 59. Re: Aperture 3.3.2 hangs on launch (library issue)
    léonie Level 9 Level 9 (51,720 points)

    Note - I would suggest removing any 'Aperture' files from the following locations if you go this route before installing:

     

    /Library/Application Support

    ~/Library/Application Support

    ~/Caches

    ~/Preferences

     

    Corky,

    These files will be recreated, by a new install; but I recommend only to  remove - but not to delete the files in ~/Library/Application Support

     

    John,

    This directory contains all your presets and commands - every customization to Aperture, that you probably invested much time in; you will not want to lose that. After reinstalling you can try to put your most important presets back one by one, and check if they are o.k. The most likely presets to give trouble are

    ~/Library/Application Support/Aperture/Raw Decode Presets.plist.

     

    Léonie