Skip navigation

Photo sync issues after 10.8.2, iOS 6, iPhoto 9.4 upgrades

64395 Views 267 Replies Latest reply: Jan 10, 2014 11:39 AM by sungyle RSS
  • maminique Calculating status...

    Thank you very much Joseph you DA MAN, this fixed my problem !

  • Mr C Calculating status...

    Hi Joseph,

     

    It looks like you've found a solution - however it doesn't seem to work for me. At least the option you give doesn't seem to be applicable since I do not have any slideshows created in iPhoto... I wonder if you (or anyone else) have any suggestions for this prediciment...

     

    iPhoto 9.4 (30+ 'normal' albums but no slideshows - I did have slideshows but deleted (trash is empty))

    iPhone 5

    iOS 6

    iTunes 10.7

    OX X 10.8.2 (2012 MB Pro)

     

    I too only have the option to sync all photos with the Selected albums option greyed out. Naturally I get the blasted (1140) error message when trying to sync... Is there perhaps some 'system file' I could try deleting?

     

    Anyway, any help / suggestions from the excellent Apple Community woud be most helpful. There are a few other discussions about this matter out there but they all seem to be centred around 'slideshow' music - perhaps there is just something I not getting!!

     

    Many thanks...

  • giga2 Calculating status...

    First of all, I'd like you to excuse my English. I'm Italian and I speak few words of English.

    I'm using Apple product since 1984. I remember very well the first machine I used, an Apple MacIntosh Plus! I've been always proud of my many Apple's products: computers, iPods, iPads, Apple Tvs and so on.

    Now I'm very sorry for what it's happening in these days (and never happened before!). Apple has released the latest version of iPad/iPhone OS (iOS 6) and Mac Os X (v10.8.2). The results are that I cannot sync my iPhone/iPad with iTunes. Every pictures I took during many years of activity disappeared from my devices.

    I'm expecting a new patch from Apple, but I'm very sorry because this great and glorious factory is now very similar to Microsoft ...

  • Joseph Delaney Level 3 Level 3 (515 points)

    Mr C (and everyone else with this problem)

     

    Do not limit yourselves to "slideshows"

     

    iPhoto now has a "slideshow" button on every album, including the 'normal' ones - even on "events," photostream, etc.

     

    If you have time, and don't want to wait for the 9.4.1 update, then you can go down every item in the left hand column, click the "Slideshow" button (it's at the bottom of the iPhoto window, smack in the middle), then click the "music" tab, and choose any song that does not have an &, <, >, quotation mark or apostrophe in the song title, album title, or artist name.

     

    Here's an example - what we're looking at is my "Photo Stream" --- not a sildeshow. Notice the "slideshow" button in the middle, at the bottom, where I circled and put arrows? -

     

    Screen Shot 2012-09-25 at 4.03.51 PM.png

  • Joe Win Level 1 Level 1 (0 points)

    Mr. C -

     

    I never created any slideshows in iPhoto either. However, I did the .xml search for "&" and was able to determine the one file that had that offending operator. Then, it turned out that that sound file was listed as its own photo album in the list of albums on the left-hand side. That shouldn't have happened. So, I deleted it and all started working for me.

     

    However, if you only have proper albums listed on the left-hand side, then I'd suggest you follow Joseph Delaney's plan above.

     

    I can report that I've just heard back from the Apple Expert in Boise with whom I was corresponding about this and my original iPhone 5 problem. She reports that Apple Engineers have confirmed that the problems lies in iPhoto 9.4 and that they actively working for a fix. No time estimate on when it would be released.

     

    Good luck.

  • Joseph Delaney Level 3 Level 3 (515 points)

    Here's the step-by-step instructions that I posted earlier. They've gotten a little bit lost in the 11 pages of comments, so I thought it might help to post them again. I've modified them a little bit based on some comments.

     

    1. Quit iTunes
    2. Quit iPhoto
    3. Right click on your iPhoto Library (in your "Pictures" folder) and choose "Show Package Contents"
    4. Find the "AlbumData.xml" file and open it in TextEdit or any other text editor. If you're uncomfortable doing this, then copy the file to your desktop and open the copy.
    5. Search (command-F) for "& " - don't include the quotation marks, but do include a single space after the ampersand. It should take you right to the name of the song that's the problem.
    6. Do not change anything! Just look in the lines immediately above the song name, for the name of the Photo Album that's using that song. It will look something like this, if the name of the album was "Vacation Pictures":
        <key>AlbumName</key>  
        <string>Vacation Pictures</string>
    7. Close the "AlbumData.xml" file, and close the "iPhoto Library" folder.
    8. Now open up iPhoto.
    9. Look for the album with the same name as the one you found in the file, and click on it.
    10. Click the "Slideshow" or "Play" icon
    11. You should see some options for the slide show (if the slide show starts playing, just move your mouse and click the "music" icon to get there)
    12. On the music tab, cilck the "custom playlist" checkbox, and drag any song (make sure it doesn't have an "&" in the song name, album name, or artist name) into the custom playlist box.
    13. Click "Play"
    14. Start up iTunes, and see if you can now sync selected albums. If not, repeat from step 1 (you may have more than one photo album that is affected).

     

    That will safely and permanently remove the ampersand from the slideshows, so when you go back to iTunes you should be able to sync selected albums.

     

    The ampersand "&" is only one of a few possible problems. it's the easiest to find, and also the most likely to have been used in a song title or band name, so it's the best one to search for. If you can't find any ampersands, try using a safe song for all your photo albums, slide shows, events - everything in iPhoto can have a song attached to it.

     

    Or wait for the iPhoto 9.4.1 update, which will fix the problem. Nobody knows when it will arrive, but it shouldn't take very long.

     

    And thanks should go to Andrew Patterson who is the person who figured out the solution. I just posted instructions.

  • Mr C Level 1 Level 1 (0 points)

    Thank you! Yes, I had noticed the new slideshow option but figured since I hadn't created or even run any slideshows it couldn't possibly be interferring... How wrong was I?!

     

    Thank you for the 'idiot' proof guide. I have taken 3/4 of an hour to go through and make sure each album has default theme music allocated to it... Heypresto... Sync complete...

     

    Thanks again for your help, you're a credit to the community

  • bug00 Level 1 Level 1 (45 points)

    Thank you so much, Joseph Delaney, for the clarity in your instructions for people who didn't have slideshows.  I had looked at the XML file, and had seen that there was one offending song, but it was not associated with any slideshow (because I didn't have any).  After reading your instructions regarding the slideshow feature that is contained in all regular albums, I was able to figure out the offending album, change the music that had been assigned at some point (looks like that happened maybe 5 years ago or so) and I'm FINALLY back in business. I'm able to sync and able to choose which albums to sync, etc.  Thank you so much for the instructions...and how lovely that you recredited Andrew Patterson for the original solution.  Mr. Delaney, you single handedly renewed my faith in mankind!!  ;-)

  • Homer2067 Calculating status...

    I have found the offending song that contains the '&' in the title, but the problem I am having is that it is attached to a saved slideshow that contains over 1000 pictures, and when I select the slideshow all I get is the beachball.  I waited over an hour for the slideshow to load, but still nothing.  Am I not giving iPhoto enough time to load the slideshow?  Is there a way to delete the slideshow without it trying to load?  Not sure what to do now.  I guess I'll have to wait until a fix comes in.

  • ronboze Calculating status...

    Thanks for taking the time to re-post the solution!!!

  • carolinseattle Calculating status...

    Mr. Delaney,

     

    Excellent instructions!!  Anyone who can't wait for Apple to get around to an update would easily be able to follow these instructions.  Thanks for taking the time to help others!

     

    Carol

  • Everest cat Calculating status...

    You are my best friend!  Thank you!!!  It worked perfectly after hours of frustration.

  • Brian Smith7 Calculating status...

    Thank you SO MUCH, Joseph.  Wow.  What an obscure problem. I don't know how anyone figured this out.  But, it worked for me!

  • Ralph Edgar Bennewitz Calculating status...

    PERFECT!

    i had a "custom" song defined per default and just choosed a "standard inbuild iphoto song". THATS IT.

     

    it took in total 45 sec ;-) luv u ;-)

  • llinnen Calculating status...

    Thanks, Joseph. I spent about an hour in the Apple Store yesterday trying to get this fixed. They suggested the rebuilding options in iPhoto and reinstalling the system software, which I did last night. None of that worked, but Joseph's fix did work. I should have tried that before going to the Apple Store.

1 ... 9 10 11 12 13 ... 18 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (23)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.