Skip navigation

HT1338: OS X: Updating OS X and Mac App Store apps

Learn about OS X: Updating OS X and Mac App Store apps

HT1338 blank screen when hdmi cable is plugged

9312 Views 20 Replies Latest reply: Aug 11, 2013 10:53 AM by koppah RSS
1 2 Previous Next
Kjeldor Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 23, 2012 6:33 AM

Screen Shot 2012-09-23 at 8.49.46 PM.png

 

I get a black screen with the mouse cursor whenever I try to plug in my macbook pro with retina display to my HDMI cable tv. last week it works fine, now it doesnt.

 

I tried booting into windows 7 and it works fine there. When I boot back to Mountain Lion, and plug it in again, its the same...

 

As you can see, I get weird windows when I try right clicking on the screen, I see this both on my HDTV and on my mac. Remember, this was working fine just last week. My macbook pro is just 2 weeks old. I even used to watch HD movies here, now cant...

MacBook Pro with Retina display, OS X Mountain Lion (10.8.2)
  • sh3toor Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2012 8:24 PM (in response to Kjeldor)

    I'm having the same problem! It was fine 4 days ago but I don't know what happened... I think it has to do with the new update maybe?

  • kckaos Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 26, 2012 12:26 PM (in response to Kjeldor)

    I'm also having this problem, and it also seems to have only been happening since the last update!!

  • joepl Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 26, 2012 4:00 PM (in response to Kjeldor)

    I am having the same issue. I am using MacBook Pro with Retina display, OS X  (10.7.5)

  • The_Virginian Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 26, 2012 6:44 PM (in response to Kjeldor)

    Same problem here. Under 10.8.1, I could plug in the HDMI cable and it would display on my TV. A few days ago, I upgraded to 10.8.2, and now my screen goes black on the Retina MacBook Pro when I plug in the HDMI cable if it's connected to the TV. It seems to transmit that black screen to the TV. The reason I say so is that I can see a magnified white outline of my cursor against the black background on both the laptop and on the TV. I get the sound, and I can move the cursor around on the TV screen. (You might not see it because the cursor can fall off the edges---the black desktop is bigger than the portion you see on the monitor), but everything else on both screens is black.

     

    Also, after the upgrade, I started getting weird graphics artifacts in Safari. The red-yellow-green buttons in the upper left get underlined---short horizontal red lines under the red button, yellow under the yellow, etc., and gray lines under the window title text.

     

    I think Apple is struggling with the video system on the rMBP. Under the version of Lion it came with, I got multiple crashes per day. An upgrade to 10.8.1 fixed that problem completely. It worked great on the laptop and the TV with no crashes. Now with 10.8.2, I can no longer connect it to an external monitor via HDMI, it appears. I wonder what surprises 10.8.3 will bring.

  • b0dylanguage Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 26, 2012 7:13 PM (in response to Kjeldor)

    yep, having the same issue on my end.  before the update to 10.8.2 i could plug into my tv via hdmi without any problems.  now, having updated to the latest build, i just get a blank screen on both my computer monitor and the tv.  funny: plugging into an external monitor via hdmi still works without a hitch. 

     

    apple: hopefully we can see a fix before sunday?  if not, how am i going to enjoy streaming my NFL games?

  • kckaos Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 27, 2012 1:29 AM (in response to Kjeldor)

    joepl, by the looks of things is still running snow leopard, and its still affecting him?? There was a spacific retina display update not so long ago maybe it could have been that, rather than the ML update??

  • joepl Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 27, 2012 4:56 AM (in response to kckaos)

    kckaos, this is my first mac and I am a newbie. I thought 10.7.5 is lion. I bought my mbp w/ retina in late June but I haven't upgraded to Mountain Lion.

  • kckaos Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 27, 2012 9:39 AM (in response to joepl)

    Yeah sorry joepl, my bad! i meant to say lion!! But this still leads me to belive that it can't be the ML update unless they updated lion with the same issue??

  • koppah Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 27, 2012 10:15 AM (in response to kckaos)

    I'm also seeing this. Was working fine in 10.8.1.

     

    Software  OS X 10.8.2 (12C54)

  • joepl Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 27, 2012 10:29 AM (in response to kckaos)

    kckaos, I am looking at my update log. I remember everything was working fine on 9/22. On 9/23 there was a couple update - MAC OS X Update 10.7.5 and MacBook Pro Retina EFI update. And ever since that's when I start experiencing the problem.

  • koppah Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 27, 2012 2:14 PM (in response to koppah)

    I'm now also seeing this with the VGA adapter. :-/

  • fribay Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 28, 2012 2:21 AM (in response to joepl)

    Same with me - everything fine until I updated the firmware and the OS update a few days ago. How soon is this going to be fixed?

  • kisayg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 29, 2012 3:26 AM (in response to Kjeldor)

    same problem here. i finally got it to work cause i was originally having problems with the audio not working. now i just updated the OS and it's not working. black screen and mouse.

  • jewski32 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 29, 2012 9:33 AM (in response to Kjeldor)

    OK I think have may have found a way to help us.  I too was suffering this loss.  I would plug HDMI and TV together and the screen would go black and it was working fine all summer up until a week ago or so.  I contacted apple support and the guy told me to go to the apple icon (top left) then select system preferences.  Then hit displays.  Now when this comes up make sure the mirroring option is checked.  Then this is the weirdest thing.  Now hold down the option button on the keyboard.  A tab will appear readin "Detect displays".  He said this should work.  I haven't tried it yet but let me know if it works.  He also said tht the option used to be there but now it is not.  Being apple strives to make things simple and dummy proof, to take away this option just makes it harder for people to find a button.  Not a good move I think.  Again, let me know if this works.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.