2 Replies Latest reply: Sep 26, 2012 9:59 PM by nohemy02
nohemy02 Level 1 Level 1 (0 points)

I'm trying to download 10.8.2 but it says this update requires OS X version 10.8. but I can't find it if someone could help it would be great thank you


iMac