Skip navigation

Mountain lion wifi problems

123704 Views 371 Replies Latest reply: Mar 1, 2014 10:21 PM by lfcitz RSS Branched to a new discussion.
  • santranyc Level 1 Level 1 (10 points)
    Currently Being Moderated
    Sep 19, 2012 8:12 PM (in response to paulduv)

    Well, 10.8.2 was just released.  It's given me a bunch of problems completely unrelated to this thread, but there may be a chance that 10.8.2 fixed the wifi problem.

     

    All I know is: I'm using wifi on my 2007 MBP for the first time in over a month, and it actually is working!

     

    I have not tested it extensively with AirTunes, however.

  • Robert Follis Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 20, 2012 8:55 AM (in response to henrijacobs)

    MacBook Pro and Airport Extreme

     

    10.8.2 has now introduced to my Pro the problem 10.8.1 gave me on my Air!

     

    After sleep I get connected but Wi-fi menu has '!' and says no internet connection

    Renewing DHCP lease does not work

    Tried new location with Open DNS and that worked once

    Tried PRAM reset

     

    Any ideas please

     

    Cheers Robert

  • Luke8400 Calculating status...
    Currently Being Moderated
    Sep 20, 2012 3:55 PM (in response to santranyc)

    I'm still having the same problem, even after the latest OS X update and MBP firmware update. Sometimes my wifi will stay on for hours...other times, it disconnects every few minutes. Very inconsistent, and it doesn't affect any other device on my network...just the MacBook Pro. Again, it's fine if I switch over to Windows...

  • Jarham Calculating status...
    Currently Being Moderated
    Sep 23, 2012 4:37 PM (in response to henrijacobs)

    I'm pleased to finally find others describing the same issue I've been having since installing ML. Definitely not pleased that this is still an issue. For the first time, and not the last, I imagine, I'm genuinely angry with Apple.

     

    I stay connected to the wifi network itself but have to run the diagnostic every 2-5 minutes so it can sort itself out and tell me my connection "seems to be working fine", until the next time of course. I've noticed some comments about volume of data having an effect - this is true for me, also. I can surf text-based pages for maybe 10 or 15 minutes between diags, but I need 2 or 3 diags to get through a short YouTube video. Intensely frustrating!

     

    And since upgrading my iPhone to iOS 6, its happening on it, too! Unbelievable!

     

    If I have to go spend money on an Airport Express as a reward for this OS "upgrading" business, I will be most displeased. I loathe Windows machines, but this is not acceptable for the premium I paid for Apple products.

  • yhl899 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2012 6:20 PM (in response to Jarham)

    I can totally understand this frustration. I updated to 10.8.2 hoping that this would fix the problem but it got worst. Not only am I loosing connectivity but Safari would crash or become unresponsive after loosing the Wifi connectivity. I was told a while back ago by technical support from Apple (after paying $49) for this assistance that nothing can be done and that 10.8.2 would solve the issue. But it didn't. So, what I did, like someone suggested, I purchased a new router, a Dual Band (2.4 & 5ghz) wireless-n router, try it and its been 4 days now, it seems fine. No lost connection and no crashes so far....my fingers crossed!!

     

    Now, is Apple going to refund the cost for the router, NO. Would I be able to get the $19.99 back for purchasing ML? NO! I am screwed anyway.

     

    I had another thread here, "Did Apple rushed the 10.8.2 update?" - I think they did. Is Apple getting to be "Too successful to care?"...... I had better chance of stable experience with Microsoft windows than Mac OS lately...

     

    Apple, hope you improve. Otherwise I may decide to go back to Windows, not that you care...

  • mkrstf Level 1 Level 1 (20 points)
    Currently Being Moderated
    Sep 24, 2012 3:50 AM (in response to yhl899)

    I bought a Retina MacBook Pro in the end of August so it came with Mountain Lion preinstalled. I had two major issues with it. Wake up from sleep from was very slow, sometimes 10 seconds (not from deep sleep).

    The other one was a very big problem with connecting to wifi networks. The strange thing was that in the beginning it couldn't connect to my own router or if it could then there were regular drop outs and slow downs in internet speed. After a while (without any kinds of update) the connection problem gone with my own router but the speed was still quite unreliable. Still I couldn't connect to the majority of routers when I was on the road. Usually it said "connection timed out". To be honest I can't remember one wifi network from the last two months which I could connect to except my home router. I did extensive testing, one of the most interesting problems was my neighbor's router (the most popular Linksys WRT54G) which I couldn't connect at all, it didn't accept the given password even if my other devices could connect flawlessly.

    Of course since then I downgraded to OS X 10.7.5, Lion and now everything works fine but it's totally insane, I cannot even imagine what kind of bug it can be in Mountain Lion which renders the OS absolutely unusable and something that Apple don't work out exclusively. Maybe not everyone has these problems even if all Retina and standard MacBooks have the same networking hardware. It must be a joke.

  • boiler76 Calculating status...
    Currently Being Moderated
    Sep 24, 2012 6:02 AM (in response to henrijacobs)

    I have been having the same problem. I have a two year old iMac. Ever since I installed Mountain Lion, I cannot maintain a consistent wifi connection. I have tried everything suggested. The only thing that works is if I go into the system configuration folder and delete all of the the network files and restart. This give me connection for a few minutes and then it goes out. My iMac doesn't show any other networks. Yesterday, I took it to an apple store. After twenty minutes or so, they told me my airport card needed to be replaced. This doesn't seem right to me. Has anyone else been told the same thing? I find it awfully coincidental that my wifi card needs to be replaced at exactly the same time I upgraded to Mountain Lion. I really don't want to shell out $100 for them to replace the wifi card. Any help would be greatly appreciated. Thank you.

  • Jarham Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 25, 2012 12:47 PM (in response to boiler76)

    It seems like I've heard every 'solution' I could imagine from other people's experiences. If Apple is aware of the problem we are all having, then they are still trying to figure it out.

     

    I imagine, as an Apple Genius, the worst thing you can do is appear uncertain or say, "I don't know". But if Apple is aware of our problem and doesn't have a solution or reassurance that they're working on one, then its irresponsible business practice to confidently hand out "solutions" which are probably expensive, and may or may not solve the problem. I feel your pain.

  • Rotrunner Calculating status...
    Currently Being Moderated
    Sep 25, 2012 11:16 PM (in response to henrijacobs)

    Hallo,

     

    since the upgrade from Lion to Mointain Lion it's get really worse with the wifi problems. It's start with the upgrade to Mointain Lion.

     

    At least once a day the MacBook Pro lost the wifi connection, it's doesent matter which wifi network is used and than the only method to get wifi connection back is the Reboot. 

    I really try every hint from the www but nothing solved the problem.

     

    The problem must be ML the only thing changed so far in that time on my side.

     

    Lion was not really an improvement, so not an option. If their is no solution I have to Fallback to Snow Leo. The last stable Apple like OS Version.

     

     

    br

    Rotrunner

  • iSimoInfcom Calculating status...
    Currently Being Moderated
    Sep 27, 2012 5:09 AM (in response to henrijacobs)

    if i reboot the router the wifi works very well... Apple are you serious??????????? i want back in 2002, when Apple was Apple.

  • russmcc Calculating status...
    Currently Being Moderated
    Sep 27, 2012 7:18 AM (in response to iSimoInfcom)

    This worked for me as well..... I rebooted the router even though everything else worked on the router but the macbook air....

     

    It works fine now

     

     

    Good luck

  • mkrstf Level 1 Level 1 (20 points)
    Currently Being Moderated
    Sep 27, 2012 7:58 AM (in response to russmcc)

    My wifi problems disappeared after installing 10.8.2 update.

  • Scottish Mike Calculating status...
    Currently Being Moderated
    Sep 28, 2012 2:35 AM (in response to henrijacobs)

    I have had this problem for such a long time now, ever since Snow Leopard and I have just installed 10.8.2.  In order to load a page I have to renew the DHCP lease every time. I was hoping that the latest upgrade would sort this out but absolutely nothing has changed...

     

    It happens in Chrome, Firefox and on Safari...  I've tried all the suggestions and even set the MTU to 1453 but nothing makes a difference..

     

    Can anyone give another suggestion for a fix??  Help!!!

  • chogokin666 Calculating status...
    Currently Being Moderated
    Sep 28, 2012 11:22 AM (in response to Scottish Mike)

    10.8.2 did not fix this problem for me one iota. I have a connection to the router and WIFI signal is great and NO INTERNET CONNECTION. This occurs at random intervals. Have to disable and reenable WIFI. Im at a loss what could be causing this. It is definately not on the routers end because others devices on the network dont suffer from this. Why oh why did I follow the prompt to update Snow Leopard to 10.8 and then Mountain Lion its been nothing but aggravation since. Never had  connectivity or battery problems now thats all I have. Also running a speedtest on Macbook will yeild a significantly lower  score than on a device right next to it on the same network 13Mbps to 1.8Mbps Etherenet cable into router over 30Mbps. As well as not being able to stream audio without constant buffering leads me to believe there is a glitch in the coding of this OS.

  • Joseph G Stroll Sr Calculating status...
    Currently Being Moderated
    Sep 28, 2012 11:41 AM (in response to chogokin666)

    I went back to reinstall the Airport utility but went for the 5.2 version.  This causes Time Cap  to reset back to the Apple default settings.  After this Appel Time Cap  worked just fine.

     

    I found the older software on the Apple website under Airport Utility 5.3

     

    Good luck!

     

    Joe

1 ... 4 5 6 7 8 ... 25 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.