Skip navigation

Apple TV2: Hulu Plus app (only) doesn't load content, everything else does

5262 Views 13 Replies Latest reply: Dec 2, 2012 6:04 PM by TA_Tellez RSS
saxophonedoug Calculating status...
Currently Being Moderated
Sep 26, 2012 10:13 PM

Please help me figure this Hulu/ATV2 (Apple TV 2) problem out:

 

The Hulu Plus application on my ATV2 is not loading content, though it will load the content browsing information. I can navigate the shows and movies, etc., but once I try to hit "play" it gives me a pinwheel for about a minute and then something like "An error has occurred loading this content. Try again later." It does this for all content, even movie trailers.

 

Hulu Plus will work fine on the computer and an iPad on the same network.

 

Every other app on on the ATV2 also works flawlessly (Netflix, movies, etc.).

 

I've tried resetting settings, rebooting/restarting, you name it. Any ideas on what's going wrong?

 

I'm using a Motorola SBG6580 gateway router hooked up to a Netgear Ethernet switcher. Even without the switcher the problem persists.

 

Cheers,

 

Doug

AppleTV 2, iOS 6

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.