Skip navigation

iMessages fail to send

4717 Views 38 Replies Latest reply: Oct 17, 2013 9:55 AM by richmlee RSS
1 2 3 Previous Next
Rob Wheatley Level 1 Level 1 (15 points)
Currently Being Moderated
Sep 22, 2012 1:49 PM

I know there are a ton of problems with iMessages, but I thought I'd put this one in as Googling the console error gets me nothing.

 

 

If I dont send a message for a while. The first message that I send always fails. Re-trying to send the message will work and I'll be fine again until I leave messages alone for a while and then it starts over. Also, when in this mode, I receive no messages either. It seems I have to 'wake it up' and re-establish a connection all the time to send or recive. I've reported it to Apple, but wondered if anyone here could help.....?

 

I get the following errors in my console.

 

22/09/2012 21:40:26.407 Messages[340]: [Warning] Updating typing guid on IMMessage from xxxxxxxxxx to xxxxxxxxxxxx

22/09/2012 21:40:48.071 imagent[296]: [Warning] FTMessageDelivery failed! Error (APSErrorDomain:2): Server rejected message as invalid (null)

22/09/2012 21:40:48.071 imagent[296]: [Warning] FTMessageDelivery failed! Error (APSErrorDomain:2): Server rejected message as invalid (null)

22/09/2012 21:40:48.249 imagent[296]: [Warning] FTMessageDelivery failed! Error (APSErrorDomain:2): Server rejected message as invalid (null)

22/09/2012 21:40:50.988 Messages[340]: [Warning] -[ChatTranscriptViewController _increaseResourceLoadCountForURL:] url called for url: ichat-resource://coreui/exclamation-pressed with nil _loadingIdentifiers

 

 

I've replaced the IDs with xxxxxxxxx for privacy.

MacBook Air, OS X Mountain Lion, New 2011 model
  • renefromsontra Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2012 3:57 AM (in response to Rob Wheatley)

    I have exactly the same problem and still could not receive the issue.

  • tookish Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 25, 2012 11:18 AM (in response to Rob Wheatley)

    Yes this is exaclty what is happening to me and has been happening to me for months. I thought iOS6 and 10.8.2 would help but they don't. I've turned messages on/off so many times as many poeple say that helps them, but it doesn't work for me.

     

    Also, my messages are never in sync....if I send one from my phone, it won't show up on my macbook for a very long time. If someone messages me, my phone will get it but it won't show up on my macbook, again, for a long time. If I get a message, I'll read it on my phone, then type a response out on my macbook and try to send it. It will fail, then it appears messages "catches up" and I can resend my message then.

     

    This is EXTREMELY annoying behaviour as it basically means messages is uselss to me. I have friends who have no troulbe at all swithcing between devices, sending messages, etc. And I just want mine to work like it's supposed to.

     

    Yes I have setup everything up correctly, I have send/receive on my iPhone5 setup to my phone number, and two emails addresses....just like it is setup on my macbook. New conversations are both set to the same (my phone number).

     

    Anyone got any ideas? Am I just the super unlucky person that messages won't work for?

     

    P.S. my Photostream is incredicbly slow too...probably not related but worth mentioning.

  • renefromsontra Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 27, 2012 12:45 PM (in response to Rob Wheatley)

    Thank for the help

     

    Unfortunately it does not work as I am still able sign in and no 2nd account is created.

  • Spencer Swift Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 4, 2012 8:22 AM (in response to Rob Wheatley)

    Just adding my $0.02.

     

    Quick summary - Logging out of and back in to my iMessage account in Messages.app->Preferences->Accounts seems to be fixing this problem for me.

     

    I've been having the same or very similar problem since about Oct. 2, 2012.  iOS (6.0) Messages and OS X (10.8.2) Messages had been working and syncing fine for a while.  Then OS X Messages stopped syncing through iMessage and could not send out over iMessge at all.  Google and Yahoo IM in OS X Messages kept working fine during the same period.  No amount of toggling things off/on in the Accounts pane made a difference.  But so far, logging out and in to the iMessage account in OS X Messags seems to fix it each time.

     

    I don't see anything obvious in my Console log, except for the GUID message given in the original post.  Not sure what that means exactly or how it is related.  Other than it seems like the account gets foobar'ed.

  • Spencer Swift Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 4, 2012 8:31 AM (in response to Spencer Swift)

    I should add, I have a suspicion of a back-end iCloud/iMessage update that might be related.  When this started, I noticed that my iPhone and Mac both had a new @icloud.com email address authorized for messaging.  That was clearly related to the @me.com address I was using.  I did not do anything to claim or start using that @icloud.com address.  It just appeared automatically.

  • BigJoeCool Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 5, 2013 11:18 AM (in response to Rob Wheatley)

    Hello chaps - myself and another guy that I found via Twitter are still experiencing this issue. We're both on Virgin Media in the UK using a SuperHub - I was wondering whether a) you'd managed to finally resolve this (as often it seems to be fixed, only to break again a few hours later) and b) whether you are also on Virgin Media?

  • Ralph Johns (UK) Level 9 Level 9 (66,835 points)
    Currently Being Moderated
    Jan 5, 2013 2:01 PM (in response to Rob Wheatley)

    Hi,

     

    I had two iPhones using different Apple IDs (Although both linked to the same iCloud Account).

    Messages on the Mac popped up the Alert form the server saying the second iPhone Number and the Apple ID were being Added  ( I In fact Denied them - they get added but not ticked)

     

    Later the iMessages server seemed to thing they should be active and the Messages app on the Mac showed both Apple IDs and both iPhone numbers.

     

    I deleted the Apple ID on the second iPhone then put it in Airplane Mode.

    This removed the Apple ID and the second iPhone's Number from Messages.

     

    I was able to reinstate the Apple ID on the second phone without it showing up on the Mac.

     

    Summary.

    I did similar from the iPhone end.

     

     

    3Sigcopy2.png
    10:01 PM      Saturday; January 5, 2013


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Spencer Swift Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 1, 2013 9:01 AM (in response to Rob Wheatley)

    This sounds like an ongoing situation for you. If it was only yesterday (2/28/2013), there was a known outage of some iCloud services.

     

    http://www.apple.com/support/systemstatus/

  • Ralph Johns (UK) Level 9 Level 9 (66,835 points)
    Currently Being Moderated
    Mar 1, 2013 12:33 PM (in response to Rob Wheatley)

    Hi Rob,

     

    In the Finder > Go Menu > Go to Folder type in ~/Library/Preferences in the dialogue that appears.

    In the Preferences Folder find com.apple.imagent.plist and drag it to the Trash.

     

    Next go to Applications/Utilities an open Activity Monitor and find imagent in the list (it will be in lower case)

    Use the Quit option and confirm Force Quit.  (it will respawn almost immediately)

     

    Restart Messages.

     

    3Sigcopy2.png
    8:33 PM      Friday; March 1, 2013


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Ralph Johns (UK) Level 9 Level 9 (66,835 points)
    Currently Being Moderated
    Mar 1, 2013 1:10 PM (in response to Rob Wheatley)

    Hi Rob,

     

    Yes I saw that in the Original Post which is why I targeted IMAgent.

     

    In Messages what Style are  you using ?  (View Menu > Messages)

    Balloons, Boxes or Compact ?

     

    If Balloons (it has been a problem in iChat form time to time) change it one of the others.

    It makes no difference to how it is seen on an iOS device.

     

    3Sigcopy2.png
    9:08 PM      Friday; March 1, 2013


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.