Skip navigation

Can't pair remote

14283 Views 30 Replies Latest reply: Jun 2, 2013 7:28 PM by Cawas RSS
  • b j t Level 4 Level 4 (3,670 points)
    Currently Being Moderated
    Mar 24, 2012 11:25 AM (in response to abross86)

    Good to here you fixed it.

  • saxlax Calculating status...
    Currently Being Moderated
    Apr 24, 2012 6:11 AM (in response to abross86)

    Hey! I'm missing too... Can't find it anywhere though :/ How to I find this one?!

    Dont have any Mac friends either... hehe



  • schpink Calculating status...
    Currently Being Moderated
    Jun 5, 2012 3:17 PM (in response to abross86)

    I would LOVE to do this operation also, but I have to confess I can't find the Library/LaunchDaemons folder.  Could you help a less experienced person with this?



  • The Narcissist Calculating status...
    Currently Being Moderated
    Sep 28, 2012 9:56 PM (in response to abross86)

    Thank you, abross86 that was awesome! I have very limited knowledge of programming stuff, so your detailed answers were great. FYI, what button combo worked for me is MENU + Back button for 2 seconds. What a sight for sore eyes after all that trouble. Thanks again!

  • lambock Calculating status...
    Currently Being Moderated
    Oct 4, 2012 2:52 AM (in response to abross86)

    On my MacBook (Mid'09) the problem with pairing a white remote was aparently the BetterTouchTool. I first added the file mentioned before to the LaunchDeamons folder though. Thanks and good luck to all the others

  • mariosangiorgio Calculating status...
    Currently Being Moderated
    Nov 26, 2012 8:46 AM (in response to lambock)

    Can you please tell me how you fixed the issue with better touch tool?


    I tried everything I read on the web, I tried to pair with better touch tool enabled, disabled but without success.


    The remote is working, it is just not pairing.

    I even did the iSight test, and if I hold Menu and Next after 5 seconds I can see a signal emitted, but, I don't know why, it is not received by my Mac.

  • lambock Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 26, 2012 9:19 AM (in response to mariosangiorgio)

    My "solution" wasn't really a good one. I just quit BBT and the remote worked again. Sorry, not too versed to solve that probelm in an accurate way...

  • mariosangiorgio Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 26, 2012 9:23 AM (in response to lambock)

    Ok. Thanks for your reply!

  • ianji Calculating status...
    Currently Being Moderated
    Dec 22, 2012 4:21 PM (in response to abross86)

    I bought an iMac in late 2009 with which I could not pair the supplied remote. I tried a couple of times since then without luck and just decided to have another go, which brought me here. I checked in /Library/LaunchDaemons and there was no so I found a copy online somewhere and added it. After rebooting I tried pairing and nothing still happened. So then I started trying different button combinations and bingo, it paired! Well now I didn't know whether adding the plist file had had any effect so I deleted it and rebooted again then unpaired the remote from security prefs and tried pairing again. It still worked.


    My conclusion is that at least on a late 2009 iMac the plist file is not required for pairing to work, all that is required is pressing the correct two buttons simultaneously for about 5 seconds. So why had I been going wrong? Clicking on "Pair..." in the Advanced settings under Security & Privacy -> General pops up a box telling you to use the "Menu" and "Next" buttons. Well on my remote there is a circle with four outer direction buttons and an inner unlabelled button. Below that are two buttons, "MENU" on the left, and one on the right with play/pause symbols. For some reason I had got it into my head that I had to press those two and I might not have even tried any other button combinations, or at least not for long enough to work. So the correct combination is the "MENU" button together with the unlabelled button. Three years to solve that!

  • mac_user1986 Calculating status...
    Currently Being Moderated
    Feb 20, 2013 3:08 PM (in response to ianji)

    I know it's month ago but I have the same issue. Can you tell me where I find the file? I don't find one and the link above just gives me a .txt file.



  • ianji Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 21, 2013 5:09 AM (in response to ianji)

    I just tried the mediafire link from the above post by abross86 and I got the plist file. It did have a .txt extension appended but you just need to remove that. In my case though the plist file was a red herring and was not required in order to pair the remote (my problem was that I had been pressing the wrong buttons).

  • Cawas Calculating status...
    Currently Being Moderated
    May 25, 2013 9:21 PM (in response to abross86)

    In my case, it was some app being initialized on Login Items that was conflicting somehow with the remote.


    No need to use the remotepairtool plist file here.


    My advice to find out if it's a conflicting software: create a Guest User or an alternate clean Admin User, whatever, and try to pair in there.


    Also, use Photo Booth to see if the infra red light is actually working. Digital cameras can see the infra red light.


    It's pretty interesting seeing how, when I press any 2 buttons at same time it holds the light for 5 seconds, then emits a much faster blinking light. Which means, in my case, it probably actually pairs up with any of two buttons combination.


    Just spend almost 3 hours researching around and trying to make this work, for the very first time.

  • clydesdale91 Calculating status...
    Currently Being Moderated
    May 28, 2013 12:34 AM (in response to abross86)

    You just saved my life with this file.  I have been searching a long time for a way to fixing the pairing problem I've had with my 2007 macbook ever since I upgraded in to lion. Thanks!


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.