1 Reply Latest reply: Apr 6, 2013 8:47 PM by UptimeJeff
RockyMountainMac Level 1 Level 1 (0 points)

So I have had this machine in production for quite sometime now. Yesterday my certificate expired, so I attempted to renew it through Thawte. I basically did a re-issue with the exact same information for the old certificate, but every time I try to "Add Signed Certificate" (The file I receive back from Thawte after issuing the "Request Signed Certificate From CA..." I get an "Error while writing settings (-1)" the really STUPID thing, is that the certificate which Thawte issued to me, shows up in Keychain, alongside the one that is still "Self Signed"........

 

Can ANYONE help me with this issue, it is driving me insane and of course my domain is now unsigned which isn't a good thing to have for a production server.

Look forward to any responses out there. I have tried from scratch as well, but there is something that is persisting from the old certificate that is not happy and I am unable to track that down.....

 

Thanks in advance.

Jeff.

  • 1. Re: 10.4 SERVER - CERTIFICATE **** !! Please HELP....
    UptimeJeff Level 4 Level 4 (3,390 points)

    I think 10.4 only produces 1024bit keys..

     

    My habit is that I create all keys on a 10.6 server, generate the CSR from that machine, get it signed, then import the combo into whatever server I need it for (10.4 through 10.8)

     

    Do you have a 10.5+ server? if so, why not create a new key/csr and get it signed.

    Then import in your 10.4 server.