Skip navigation

Aperture 3.4.1 won't edit some images

888 Views 4 Replies Latest reply: Apr 25, 2013 6:18 AM by Kirby Krieger RSS
Malcolm Hollick Calculating status...
Currently Being Moderated
Sep 30, 2012 8:54 PM

I upgraded my iPhoto library to v9.4 and all seems to be ok. I then installed Aperture 3.4.1. Some of my photos I can edit ok in Aperture, but many of them cannot be edited even though taken with the same camera on the same day. Where the histogram normally comes up there is the message "iPhoto externally edited image". In the past I've done most of my editing in Photoshop Elements, with only a few edited in iPhoto. There doesn't seem to be any pattern to the Aperture problem, however. Some  images that have been edited in PS can be edited in Aperture, and some that I haven't touched cannot be edited in Aperture. I'm pretty sure the same applies to iPhoto editing.

 

Any ideas on how to get around this problem?

 

Malcolm

MacBook Pro, OS X Mountain Lion (10.8.2)
  • Thomas Emmerich Level 4 Level 4 (3,470 points)
    Currently Being Moderated
    Sep 30, 2012 9:39 PM (in response to Malcolm Hollick)

    I haven't figured out why some images do that and other don't. But a solution is to right click an offending image and choose Duplicate Version. You'll get a 2nd copy that you can edit. You can then choose to keep or delete the one that won't edit as you see fit.

  • gonnygump Calculating status...
    Currently Being Moderated
    Apr 25, 2013 6:02 AM (in response to Malcolm Hollick)

    This is crazy.  I have hudreds of images that I imported from iPhoto.  Many fail to inherit the proper orientation (i.e., that were rotated in iPhoto, but for some reason fail to show properly in Aperture).  Does this mean I have to manually duplicate everyone, rotate it, and then delete the original?

  • Kirby Krieger Level 6 Level 6 (11,570 points)
    Currently Being Moderated
    Apr 25, 2013 6:18 AM (in response to gonnygump)

    Many contributors don't read threads marked as "Solved".  You might want to start a new thread.  Provide details on your software versions and exactly what is happening and how it differs from what you expect.  Also provide links to theads that you think are apropos.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.