Skip navigation

Sudden rMBP graphic performance issues

28375 Views 110 Replies Latest reply: Dec 16, 2013 11:31 AM by brsm1990 RSS
  • skater704 Calculating status...
    Currently Being Moderated
    Oct 1, 2012 5:56 PM (in response to w00fa)

    Anyone get any solutions from Apple yet besides the SMC reset?  I'm having the same issue here with Borderlands 2 and Skyrim (high frames per sec and now they are unplayable).

  • skater704 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 1, 2012 8:20 PM (in response to w00fa)

    Yes it ran great for about 2 weeks until last night.  To reset the SMB, you hold left shift, control, option, and press the power button correct? And then press the power button to start the machine? Any indications to show that I did it right? (Sound, led light, etc?)

  • skater704 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 3, 2012 10:04 AM (in response to w00fa)

    The SMC reset seems to be a temporary fix.  From what I've observed, the framerates in Borderlands 2 are at 40-50 when i first boot into windows.  But, if I've played for about one hour, they drop below 20.  As a test, I left it paused and came back two hours later, the frame rate was unplayable at 5-10.  To me, it seems to be a heat issue.  When the fans are chugging hard, the frames per sec seem to be really low.  Anyone else experience this?

  • buttmonki Level 1 Level 1 (15 points)
    Currently Being Moderated
    Oct 3, 2012 10:56 AM (in response to skater704)

    This is not the problem I have. I am playing in OSX, I close WoW/Diablo and shut the lid on the MacBook (sleep mode) unplug it, take it to another room (ironically the bedroom which is about 2-4 degrees cooler), plug it back in, open it up restart WoW/Diablo from launcher and frame rate has dropped to 5-10fps. The fans do not go at all. It sounds like your problem is a heat problem? Which I assume may be due to Windows. The other problem which most people on this forum seem to have is that the SMC somehow sets itself to the lowest possible setting so it isn't even possible for the computer to get hot as it is barely using anything. I have also noticed that where I have the energy saver set to highest graphics (not auto switching) it randomly switches back itself.


    Unfortunately I live in the UAE and there is no real Apple service here, so I cannot report it until I am I'm the UK for Xmas.

  • teggo Calculating status...
    Currently Being Moderated
    Oct 3, 2012 11:28 AM (in response to buttmonki)

    I have the same issue as you, SMC reset works. Doesn't seem related to heat as I can play as long as I want without issues, but waking up from sleep seems to be the issue.


    I've called support several times, but they are pretty clueless here and it seemed to have happend with the latest EFI update, at least the timing seems right. I'll go by an apple store again, to see if that helps, but so far I have had no luck. They just ask me to re-install, which does not solve this issue.

  • oleg.lestat Calculating status...
    Currently Being Moderated
    Oct 3, 2012 12:55 PM (in response to w00fa)

    Hi. I have problem with lags, and after reading this thread still cant find solution. I installed win7 via bootcamp and latest drivers from nvidia (306.23). After few days of normal gameplay, suddenly, i experienced lags - after playing mass effect 3 for 5 minutes I'm receiving lag tick every 1 sec, even after game closed and laptops cools down, it continues (i can see it on windows animations), only reboot helps, inspected through nvidia inspector - max temperature 72 degrease, 900/2500. What can i do?


    SMC reset works only for limited amount of time, 1 day maximum, and then all goes around.

  • teggo Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 3, 2012 1:44 PM (in response to oleg.lestat)

    There is no solution right now. Call apple support or take your laptop to an apple store, to make them recognize this issue. I've called them several times, but they are still not recognizing this as a new issue, so we need more people to report it.

  • skater704 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 3, 2012 3:42 PM (in response to teggo)

    I called in it.  They had me do something I haven't seen on the forum, a pram reset.


    It seems to have fixed my FPS for now.  They also told me to take the MBP into an apple retail store for a hardware diag tests. 

  • teggo Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 8, 2012 10:17 PM (in response to w00fa)

    So looks like I may have stumbled on something that works, this is only for advanced users though and I take no responsibility for any issues arising from following the below steps.


    Nvidia released new MacOS 10.8.2 drivers, but you need to change the .dist file before they will install. Generally nvidia drivers work with all their GPUs, but they only release drivers for GPUs they actually specifically tested, anyways.


    First thing first, check that you are on MacOS 10.8.2 (Mountain Lion), installing these drivers on any other version of MacOS will break your system and you'll be unable to boot, you've been warned!


    1) Install the latest Nvidia CUDA drivers found here, no need to change anything these install without having to modify anything



    2) Install the latest Nvidia MacOS drivers, these does not support MacBook pro retina by default so you'll have to modify the package.



    3) After you download open the Retail-304.00.05f02-macosx file and shortly after a new window should open called NVIDIA Drivers. Inside is an icon looking like an open box and the filename is 304.00.05f02 Web Release.


    4) Drag this box to your desktop


    5) Right click the file on your desktop and select Show Package Content


    6) Expand the Content folder and you'll see a file called Distribution.dist


    7) Right-click and select open with, then Other...


    8) Scroll down until you find TextEdit, double-click TextEdit


    9) Locate this line: var found_hardware = 0;


    10) change 0 to 1 so the line reads: var found_hardware = 1;


    11) Close Textedit


    12) Close Finder


    13) Double click the 304.00.05f02 Web Release file that you copied to your desktop


    14) Let it install, when it asks you to reboot, click reboot


    15) Hope it works!


    So far it's been working for me, but I only tested for a few hours, so no guarantees this fix is permanent, but for me it was worth a shot at least!


    Message was edited by: teggo

  • mtr64 Calculating status...
    Currently Being Moderated
    Oct 16, 2012 4:50 PM (in response to teggo)

    Took mine to the apple store they haven't heard of the problem yet, but both my roommate and I have the same issue with brand new rMBPs. I just tried your solution hope it works. Thanks teggo.

  • teggo Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 16, 2012 8:17 PM (in response to mtr64)

    So far I haven't had any issues in MacOS or Windows 7 after I installed the latest nvidia drivers for the 650m on both systems, so no need to SMC reset anymore.


    Let me know if it doesn't help though!

  • mtr64 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 17, 2012 2:51 PM (in response to teggo)

    I don't think it worked had to reset smc again today...I dont think it is just a graphics issue I think it is a power management issue that needs to be updated.

1 2 3 4 ... 8 Previous Next


More Like This

  • Retrieving data ...

Related Articles

Bookmarked By (12)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.