Skip navigation

Lost photos while downloading

143 Views 1 Reply Latest reply: Oct 2, 2012 8:28 AM by topcop1 RSS
topcop1 Level 1 Level 1 (5 points)
Currently Being Moderated
Oct 2, 2012 7:05 AM

Hope someone has a god idea on this.


Just got back from a special photo shoot and downloaded my pictures to my Mac.  I had two cameras, each with over 400 shots.


I downloaded the first camera and chose the "Delete Photos in camera" option.  Took a couple of minutes to detele the camera photos.  Worked just fine, just as it always had. 


I then downloaded the second camera and again, when the downloading was finished I chose the "Delete Photos in camera" option.  This time, 15 minutes later and it was still deleting photos from the camera.  A waited a while longer and it still wasn't finished.  I then went to Force Quit and it said "Iphoto not responding."  Well, figuiring my pictures were alrady downloaded in it was just working on deleting my camera, I chose Force Quit.


Well, when I checked my photos there were only 196 out of over 400.


I have tried restarting and looking everywhere for the missing pictures, too no avail.


Any ideas???



More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.