1 2 Previous Next 21 Replies Latest reply: Mar 30, 2014 1:38 PM by pixeleyes Branched to a new discussion.
samgtz Level 1 Level 1 (0 points)

HELPPPPPP, I use remote desktop to turn on my Xserve and I cannot configure the LOM on the Xserver running the new 10.8 Mountain Lion server. I NEED HELP ANYONE!!!


Xserve, OS X Mountain Lion (10.8.1)
  • 1. Re: What happened with my LOM?
    Steven Smith12 Level 1 Level 1 (10 points)

    LOM support was removed in Mac OS X Lion Server. Just keep saying it...Apple Love's Their Enterprise Hardware...Apple Love's Their Enterprise Hardware....

     

    Sorry to bare the bad news. This is a major reason I've not upgraded any of my 2009 Xserves from 10.6.8 Server.

  • 2. Re: What happened with my LOM?
    Some Dude Level 1 Level 1 (55 points)

    I believe you mis-spoke there.  LOM is indeed available in Lion Server, just not in Mountain Lion Server.  At least not yet. 

  • 3. Re: What happened with my LOM?
    Steven Smith12 Level 1 Level 1 (10 points)

    Hi, Some Dude,

     

    I happily stand corrected re: LOM in Lion Server. It took 10.7.5 Server's release for Apple's official LOM support to arrive. Prior to that LOM was 'available' in Lion but only with a non-apple workaround. Workarounds are not long-term solutions in most cases. If LOM support does make its way to Mountain Lion Server, then I'll upgrade my Xserves. Fingers and toes crossed.

     

    Thanks for the info, Some Dude.

  • 4. Re: What happened with my LOM?
    Some Dude Level 1 Level 1 (55 points)

    Just FYI on a post I made in another thread here. 

     

    FYI guys, after much research on my Early 2009 XServe.  LOM actually DOES work under Mountain Lion, provided that you had already configured it under Snow Leopard Server (or presumably Lion).  However, once configured (under SL or Lion), you cannot make any changes to it under Mountain Lion, there is no GUI and ipmitool is not to be found.  That should be easily fixable by Apple, if they get on the horse one of these days.  My experience has proven this works, but you must monitor it with Server Monitor from the old Snow Leopard Server days.  In other words, I have an old Snow Leopard Server sitting around that will not get upgraded at all, and that one is perfect for monitoring the new Mountain Lion install on the XServe.  I've got it sending automatic emails upon any 'incident' it sees, etc. etc.  But again, no way to change settings.  Keep in mind, my experience makes perfect sense actually - LOM by its nature is totally un-associated with the OS.  It runs on a totally separate little Intel processor and communicates with the Ethernet port completely independent of the OS.  This is a Good Thing (TM).  It means that whatever foolishness Apple does, you can still monitor your LOM port, even on a clean install of ML, provided that the LOM port was configured once upon a time under an earlier GUI.  I know this gets confusing a bit, but when you peel back the onion, it's not that surprising.  You have to separate "LOM Configuration" and "LOM Monitoring".  Lastly, I am even able to use the wonderful iPhone app that someone mentioned called IPMITouch, and can remotely shut down, restart, etc. the XServe running ML just like you would with Server Monitor.  You see all the variables, everything, it's perfect.  So my suggestion is that even for those who cannot keep a Snow Leopard Server around to use Server Monitor to monitor their LOM port on ML, just use the iPhone app.  You won't get the email notifications (unless configured previously with Server Monitor of course), but you can see what's up and do remote soft shutdowns, restarts, etc.

     

    I hope this helps someone, I've been spending WAY too much time on LOM lately.  Time to move on :-)

     

    Cheers!

    Some Dude

  • 5. Re: What happened with my LOM?
    samgtz Level 1 Level 1 (0 points)

    If I understood correctly, You are basically saying the following:

     

    1.- Install snow leopard on my Xserve 2009

    2- Configure LOM

    3.- Install Mountain lion on the same Xserve 2009 (can it be a clean install or just via upgrade to ML?)

    4.- Use the iPhone IPMI touch to control it.

     

    That's it?

     

    Sounds to good to be true but if this works then WOW we are in heaven.

     

    Thanks in advance.

  • 6. Re: What happened with my LOM?
    Steven Smith12 Level 1 Level 1 (10 points)

    Thanks for going the extra mile on this LOM issue, Some Dude. I know of at least two other 'dudes' who appreciate your efforts.

  • 7. Re: What happened with my LOM?
    Some Dude Level 1 Level 1 (55 points)

    Exactly SamGTZ.

     

    1. Install Snow Leopard Server.

    2. Configure LOM using Server Monitor (choosing the IP to use, login account/passwd, etc. and remember, you WON'T be able to change it later, so choose wisely!).  Also, set up email notifications and test them, make sure they work properly, again, you won't be able to change them later, at least not from the XServe running Mt. Lion.

    3.  Install Mountain Lion (and then Server add-on) to the XServe.  This can be a clean install or it can be an upgrade from SL Server, it matters not, same results occur in both cases.

    4.  Use the iPhone app IPMI Touch to monitor/control your XServe, and/or use an old Snow Leopard Server install with Server Monitor, it will still work!  The Server Monitor method is nice, because you can actually still make some minor changes to things, like the email notifications/SMTP server to use, etc.  Both methods work however, and both methods will importantly allow you to Shutdown, Restart, etc. if things get particularly nasty on your new ML Server.  Not that Apple would ever give us troubled OS code, but one never knows :-)

     

    Cheers gang.

  • 8. Re: What happened with my LOM?
    Some Dude Level 1 Level 1 (55 points)

    UPDATE!! 

     

    I just went back and tried it again, with a clean install of Mountain Lion and then adding on the Server add-on.  It turns out that at least with this latest Server add-on version released last week (specifically 2.1.1 released on 9/27), we now have the ability to edit LOM port as part of the Server install process!  You can indeed make changes now to the IP address, the LOM account itself, the physical Port it uses, etc. This is a welcome refresh for sure.  So, this should work whether you're doing a clean install like I just did, or an upgrade.  Because either way, you have to load normal ML first, then add-on Server second. The opportunity to edit LOM comes during the Server install portion.  I guess this might fall under what they call in the Release Notes for Server 2.1.1:

     

    'retaining network, DNS, and PHP settings installing or upgrading OSX Server'

    or

    'migrating from Lion Server and Snow Leopard Server'

     

    whatever it was, it works.

     

    -SomeDude

  • 9. Re: What happened with my LOM?
    samgtz Level 1 Level 1 (0 points)

    Some Dude, Hi again. I see that Apple is now allowing me to add the LOM account as well as the IP address. I have a question though, What address did you use for the LOM? I have 192.168.1.3 for my Ethernet 2 and I think the LOM must be different right?

     

    After everything is setup and ready. Did you try to use IPMI Touch?

     

    THANKS SO MUCH IN ADVANCE!!!!!!

  • 10. Re: What happened with my LOM?
    Some Dude Level 1 Level 1 (55 points)

    You have to use a different IP, yes, but it can be on the same subnet as your 192.168.1.3.  So you could use perhaps 192.168.1.20, assuming that IP is not being used for anything else on your network.  And as for IPMI Touch, as I noted earlier today in my post above, yes, it works, and yes, it's great, and yes it works fine with Mountain Lion and ML Server.  Hope that helps!

  • 11. Re: What happened with my LOM?
    samgtz Level 1 Level 1 (0 points)

    I will Try this immediately!!! thanks for everything. And yes, you are quite a nice Dude!!! hahaha.

     

    Hey, final question. For the IPMI Touch. Did you used IPMI v2.0 intel with RMCP+ protocol plus SHA1?

     

    Thanks and have an EXCELLENT DAY!!

     

    Sam

  • 12. Re: What happened with my LOM?
    Some Dude Level 1 Level 1 (55 points)

    For IPMI Touch, use v2.0 with ITCS Support and SHA1.

  • 13. Re: What happened with my LOM?
    DigitalAddict Level 1 Level 1 (5 points)

    Is there any way to edit the LOM configuration in Mountain Lion Server outside of initial configuration? 

     

    I had it installed on a 2009 Xserve well before the 2.1.1 release, and am at 2.2 currently.  I can see the LOM interface listed with the network interfaces, but can't see any way to configure it:

     

    Screenshot_1_17_13_1_13_AM.jpg

    I tried removing /var/db/.ServerSetupDone file which let Server.app walk throgh initial configuration again, but didn't see anything offered along the way.

     

    Just hoping there is is something I'm overlooking short of starting from scratch...

     

    Thanks!

  • 14. Re: What happened with my LOM?
    skynet3020 Level 1 Level 1 (0 points)

    what the **** !! apple becomes ever more laborious :-(

     

    why remove apple the server monitor in 10.8 ???

     

    now i got a xserve late 2009 and can't configure LOM before i have a 2006 xserve with lion, LOM works perfect; LOM is needed for every server look at HP, DELL etc

     

    APPLE > i say: that is unbelievably !!!

     

    F*****G icloud etc looking more to enterprise please !

     

    i'm a big Apple lover but now i turn somehow slowly away from it :-(

    if these things more badly to every update, i change willy-nilly to microsoft's Win2008R2

     

     

    Edit:

    i found something:

     

    go in server APP to network, then edit host name > click continue > again continue

    then change network > now i see LOM Port 1 and configure something

1 2 Previous Next