Skip navigation

Temp fix for iOS 6 not pushing Exchange mail

299663 Views 929 Replies Latest reply: Apr 14, 2014 10:35 AM by RaghuSatya RSS Branched to a new discussion.
  • DQMIA Calculating status...
    Currently Being Moderated
    Oct 2, 2012 7:32 AM (in response to Frank Malloy)

    That stinks but I've deployed ATT IP5's to 10 of my staff and not one of them has had any issues with push. 

  • Frank Malloy Level 2 Level 2 (350 points)
    Currently Being Moderated
    Oct 2, 2012 7:34 AM (in response to DQMIA)

    Hmmm...that is strange. Can't figure it out.

     

    Last failure just happened to me yesterday.

     

    Are they using the phone over AT&T LTE? Do you get LTE coverage?

  • DQMIA Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 2, 2012 7:44 AM (in response to Frank Malloy)

    Yes and Yes...very strange indeed that its not working for you

  • MikeC66 Calculating status...
    Currently Being Moderated
    Oct 2, 2012 7:49 AM (in response to superclay)

    An Update:

    I am on Verizon (I'm updated with the latest Verizon carrier update), I have an iPhone 5 (64 GB) and my company uses MS Exchange 2010. I was coming from a 4S on AT&T that worked perfectly. On Friday (9/21) when I got my phone I synched to my iCloud Backup and my phone was set up a couple of hours later, minus all my music and non-photo stream pictures. Saturday/Sunday I started noticing that I wasn’t getting any notifications.

     

    Monday morning at work I wasn’t getting anything and that's when I stumbled upon this page. I too was suffering with apsd crashes(10-15 per day since 9/23), some low memory crashes, etc. and no push on Exchange and then no push notifications all together (nothing from AP Mobile, Songpop, FB, etc.). My iMessages were sending green (as a text, not iMessage) and a reset/reboot/ or Airplane mode toggle would fix my phone for 5-30 minutes. I would also get all my push alerts at once after the reset. It has been very frustrating.

     

    I called Apple and spoke with several tier 1 and tier 2 individuals. They called me back multiple times and followed up with emails from their engineers.

     

    My last call was this past Friday (1 week of non push frustrations). After talking with a Tier 2 individual, I went into Settings, then Messages and limited my Send & Receive Addresses to 2 and did the same thing to my MacBook Pro and MacBook Air (as I thought the conflicts here might be causing some of the crashes). I did the same thing with FaceTime on my phone, Macbook pro and Macbook Air. I also went into Settings, iCloud, Account, Mail and turned OFF my @cloud.com email (I do believe this was an important step).

     

    At this time (after those setting were saved to iCloud) I went to Settings, General, Reset and "Erase all Content and Settings" and started my phone fresh. I connected to iCloud (with the new limited number of iCloud , Messages and FaceTime Send & Receive Addresses). My phone worked well and was very zippy with iMessages and FaceTime.

     

    About 3 hours later I connected 1 MS Exchange account (MS Exchange 2010) to my iPhone and I downloaded the GMail App and used that for my Gmail accounts, since It has push notifications.

     

    So far since Saturday, I have had push working well without any issues. I have forwarded all my GMail and other accounts to iCloud and all is working well (since this was working so well I deleted the GMail App).

     

    So, I currently have 1 Exchange and my iCould email push synching to my iPhone 5 and all is working well.

     

    I don't know if this will work for everyone, but if you follow all my steps I hope it works for you.

     

  • BeeJaay00 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 2, 2012 10:09 AM (in response to superclay)

    I downloaded the iPhone Confiiguration Utility and ran some tests while looking at the Console logs.  

     

    While connected to Wi-Fi (Cellular Data ON)

     

    Oct  2 09:43:44 BIG-B apsd[1231] <Error>: *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: 'Action PCActionMaintainPushKeepAliveInterval not appropriate for manual. PrefsStyle=push. _forceManualWhenRoaming = YES  onlyAllowedStyleSet=YES onlyAllowedStyle=push'

    *** First throw call stack:

    (0x398253e7 0x3438a963 0x396aca79 0x396ac1e9 0x37b54e67 0x397fa857 0x397fa503 0x397f9177 0x3976c23d 0x3976c0c9 0x37ab0dd3 0x37b54455 0xb176d 0x333dab20)

    Oct  2 09:43:44 BIG-B ReportCrash[1325] <Notice>: Formulating crash report for process apsd[1231]

    Oct  2 09:43:44 BIG-B com.apple.launchd[1] (com.apple.apsd[1231]) <Warning>: (com.apple.apsd) Job appears to have crashed: Abort trap: 6

     

     

    While connected to Cellular Data (Wi-Fi OFF)

     

         Same error as above

     

     

    Turned off Roaming and connected to Cellular Data (Wi-Fi OFF)

    Turned off roaming because of the "_forceManualWhenRoaming = YES" above

     

         Same error as above

     

     

     

    While connected to Wi-Fi (Cellular Data OFF)

     

         NO ERROR

     

     

     

    One thing I also noticed while connected to Cellular data is right before push email stopped working these appeared in the log:

     

    Oct  2 10:40:56 BIG-B wifid[14] <Error>: WiFi:[370888856.826819]: Disable WoW requested by "dataaccessd"

    Oct  2 10:40:57 BIG-B wifid[14] <Error>: WiFi:[370888857.092013]: Disable WoW requested by "apsd"

  • Frank Malloy Level 2 Level 2 (350 points)
    Currently Being Moderated
    Oct 2, 2012 10:15 AM (in response to MikeC66)

    I turned off @cloud.com as you did (I have no idea what this does as I use @me.com) but I still got a push failure this morning after that.

     

    I did not erase everything...this is a brand new phone!

  • Frank Malloy Level 2 Level 2 (350 points)
    Currently Being Moderated
    Oct 2, 2012 10:17 AM (in response to BeeJaay00)

    Thanks BeeJaay00 for your hard work.

     

    I am not familiar with iOS, but this:

     

    'Action PCActionMaintainPushKeepAliveInterval not appropriate for manual. PrefsStyle=push. _forceManualWhenRoaming = YES  onlyAllowedStyleSet=YES onlyAllowedStyle=push'

     

    Looks strange. What does "not appropriate for manual" mean? The schedule is push, not manual, right?

  • Frank Malloy Level 2 Level 2 (350 points)
    Currently Being Moderated
    Oct 2, 2012 10:33 AM (in response to superclay)

    Just had the problem again - no push received. I noticed that apsd had NOT crashed, but still not receiving push email notifications.

     

    Did the following:

     

    * Toggle Airplane Mode

     

    * Restart Mail app

     

    * Toggle from Push to Manual and back

     

    Push still did not work. I had to restart the phone.

     

    Again, I am on AT&T.

  • noahs Level 1 Level 1 (15 points)
    Currently Being Moderated
    Oct 2, 2012 11:53 AM (in response to Frank Malloy)

    I can confirm that the problem does not occur for me when I have cellular data turned off and force the phone to use Wi-Fi for push notifications. I've been running it this way for a couple days and have seen no apsd crashes. So if you have consistent Wi-Fi at work, this is at least a temporary workaround.

  • Frank Malloy Level 2 Level 2 (350 points)
    Currently Being Moderated
    Oct 2, 2012 11:59 AM (in response to noahs)

    Thanks. I think we are all in agreement about this - the problem is tied to Exchange push over cellular.

     

    The problem is that turning cellular data off is very limiting. At the office, I can check email on my desktop computer. When I really want to get email notification on the phone is over cellular, when I'm away from the office.

     

    They need to fix this bug. There is no reasonable, consistent workaround.

  • greggabe Calculating status...
    Currently Being Moderated
    Oct 2, 2012 4:19 PM (in response to Frank Malloy)

    Well, I posted over the weekend that mine just started working out of the blue, and of course since then it has stopped working out of the blue and I've now noticed that I'm having the problem with Imessage to that some other have been reporting.  I'm not sure if I was having that problem before and just did not notice it or if it is new, but that is ridiculously frustrating.  I don't know what to do at this point, thought about trying to get a new one, but others have reported that did not work for them and how would I even do that anyways as every store seems to be sold out.  This is massively annoying and Apple dragging their feet on this is not helping.  I guess I just needed to vent, because this is BS.  These phones cost way to much to have basic flaws in the way they handle e-mail and text messaging!

  • sirish19 Calculating status...
    Currently Being Moderated
    Oct 2, 2012 4:40 PM (in response to Frank Malloy)

    Frank, I was having a conflict with the @me.com account so I turned that off and am now using the @icloud.com account.  That did the trick for me.  I informed apple's engineers about this so believe that they should be investigating.  Hope that works for you.

  • Cerina Calculating status...
    Currently Being Moderated
    Oct 2, 2012 8:49 PM (in response to superclay)

    Well I've been reading your posts for days now, trying to figure out my issue.  Similar symptoms - no exchange sync on new iPhone 5 backed up from an iPhone 4S that worked perfectly, Bluetooth failure, etc.  I've tried various changes based on what you have all been writing, waiting impatiently for something to work.  I'm nowhere near as technical as some of you but know a thing or two about "how" these should work.

     

    My phone tried to sync with our exchange server twice on the friday I rec'd it.  I rec'd automated Outlook email notices that my phone was temporarily blocked while the server verifies the validity of "who" is trying to connect, so I ignored the sync failure for 2 days until I then rec'd another automated Outlook email saying my phone has been restricted from syncing with exchange and has been "quaranteened".

     

    So, now I don't really know if any of your suggestions would have worked since our corporate exchange server blocked me from syncing.  I have a ticket in (with corporate telephony help desk) to find out what the deal is, but again, the company issued iPhones AND our personal ones have all worked until now (through 4S).

     

    Between this, the number of docks/ports/accessories/adaptors I need to purchase to upgrade my "30 Pin World", and NONE of the USB ports on my 2011 laptop (PC/work issued) can charge it using the lightning cable... I'm returning it.

     

    My two cents...

  • TongueJedi Calculating status...
    Currently Being Moderated
    Oct 3, 2012 6:34 AM (in response to superclay)

    Had the iPhone 5 since day 1 and push never worked for my corp Exchange.  Been watching this thread and Sirish19 seemed to have done the trick.  My icloud email account was configured for username@mac.com.  I deleted the @mac.com and re-added as username@icloud.com.  So far push has been working for a few hours now. 

     

    I'll let you know if it crashes again, but it's the most hours I had push since day of release.

  • slmk Calculating status...
    Currently Being Moderated
    Oct 3, 2012 6:39 AM (in response to TongueJedi)

    Hello

    Can you post exactly what steps you used to change this in icloud. Also, would this also change my email adresss from me.com to icloud.com.

    Thanks

1 ... 14 15 16 17 18 ... 62 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (19)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.